aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoremaste <emaste@FreeBSD.org>2018-09-27 00:12:12 +0800
committeremaste <emaste@FreeBSD.org>2018-09-27 00:12:12 +0800
commit60279d141a108042caecd4ee9dbbf9e89b2c6d99 (patch)
tree04964e84769ceaf209ed3f5f1261b819bfb55c22
parent3898de35c8dcd17235a542e48d3f63b4a06b9385 (diff)
downloadfreebsd-ports-gnome-60279d141a108042caecd4ee9dbbf9e89b2c6d99.tar.gz
freebsd-ports-gnome-60279d141a108042caecd4ee9dbbf9e89b2c6d99.tar.zst
freebsd-ports-gnome-60279d141a108042caecd4ee9dbbf9e89b2c6d99.zip
Add -znotext to LDFLAGS on i386, for lld
These ports link some non-PIC code, which fails with lld as it defaults to disallowing relocations against read-only segments. For i386 we can just add -znotext unconditionally: for GNU BFD ld it just affirms BFD's existing default. PR: 214864 Approved by: portmgr (lld blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--audio/zinf/Makefile1
-rw-r--r--emulators/mupen64plus-core/Makefile1
-rw-r--r--games/q2pro/Makefile1
-rw-r--r--games/quakeforge/Makefile1
-rw-r--r--lang/clover/Makefile1
-rw-r--r--multimedia/gstreamer-ffmpeg/Makefile1
-rw-r--r--multimedia/libass/Makefile1
7 files changed, 7 insertions, 0 deletions
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index a53ccdacfe5b..5dad8c582556 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -23,6 +23,7 @@ CONFIGURE_ARGS= --enable-ipv6 \
CPPFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -D_WANT_SEMUN
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= ESOUND VORBIS
OPTIONS_DEFAULT=VORBIS
diff --git a/emulators/mupen64plus-core/Makefile b/emulators/mupen64plus-core/Makefile
index 58ae1a4b2a95..56d699c74231 100644
--- a/emulators/mupen64plus-core/Makefile
+++ b/emulators/mupen64plus-core/Makefile
@@ -19,6 +19,7 @@ USE_GL?= yes
USE_SDL?= sdl2
USE_LDCONFIG?= yes
ONLY_FOR_ARCHS= i386 amd64
+LDFLAGS_i386= -Wl,-znotext
OPTFLAGS= #
diff --git a/games/q2pro/Makefile b/games/q2pro/Makefile
index 68bc15ad0ecc..a71089e383f1 100644
--- a/games/q2pro/Makefile
+++ b/games/q2pro/Makefile
@@ -22,6 +22,7 @@ SVN_REV= 142
MAKE_ENV= LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S|${PREFIX}/||}"
LIBDIR= ${PREFIX}/lib/${PORTNAME}
+LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= CLIENT DEDICATED GAME GL SOFT UI
OPTIONS_DEFINE_i386= ASM
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index a1eae860a5d7..4eecacb0ec78 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -34,6 +34,7 @@ CONFIGURE_ARGS= --disable-alsa \
USE_CSTD= gnu89
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
+LDFLAGS_i386= -Wl,-znotext
SUB_FILES= pkg-message
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index f8adadacccbc..bdb119381e5e 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -22,6 +22,7 @@ CONFIGURE_ARGS+= --enable-opencl --enable-opencl-icd --disable-dri \
--disable-egl --disable-gbm --disable-gles2 --disable-glx \
--disable-va --disable-vdpau --disable-xvmc \
--with-gallium-drivers=r600,radeonsi # only supported GPUs
+LDFLAGS_i386= -Wl,-znotext
#MESA_BUILD_WRKSRC= src/util src/compiler src/mesa src/gallium
MESA_INSTALL_WRKSRC= src/gallium/targets/opencl src/gallium/targets/pipe-loader
diff --git a/multimedia/gstreamer-ffmpeg/Makefile b/multimedia/gstreamer-ffmpeg/Makefile
index 50c1d343db92..ac3082ded560 100644
--- a/multimedia/gstreamer-ffmpeg/Makefile
+++ b/multimedia/gstreamer-ffmpeg/Makefile
@@ -27,6 +27,7 @@ USE_LDCONFIG= yes
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
PLIST_SUB= VERSION="${PORTVERSION:R}"
+LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= FFMPEG
FFMPEG_DESC?= Use system ffmpeg instead of internal libav
diff --git a/multimedia/libass/Makefile b/multimedia/libass/Makefile
index 4f46875ca325..7fca5fa8fa43 100644
--- a/multimedia/libass/Makefile
+++ b/multimedia/libass/Makefile
@@ -20,6 +20,7 @@ USES= autoreconf iconv libtool pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= HARFBUZZ
OPTIONS_DEFAULT=HARFBUZZ