aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-11-04 22:49:24 +0800
committervanilla <vanilla@FreeBSD.org>2013-11-04 22:49:24 +0800
commit6345fabcc75dcb80b7947ca00088d9922051aed3 (patch)
treebd20ebeefbea33791e0a298775ba7031782860d0
parent927e225c04fdd67b5445a714ef0d7c18f08fe79c (diff)
downloadfreebsd-ports-gnome-6345fabcc75dcb80b7947ca00088d9922051aed3.tar.gz
freebsd-ports-gnome-6345fabcc75dcb80b7947ca00088d9922051aed3.tar.zst
freebsd-ports-gnome-6345fabcc75dcb80b7947ca00088d9922051aed3.zip
Support STAGEDIR.
-rw-r--r--games/p5-Acme-GuessNumber/Makefile7
-rw-r--r--games/p5-Acme-GuessNumber/pkg-plist5
-rw-r--r--games/p5-Algorithm-Pair-Best/Makefile3
-rw-r--r--games/p5-Algorithm-Pair-Best/pkg-plist3
-rw-r--r--games/p5-Algorithm-Pair-Swiss/Makefile3
-rw-r--r--games/p5-Algorithm-Pair-Swiss/pkg-plist1
-rw-r--r--games/p5-Baseball-Sabermetrics/Makefile3
-rw-r--r--games/p5-Baseball-Sabermetrics/pkg-plist9
-rw-r--r--games/p5-Games-Alak/Makefile3
-rw-r--r--games/p5-Games-Alak/pkg-plist5
-rw-r--r--games/p5-Games-AlphaBeta/Makefile6
-rw-r--r--games/p5-Games-AlphaBeta/pkg-plist10
-rw-r--r--games/p5-Games-GuessWord/Makefile3
-rw-r--r--games/p5-Games-GuessWord/pkg-plist3
-rw-r--r--games/p5-Games-Tournament-RoundRobin/Makefile4
-rw-r--r--games/p5-Games-Tournament-RoundRobin/pkg-plist2
16 files changed, 28 insertions, 42 deletions
diff --git a/games/p5-Acme-GuessNumber/Makefile b/games/p5-Acme-GuessNumber/Makefile
index 8ce6f4549aff..fbd1dcf7e294 100644
--- a/games/p5-Acme-GuessNumber/Makefile
+++ b/games/p5-Acme-GuessNumber/Makefile
@@ -13,12 +13,5 @@ COMMENT= Automatic number guessing game robot
USES= perl5
USE_PERL5= configure
-MAN3= Acme::GuessNumber.3
-PLIST_FILES= %%SITE_PERL%%/Acme/GuessNumber.pm \
- %%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme-GuessNumber/.packlist
-PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme-GuessNumber \
- %%SITE_PERL%%/Acme
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/p5-Acme-GuessNumber/pkg-plist b/games/p5-Acme-GuessNumber/pkg-plist
new file mode 100644
index 000000000000..1a00a516a048
--- /dev/null
+++ b/games/p5-Acme-GuessNumber/pkg-plist
@@ -0,0 +1,5 @@
+%%PERL5_MAN3%%/Acme::GuessNumber.3.gz
+%%SITE_PERL%%/Acme/GuessNumber.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme-GuessNumber/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme-GuessNumber
+@dirrmtry %%SITE_PERL%%/Acme
diff --git a/games/p5-Algorithm-Pair-Best/Makefile b/games/p5-Algorithm-Pair-Best/Makefile
index 3589e9bc89b5..1a3b2d50f893 100644
--- a/games/p5-Algorithm-Pair-Best/Makefile
+++ b/games/p5-Algorithm-Pair-Best/Makefile
@@ -15,7 +15,4 @@ DEPRECATED= Use games/p5-Algorithm-Pair-Best2 instead
USES= perl5
USE_PERL5= configure
-MAN3= Algorithm::Pair::Best.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/p5-Algorithm-Pair-Best/pkg-plist b/games/p5-Algorithm-Pair-Best/pkg-plist
index d1aaf97c6ce3..e27de468ebc4 100644
--- a/games/p5-Algorithm-Pair-Best/pkg-plist
+++ b/games/p5-Algorithm-Pair-Best/pkg-plist
@@ -1,6 +1,7 @@
+%%PERL5_MAN3%%/Algorithm::Pair::Best.3.gz
%%SITE_PERL%%/Algorithm/Pair/Best.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair/Best/.packlist
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair/Best
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair/Best
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
@dirrmtry %%SITE_PERL%%/Algorithm/Pair
diff --git a/games/p5-Algorithm-Pair-Swiss/Makefile b/games/p5-Algorithm-Pair-Swiss/Makefile
index dad56576f057..c5655a97bca7 100644
--- a/games/p5-Algorithm-Pair-Swiss/Makefile
+++ b/games/p5-Algorithm-Pair-Swiss/Makefile
@@ -12,10 +12,7 @@ COMMENT= Generate unique pairings for tournaments
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-MAN3= Algorithm::Pair::Swiss.3
-
USES= perl5
USE_PERL5= modbuild
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/p5-Algorithm-Pair-Swiss/pkg-plist b/games/p5-Algorithm-Pair-Swiss/pkg-plist
index fb2024fb91cb..6a4fa6b6a030 100644
--- a/games/p5-Algorithm-Pair-Swiss/pkg-plist
+++ b/games/p5-Algorithm-Pair-Swiss/pkg-plist
@@ -1,3 +1,4 @@
+%%PERL5_MAN3%%/Algorithm::Pair::Swiss.3.gz
%%SITE_PERL%%/Algorithm/Pair/Swiss.pm
@dirrmtry %%SITE_PERL%%/Algorithm/Pair
@dirrmtry %%SITE_PERL%%/Algorithm
diff --git a/games/p5-Baseball-Sabermetrics/Makefile b/games/p5-Baseball-Sabermetrics/Makefile
index aae3e7e83c37..0cf1bce54c20 100644
--- a/games/p5-Baseball-Sabermetrics/Makefile
+++ b/games/p5-Baseball-Sabermetrics/Makefile
@@ -18,7 +18,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= Baseball::Sabermetrics.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/p5-Baseball-Sabermetrics/pkg-plist b/games/p5-Baseball-Sabermetrics/pkg-plist
index 3ca8dcc66cfb..ccf9cea25174 100644
--- a/games/p5-Baseball-Sabermetrics/pkg-plist
+++ b/games/p5-Baseball-Sabermetrics/pkg-plist
@@ -1,10 +1,11 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Baseball/Sabermetrics/.packlist
+%%PERL5_MAN3%%/Baseball::Sabermetrics.3.gz
%%SITE_PERL%%/Baseball/Sabermetrics.pm
+%%SITE_PERL%%/Baseball/Sabermetrics/League/CPB2.pm
+%%SITE_PERL%%/Baseball/Sabermetrics/League/CPBL.pm
+%%SITE_PERL%%/Baseball/Sabermetrics/Player.pm
%%SITE_PERL%%/Baseball/Sabermetrics/Team.pm
%%SITE_PERL%%/Baseball/Sabermetrics/abstract.pm
-%%SITE_PERL%%/Baseball/Sabermetrics/Player.pm
-%%SITE_PERL%%/Baseball/Sabermetrics/League/CPBL.pm
-%%SITE_PERL%%/Baseball/Sabermetrics/League/CPB2.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Baseball/Sabermetrics/.packlist
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Baseball/Sabermetrics
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Baseball
@dirrmtry %%SITE_PERL%%/Baseball/Sabermetrics/League
diff --git a/games/p5-Games-Alak/Makefile b/games/p5-Games-Alak/Makefile
index 1a6f44bc4af1..8a36bc81485a 100644
--- a/games/p5-Games-Alak/Makefile
+++ b/games/p5-Games-Alak/Makefile
@@ -16,9 +16,6 @@ TEST_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
USES= perl5
USE_PERL5= configure
-MAN3= Games::Alak.3
-
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e "s,^build_.*,,g" ${WRKSRC}/Makefile.PL
diff --git a/games/p5-Games-Alak/pkg-plist b/games/p5-Games-Alak/pkg-plist
index 50a7ac3d9bc7..f87c7f7e77b7 100644
--- a/games/p5-Games-Alak/pkg-plist
+++ b/games/p5-Games-Alak/pkg-plist
@@ -1,5 +1,6 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Alak/.packlist
+%%PERL5_MAN3%%/Games::Alak.3.gz
%%SITE_PERL%%/Games/Alak.pm
-@dirrmtry %%SITE_PERL%%/Games
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Alak/.packlist
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Alak
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games
+@dirrmtry %%SITE_PERL%%/Games
diff --git a/games/p5-Games-AlphaBeta/Makefile b/games/p5-Games-AlphaBeta/Makefile
index c6037c001de9..da1b03380a1b 100644
--- a/games/p5-Games-AlphaBeta/Makefile
+++ b/games/p5-Games-AlphaBeta/Makefile
@@ -14,10 +14,4 @@ COMMENT= Game-tree search with object oriented interface
USES= perl5
USE_PERL5= modbuild
-MAN1= othello-demo.1
-MAN3= Games::AlphaBeta.3 Games::AlphaBeta::Position.3 \
- Games::AlphaBeta::Reversi.3 \
- Games::Sequential.3 Games::Sequential::Position.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/p5-Games-AlphaBeta/pkg-plist b/games/p5-Games-AlphaBeta/pkg-plist
index 39f67e72aa02..5637c9234ae3 100644
--- a/games/p5-Games-AlphaBeta/pkg-plist
+++ b/games/p5-Games-AlphaBeta/pkg-plist
@@ -1,9 +1,15 @@
bin/othello-demo
+%%PERL5_MAN3%%/Games::AlphaBeta.3.gz
+%%PERL5_MAN3%%/Games::AlphaBeta::Position.3.gz
+%%PERL5_MAN3%%/Games::AlphaBeta::Reversi.3.gz
+%%PERL5_MAN3%%/Games::Sequential.3.gz
+%%PERL5_MAN3%%/Games::Sequential::Position.3.gz
%%SITE_PERL%%/Games/AlphaBeta.pm
%%SITE_PERL%%/Games/AlphaBeta/Position.pm
%%SITE_PERL%%/Games/AlphaBeta/Reversi.pm
%%SITE_PERL%%/Games/Sequential.pm
%%SITE_PERL%%/Games/Sequential/Position.pm
-@dirrm %%SITE_PERL%%/Games/AlphaBeta
-@dirrm %%SITE_PERL%%/Games/Sequential
+man/man1/othello-demo.1.gz
+@dirrmtry %%SITE_PERL%%/Games/Sequential
+@dirrmtry %%SITE_PERL%%/Games/AlphaBeta
@dirrmtry %%SITE_PERL%%/Games
diff --git a/games/p5-Games-GuessWord/Makefile b/games/p5-Games-GuessWord/Makefile
index 8198a49a5bf2..727c52cb9eb1 100644
--- a/games/p5-Games-GuessWord/Makefile
+++ b/games/p5-Games-GuessWord/Makefile
@@ -10,10 +10,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Guess the letters in a word (ie Hangman)
-MAN3= Games::GuessWord.3
-
USES= perl5
USE_PERL5= configure
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/p5-Games-GuessWord/pkg-plist b/games/p5-Games-GuessWord/pkg-plist
index e9c3ef3303ab..4d6fe36e8258 100644
--- a/games/p5-Games-GuessWord/pkg-plist
+++ b/games/p5-Games-GuessWord/pkg-plist
@@ -1,5 +1,6 @@
+%%PERL5_MAN3%%/Games::GuessWord.3.gz
%%SITE_PERL%%/Games/GuessWord.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/GuessWord/.packlist
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/GuessWord
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/GuessWord
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games
@dirrmtry %%SITE_PERL%%/Games
diff --git a/games/p5-Games-Tournament-RoundRobin/Makefile b/games/p5-Games-Tournament-RoundRobin/Makefile
index 6ce851956fee..7d5ea757d12e 100644
--- a/games/p5-Games-Tournament-RoundRobin/Makefile
+++ b/games/p5-Games-Tournament-RoundRobin/Makefile
@@ -10,11 +10,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Round-Robin Tournament Schedule Pairings
-MAN3= Games::Tournament::RoundRobin.3 \
- Games::League::Member.3
-
USES= perl5
USE_PERL5= configure
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/p5-Games-Tournament-RoundRobin/pkg-plist b/games/p5-Games-Tournament-RoundRobin/pkg-plist
index 9a7c16ff014f..560e3f85094f 100644
--- a/games/p5-Games-Tournament-RoundRobin/pkg-plist
+++ b/games/p5-Games-Tournament-RoundRobin/pkg-plist
@@ -1,3 +1,5 @@
+%%PERL5_MAN3%%/Games::League::Member.3.gz
+%%PERL5_MAN3%%/Games::Tournament::RoundRobin.3.gz
%%SITE_PERL%%/Games/League/Member.pm
%%SITE_PERL%%/Games/Tournament/RoundRobin.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Tournament/RoundRobin/.packlist