aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-30 03:26:52 +0800
committermnag <mnag@FreeBSD.org>2005-10-30 03:26:52 +0800
commit65b6e334a0a36aee25e24cad29e7893236ff180b (patch)
tree1d47cd59b0c35d8b38a97021766ce1a3063a8ecd
parentc6bef774ff2b880526ab8f6f48d8c06fadd77129 (diff)
downloadfreebsd-ports-gnome-65b6e334a0a36aee25e24cad29e7893236ff180b.tar.gz
freebsd-ports-gnome-65b6e334a0a36aee25e24cad29e7893236ff180b.tar.zst
freebsd-ports-gnome-65b6e334a0a36aee25e24cad29e7893236ff180b.zip
Respect LOCALBASE/X11BASE
PR: 88149 Notified by: kris Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe> (maintainer)
-rw-r--r--audio/py-sdl_mixer/Makefile4
-rw-r--r--audio/py-sdl_mixer/files/patch-setup.py19
2 files changed, 23 insertions, 0 deletions
diff --git a/audio/py-sdl_mixer/Makefile b/audio/py-sdl_mixer/Makefile
index 5615c3dfc024..ca977e9eac89 100644
--- a/audio/py-sdl_mixer/Makefile
+++ b/audio/py-sdl_mixer/Makefile
@@ -30,6 +30,10 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-sdl-mixer
post-patch:
@${REINPLACE_CMD} -e 's,"SDL","SDL-1.1",g' ${WRKSRC}/setup.py
@${REINPLACE_CMD} -e 's,SDL/SDL,SDL11/SDL,g' ${WRKSRC}/sdl_mixer.c
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/setup.py
post-install:
.if !defined(NOPORTDOCS)
diff --git a/audio/py-sdl_mixer/files/patch-setup.py b/audio/py-sdl_mixer/files/patch-setup.py
new file mode 100644
index 000000000000..2825bbe40d53
--- /dev/null
+++ b/audio/py-sdl_mixer/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py.orig Fri Oct 28 00:13:10 2005
++++ setup.py Fri Oct 28 00:14:18 2005
+@@ -17,12 +17,14 @@
+
+ INCDIR = [
+ "/usr/include",
+- "/usr/local/include",
++ "%%LOCALBASE%%/include",
++ "%%X11BASE%%/include",
+ "/sw/include", # For Mac OS X
+ ]
+ LIBDIR = [
+ "/usr/lib",
+- "/usr/local/lib",
++ "%%LOCALBASE%%/lib",
++ "%%X11BASE%%/lib",
+ "/sw/lib/", # For Mac OS X
+ ]
+