aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-10-30 10:35:38 +0800
committernork <nork@FreeBSD.org>2003-10-30 10:35:38 +0800
commit66e96c2b87692647bb58b8d1ba3dad702fee03c8 (patch)
tree3e9877b6ec3dd36010d2a301a5653e7f75848503
parent7c5644f1f65943915ffc6618953f06cb63093027 (diff)
downloadfreebsd-ports-gnome-66e96c2b87692647bb58b8d1ba3dad702fee03c8.tar.gz
freebsd-ports-gnome-66e96c2b87692647bb58b8d1ba3dad702fee03c8.tar.zst
freebsd-ports-gnome-66e96c2b87692647bb58b8d1ba3dad702fee03c8.zip
Add quack 0.22, enhanced Emacs support for editing and
running Scheme programming. PR: ports/58471 Submitted by: Kimura Fuyuki <fuyuki@nigredo.org>
-rw-r--r--lang/Makefile1
-rw-r--r--lang/quack/Makefile40
-rw-r--r--lang/quack/distinfo1
-rw-r--r--lang/quack/pkg-descr5
-rw-r--r--lang/quack/pkg-message3
-rw-r--r--lang/quack/pkg-plist3
6 files changed, 53 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 1a9370c97183..84735f4f2e88 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -184,6 +184,7 @@
SUBDIR += python21
SUBDIR += python22
SUBDIR += qscheme
+ SUBDIR += quack
SUBDIR += ratfor
SUBDIR += rexx-imc
SUBDIR += rscheme
diff --git a/lang/quack/Makefile b/lang/quack/Makefile
new file mode 100644
index 000000000000..efbfc30a3754
--- /dev/null
+++ b/lang/quack/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Quack
+# Date created: 24 October 2003
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quack
+PORTVERSION= 0.22
+CATEGORIES= lang scheme elisp
+MASTER_SITES= http://www.neilvandyke.org/quack/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .el
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= Enhanced support for editing and running Scheme code
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
+EMACS_PORT_NAME?= emacs21
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+
+ELISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+
+do-build:
+ cd ${WRKSRC}; ${EMACS_CMD} -batch -q -f batch-byte-compile quack.el
+
+do-install:
+ ${MKDIR} ${ELISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/quack.* ${ELISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/lang/quack/distinfo b/lang/quack/distinfo
new file mode 100644
index 000000000000..24942af733f9
--- /dev/null
+++ b/lang/quack/distinfo
@@ -0,0 +1 @@
+MD5 (quack-0.22/quack.el) = 36b309ead5f80b5a650c7fbe81aa8d54
diff --git a/lang/quack/pkg-descr b/lang/quack/pkg-descr
new file mode 100644
index 000000000000..95d1ca231dab
--- /dev/null
+++ b/lang/quack/pkg-descr
@@ -0,0 +1,5 @@
+Quack enhances Emacs support for Scheme programming. Quack is layered
+atop the standard packages `cmuscheme.el', by Olin Shivers, and
+`scheme.el', by Bill Rozas and Dave Love.
+
+WWW: http://www.neilvandyke.org/quack/
diff --git a/lang/quack/pkg-message b/lang/quack/pkg-message
new file mode 100644
index 000000000000..76d261bfe023
--- /dev/null
+++ b/lang/quack/pkg-message
@@ -0,0 +1,3 @@
+To use Quack, add the following line to your ~/.emacs:
+
+(require 'quack)
diff --git a/lang/quack/pkg-plist b/lang/quack/pkg-plist
new file mode 100644
index 000000000000..65174c5f9e1d
--- /dev/null
+++ b/lang/quack/pkg-plist
@@ -0,0 +1,3 @@
+%%EMACS_VERSION_SITE_LISPDIR%%/quack/quack.el
+%%EMACS_VERSION_SITE_LISPDIR%%/quack/quack.elc
+@dirrm %%EMACS_VERSION_SITE_LISPDIR%%/quack