aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-10-04 22:00:02 +0800
committerhq <hq@FreeBSD.org>2005-10-04 22:00:02 +0800
commit68cfbdf6767e1e91a2f7468947d95099d425a88d (patch)
treea516afe3cabd5f42e139c300e6679f90bed0a812
parent8e7deeb14769a3f54d8b100fb325c69728ce28d4 (diff)
downloadfreebsd-ports-gnome-68cfbdf6767e1e91a2f7468947d95099d425a88d.tar.gz
freebsd-ports-gnome-68cfbdf6767e1e91a2f7468947d95099d425a88d.tar.zst
freebsd-ports-gnome-68cfbdf6767e1e91a2f7468947d95099d425a88d.zip
The Portlet API (JSR-168)
To enable interoperability between Portlets and Portals, this specification defines a set of APIs for Portal computing addressing the areas of aggregation, personalization, presentation and security. WWW: http://www.jcp.org/en/jsr/detail?id=168/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/portlet-api/Makefile27
-rw-r--r--devel/portlet-api/distinfo2
-rw-r--r--devel/portlet-api/pkg-descr7
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 972261044fc9..661c1f926c3f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1309,6 +1309,7 @@
SUBDIR += pmk
SUBDIR += popt
SUBDIR += portcheckout
+ SUBDIR += portlet-api
SUBDIR += portlint
SUBDIR += portmk
SUBDIR += porttools
diff --git a/devel/portlet-api/Makefile b/devel/portlet-api/Makefile
new file mode 100644
index 000000000000..31eefd8f9438
--- /dev/null
+++ b/devel/portlet-api/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Portlet API
+# Date created: October 04, 2005
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= portlet-api
+PORTVERSION= 1.0
+CATEGORIES= devel java
+MASTER_SITES= http://www.ibiblio.org/maven/portlet-api/jars/
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY= # empty
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= The Portlet API (JSR-168)
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+do-install:
+ ${INSTALL_DATA} ${_DISTDIR}/${DISTFILES} ${JAVAJARDIR}/${PORTNAME}.jar
+
+.include <bsd.port.mk>
diff --git a/devel/portlet-api/distinfo b/devel/portlet-api/distinfo
new file mode 100644
index 000000000000..33be684ee3e4
--- /dev/null
+++ b/devel/portlet-api/distinfo
@@ -0,0 +1,2 @@
+MD5 (portlet-api-1.0.jar) = 74e40817096d9d72963eaa143bdebd32
+SIZE (portlet-api-1.0.jar) = 17090
diff --git a/devel/portlet-api/pkg-descr b/devel/portlet-api/pkg-descr
new file mode 100644
index 000000000000..3743ca837fd9
--- /dev/null
+++ b/devel/portlet-api/pkg-descr
@@ -0,0 +1,7 @@
+The Portlet API (JSR-168)
+
+To enable interoperability between Portlets and Portals, this specification
+defines a set of APIs for Portal computing addressing the areas of aggregation,
+personalization, presentation and security.
+
+WWW: http://www.jcp.org/en/jsr/detail?id=168/