aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-09-19 05:43:47 +0800
committerswills <swills@FreeBSD.org>2016-09-19 05:43:47 +0800
commit6bb0863efbff1af4147c76e9b05494d262e9c0ba (patch)
tree5677b8c48c7131a91b80b775936512bb0e231b1a
parent3bb4bfbba6ca494122d58548cc6c3ff84b9f9e6b (diff)
downloadfreebsd-ports-gnome-6bb0863efbff1af4147c76e9b05494d262e9c0ba.tar.gz
freebsd-ports-gnome-6bb0863efbff1af4147c76e9b05494d262e9c0ba.tar.zst
freebsd-ports-gnome-6bb0863efbff1af4147c76e9b05494d262e9c0ba.zip
databases/ruby-bdb: fix rdoc parse issue
While here, fix a stage permission issue with the docs
-rw-r--r--databases/ruby-bdb/Makefile6
-rw-r--r--databases/ruby-bdb/files/patch-docs_hashlike.rd26
2 files changed, 31 insertions, 1 deletions
diff --git a/databases/ruby-bdb/Makefile b/databases/ruby-bdb/Makefile
index dd0508f4003c..38b5f8337849 100644
--- a/databases/ruby-bdb/Makefile
+++ b/databases/ruby-bdb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bdb
PORTVERSION= 0.6.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= databases ruby
MASTER_SITES= ftp://ftp.idaemons.org/pub/distfiles/ruby/ \
http://idaemons.org/distfiles/ruby/ \
@@ -30,6 +30,7 @@ INSTALL_TARGET= site-install
DOCS= Changes README.en bdb.rd docs/*.rd
DOCSDIR= ${RUBY_MODDOCDIR}
EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
+SHAREMODE= 0644
PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/bdb.so
PORTDOCS= *
PORTEXAMPLES= *
@@ -69,6 +70,9 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-common.c-22 \
${FILESDIR}/extra-patch-src-cursor.c-22
.endif
+post-patch:
+ @${RM} ${WRKSRC}/docs/*.orig
+
post-build:
(cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} rdoc)
diff --git a/databases/ruby-bdb/files/patch-docs_hashlike.rd b/databases/ruby-bdb/files/patch-docs_hashlike.rd
new file mode 100644
index 000000000000..a0de0db31d4f
--- /dev/null
+++ b/databases/ruby-bdb/files/patch-docs_hashlike.rd
@@ -0,0 +1,26 @@
+--- docs/hashlike.rd.orig 2011-04-06 19:35:39 UTC
++++ docs/hashlike.rd
+@@ -342,7 +342,6 @@ These are the common methods for ((|BDB:
+ --- each(set = nil, bulk = 0, "flags" => 0) { |key, value| ... }
+ --- each_pair(set = nil, bulk = 0) { |key, value| ... }
+ Iterates over associations.
+-
+ ((<set>)) ((<bulk>))
+
+ --- each_by_prefix(prefix) {|key, value| ... }
+@@ -360,7 +359,6 @@ These are the common methods for ((|BDB:
+
+ --- each_key(set = nil, bulk = 0) { |key| ... }
+ Iterates over keys.
+-
+ ((<set>)) ((<bulk>))
+
+ --- each_primary(set = nil) { |skey, pkey, pvalue| ... }
+@@ -369,7 +367,6 @@ These are the common methods for ((|BDB:
+
+ --- each_value(set = nil, bulk = 0) { |value| ... }
+ Iterates over values.
+-
+ ((<set>)) ((<bulk>))
+
+ --- empty?()