aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-04-03 06:14:12 +0800
committerbapt <bapt@FreeBSD.org>2017-04-03 06:14:12 +0800
commit6c0852aaacf24dd5486b13a04d66bb1faa0b40af (patch)
tree15b37b28b8012b4a70eeaa49bbd3385d6c06a9c4
parenta68e81ee66f009baab4f79121c075a05def9f4bd (diff)
downloadfreebsd-ports-gnome-6c0852aaacf24dd5486b13a04d66bb1faa0b40af.tar.gz
freebsd-ports-gnome-6c0852aaacf24dd5486b13a04d66bb1faa0b40af.tar.zst
freebsd-ports-gnome-6c0852aaacf24dd5486b13a04d66bb1faa0b40af.zip
Fix build with recent sigc++20
-rw-r--r--devel/gconfmm26/Makefile4
-rw-r--r--devel/synfig/Makefile3
-rw-r--r--multimedia/gstreamermm/Makefile3
-rw-r--r--x11-toolkits/gtksourceviewmm3/Makefile3
4 files changed, 9 insertions, 4 deletions
diff --git a/devel/gconfmm26/Makefile b/devel/gconfmm26/Makefile
index 45536571583c..7816560d93b5 100644
--- a/devel/gconfmm26/Makefile
+++ b/devel/gconfmm26/Makefile
@@ -16,7 +16,9 @@ LIB_DEPENDS= libglibmm-2.4.so:devel/glibmm
BUILD_DEPENDS= gm4:devel/m4 \
${LOCALBASE}/lib/libgtkmm-2.4.so.1:x11-toolkits/gtkmm24
-USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
+USES= compiler:c++11-lang gmake libtool:keepla pathfix pkgconfig \
+ tar:bzip2
+USE_CXXSTD= c++11
USE_XORG= x11
USE_GNOME= gconf2 referencehack
GNU_CONFIGURE= yes
diff --git a/devel/synfig/Makefile b/devel/synfig/Makefile
index 247172b623df..b787780b3bf5 100644
--- a/devel/synfig/Makefile
+++ b/devel/synfig/Makefile
@@ -24,7 +24,8 @@ LIB_DEPENDS= libboost_program_options.so:devel/boost-libs \
libavcodec.so:multimedia/ffmpeg \
libdv.so:multimedia/libdv
-USES= iconv jpeg libtool pathfix pkgconfig
+USES= compiler:c++11-lang iconv jpeg libtool pathfix pkgconfig
+USE_CXXSTD= c++11
USE_GNOME= cairo glibmm libxml++26
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG}
diff --git a/multimedia/gstreamermm/Makefile b/multimedia/gstreamermm/Makefile
index 4d57b790af5f..4f7c2e7f0ef5 100644
--- a/multimedia/gstreamermm/Makefile
+++ b/multimedia/gstreamermm/Makefile
@@ -13,7 +13,8 @@ COMMENT= C++ wrapper library for the multimedia library GStreamer
LICENSE= LGPL21
-USES= gmake libtool pathfix pkgconfig tar:xz
+USES= compiler:c++11-lang gmake libtool pathfix pkgconfig tar:xz
+USE_CXXSTD= c++11
USE_GSTREAMER= theora vorbis cdparanoia gio pango
USE_GNOME= gnomeprefix gtkmm24
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/gtksourceviewmm3/Makefile b/x11-toolkits/gtksourceviewmm3/Makefile
index faae9115da94..3a9508d382a0 100644
--- a/x11-toolkits/gtksourceviewmm3/Makefile
+++ b/x11-toolkits/gtksourceviewmm3/Makefile
@@ -14,7 +14,8 @@ COMMENT= C++ binding of GtkSourceView3
PORTSCOUT= limitw:1,even
-USES= gmake libtool:keepla pathfix pkgconfig tar:xz
+USES= compiler:c++11-lang gmake libtool:keepla pathfix pkgconfig tar:xz
+USE_CXXSTD= c++11
USE_LDCONFIG= yes
USE_GNOME= gtksourceview3 gnomeprefix gtkmm30
GNU_CONFIGURE= yes