aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2016-10-04 22:32:16 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2016-10-04 22:32:16 +0800
commit6d323683f31ae85b56653178584426e769398198 (patch)
tree795cfbc8f225d95686306391e8cd5f1c3f4db097
parent7aef47d873a3434c00b680c908ecb6d8072a807f (diff)
downloadfreebsd-ports-gnome-6d323683f31ae85b56653178584426e769398198.tar.gz
freebsd-ports-gnome-6d323683f31ae85b56653178584426e769398198.tar.zst
freebsd-ports-gnome-6d323683f31ae85b56653178584426e769398198.zip
Add new port security/kdbx-viewer
kdbx-viewer provides an ncurses GUI and command-line tool for KeePass2 Database files. Reviewed by: mat (mentor) Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D8033
-rw-r--r--security/Makefile1
-rw-r--r--security/kdbx-viewer/Makefile35
-rw-r--r--security/kdbx-viewer/distinfo3
-rw-r--r--security/kdbx-viewer/pkg-descr10
4 files changed, 49 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b0926a74ec5e..fab447877373 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -273,6 +273,7 @@
SUBDIR += keychain
SUBDIR += keynote
SUBDIR += keyprint
+ SUBDIR += kdbx-viewer
SUBDIR += kgpg-kde4
SUBDIR += knock
SUBDIR += knocker
diff --git a/security/kdbx-viewer/Makefile b/security/kdbx-viewer/Makefile
new file mode 100644
index 000000000000..dc7be9cf21dc
--- /dev/null
+++ b/security/kdbx-viewer/Makefile
@@ -0,0 +1,35 @@
+# Created by: Ben Woods <woodsb02@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= kdbx-viewer
+PORTVERSION= 0.0.1
+DISTVERSIONPREFIX=v
+CATEGORIES= security
+
+MAINTAINER= woodsb02@FreeBSD.org
+COMMENT= ncurses GUI and command-line tool for KeePass2 Database files
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libgcrypt.so:security/libgcrypt \
+ libstfl.so:devel/stfl
+
+USE_GITHUB= yes
+GH_ACCOUNT= max-weller
+
+USES= ncurses
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_FILES= bin/kdbxviewer
+ALL_TARGET=
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|gcc|${CC} ${CFLAGS} ${LDFLAGS}|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/kdbxviewer ${STAGEDIR}${PREFIX}/bin/
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/kdbxviewer
+
+.include <bsd.port.mk>
diff --git a/security/kdbx-viewer/distinfo b/security/kdbx-viewer/distinfo
new file mode 100644
index 000000000000..789bb22447f9
--- /dev/null
+++ b/security/kdbx-viewer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475588279
+SHA256 (max-weller-kdbx-viewer-v0.0.1_GH0.tar.gz) = 9898385de015dc24fbe7137683c42a171438354312d05aec5a6d9e50ab6ebb9b
+SIZE (max-weller-kdbx-viewer-v0.0.1_GH0.tar.gz) = 142777
diff --git a/security/kdbx-viewer/pkg-descr b/security/kdbx-viewer/pkg-descr
new file mode 100644
index 000000000000..b098530d1e38
--- /dev/null
+++ b/security/kdbx-viewer/pkg-descr
@@ -0,0 +1,10 @@
+Command-line tool written in C for KeePass2 Database files (kdbx).
+It works completely read-only at the moment.
+
+Features:
+- ncurses GUI to browse and view password database
+- Dump raw, decrypted XML content with obscured passwords
+- Display tree structure with de-obscured (=readable) passwords
+- Get tab-separated (TSV/CSV) password list
+
+WWW: https://max-weller.github.io/kdbx-viewer/