aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-01-10 02:36:48 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-01-10 02:36:48 +0800
commit6ed09be3865048dc35030e512a5f40db34c3bc17 (patch)
treec0213e14bab7e002c78b8e83651a7112122e0787
parent833f88101162a7fbdc57542d75f6943e09c0f5b8 (diff)
downloadfreebsd-ports-gnome-6ed09be3865048dc35030e512a5f40db34c3bc17.tar.gz
freebsd-ports-gnome-6ed09be3865048dc35030e512a5f40db34c3bc17.tar.zst
freebsd-ports-gnome-6ed09be3865048dc35030e512a5f40db34c3bc17.zip
Add rubygem-actioncable5 5.0.1
Action Cable – Integrated WebSockets for Rails Action Cable seamlessly integrates WebSockets with the rest of your Rails application. It allows for real-time features to be written in Ruby in the same style and form as the rest of your Rails application, while still being performant and scalable. It's a full-stack offering that provides both a client-side JavaScript framework and a server-side Ruby framework. You have access to your full domain model written with Active Record or your ORM of choice. WWW: http://rubyonrails.org/
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-actioncable5/Makefile24
-rw-r--r--www/rubygem-actioncable5/distinfo3
-rw-r--r--www/rubygem-actioncable5/pkg-descr11
4 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index aa757717dbc4..1d39382032a6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1904,6 +1904,7 @@
SUBDIR += ruby-aws
SUBDIR += ruby-google
SUBDIR += rubygem-ace-rails-ap
+ SUBDIR += rubygem-actioncable5
SUBDIR += rubygem-actionpack4
SUBDIR += rubygem-actionpack5
SUBDIR += rubygem-activeresource4
diff --git a/www/rubygem-actioncable5/Makefile b/www/rubygem-actioncable5/Makefile
new file mode 100644
index 000000000000..4314da009beb
--- /dev/null
+++ b/www/rubygem-actioncable5/Makefile
@@ -0,0 +1,24 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= actioncable
+PORTVERSION= 5.0.1
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 5
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Integrated WebSockets for Rails
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack5>=${PORTVERSION}:www/rubygem-actionpack5 \
+ rubygem-nio4r1>=1.2:devel/rubygem-nio4r1 \
+ rubygem-websocket-driver>=0.6.1:www/rubygem-websocket-driver
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-actioncable5/distinfo b/www/rubygem-actioncable5/distinfo
new file mode 100644
index 000000000000..084e56b95cc5
--- /dev/null
+++ b/www/rubygem-actioncable5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483834937
+SHA256 (rubygem/actioncable-5.0.1.gem) = a7ddffa73c581f9f1369a8d9048171036ba46cf7c410057c5cf944ac90dfbe00
+SIZE (rubygem/actioncable-5.0.1.gem) = 42496
diff --git a/www/rubygem-actioncable5/pkg-descr b/www/rubygem-actioncable5/pkg-descr
new file mode 100644
index 000000000000..22f58d2222cf
--- /dev/null
+++ b/www/rubygem-actioncable5/pkg-descr
@@ -0,0 +1,11 @@
+Action Cable – Integrated WebSockets for Rails
+
+Action Cable seamlessly integrates WebSockets with the rest of your Rails
+application. It allows for real-time features to be written in Ruby in the same
+style and form as the rest of your Rails application, while still being
+performant and scalable. It's a full-stack offering that provides both a
+client-side JavaScript framework and a server-side Ruby framework. You have
+access to your full domain model written with Active Record or your ORM of
+choice.
+
+WWW: http://rubyonrails.org/