aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenner <fenner@FreeBSD.org>2005-10-18 11:51:52 +0800
committerfenner <fenner@FreeBSD.org>2005-10-18 11:51:52 +0800
commit71918f54f11b939f25060b6644ac518dcd03edf0 (patch)
tree307039615809e97ae7a09068a4730f4156bccb18
parentc1f999d563509e30b56b947ab4ecb4572105d606 (diff)
downloadfreebsd-ports-gnome-71918f54f11b939f25060b6644ac518dcd03edf0.tar.gz
freebsd-ports-gnome-71918f54f11b939f25060b6644ac518dcd03edf0.tar.zst
freebsd-ports-gnome-71918f54f11b939f25060b6644ac518dcd03edf0.zip
Use groups to use the right subdirectory for the right MASTER_SITE.
Approved by: obrien (MAINTAINER)
-rw-r--r--devel/gdb6/Makefile6
-rw-r--r--devel/gdb66/Makefile6
2 files changed, 8 insertions, 4 deletions
diff --git a/devel/gdb6/Makefile b/devel/gdb6/Makefile
index b0f5af3773b7..3661fd64032b 100644
--- a/devel/gdb6/Makefile
+++ b/devel/gdb6/Makefile
@@ -13,9 +13,11 @@ PORTNAME= gdb
PORTVERSION= 6
PORTREVISION= ${SNAPVER}
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEWARE} ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= gdb/snapshots/current obrien
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE:S/$/:sw/} \
+ ${MASTER_SITE_LOCAL:S/$/:local/}
+MASTER_SITE_SUBDIR= gdb/snapshots/current/:sw obrien/:local
DISTNAME= gdb+dejagnu-weekly-${SNAPVER}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:sw,local
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= obrien
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index b0f5af3773b7..3661fd64032b 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -13,9 +13,11 @@ PORTNAME= gdb
PORTVERSION= 6
PORTREVISION= ${SNAPVER}
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEWARE} ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= gdb/snapshots/current obrien
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE:S/$/:sw/} \
+ ${MASTER_SITE_LOCAL:S/$/:local/}
+MASTER_SITE_SUBDIR= gdb/snapshots/current/:sw obrien/:local
DISTNAME= gdb+dejagnu-weekly-${SNAPVER}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:sw,local
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= obrien