aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-04-13 19:06:27 +0800
committerdanfe <danfe@FreeBSD.org>2015-04-13 19:06:27 +0800
commit7611d167732e94046b0f449310ee5ce49cce658e (patch)
tree1fc4afe25c3f90457652a3d42916da1f871f5f02
parentdbc8eb7d22d95c95de53f4c705e21c987d68790c (diff)
downloadfreebsd-ports-gnome-7611d167732e94046b0f449310ee5ce49cce658e.tar.gz
freebsd-ports-gnome-7611d167732e94046b0f449310ee5ce49cce658e.tar.zst
freebsd-ports-gnome-7611d167732e94046b0f449310ee5ce49cce658e.zip
Add a port of watchman, file alteration monitor from Facebook.
WWW: https://facebook.github.io/watchman/ PR: 199061
-rw-r--r--sysutils/Makefile3
-rw-r--r--sysutils/watchman/Makefile36
-rw-r--r--sysutils/watchman/distinfo2
-rw-r--r--sysutils/watchman/pkg-descr4
4 files changed, 44 insertions, 1 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 887458423a7f..c0d184954024 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1030,10 +1030,11 @@
SUBDIR += vpnc-scripts
SUBDIR += vstrip
SUBDIR += vttest
- SUBDIR += warden
SUBDIR += wait_on
+ SUBDIR += warden
SUBDIR += watchdog
SUBDIR += watchfolder
+ SUBDIR += watchman
SUBDIR += watchmen
SUBDIR += webjob
SUBDIR += webmin
diff --git a/sysutils/watchman/Makefile b/sysutils/watchman/Makefile
new file mode 100644
index 000000000000..821297349af3
--- /dev/null
+++ b/sysutils/watchman/Makefile
@@ -0,0 +1,36 @@
+# Created by: Jin-Sih, Lin <linpct@gmail.com>
+# $FreeBSD$
+
+PORTNAME= watchman
+PORTVERSION= 3.0.0
+CATEGORIES= sysutils
+
+MAINTAINER= linpct@gmail.com
+COMMENT= File alteration monitoring service
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+
+USE_GITHUB= yes
+GH_ACCOUNT= facebook
+GH_TAGNAME= v${PORTVERSION}
+
+USES= autoreconf gmake pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pcre
+
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --disable-silent-rules
+.endif
+
+CPPFLAGS+= -I${LOCALBASE}/include
+
+PLIST_FILES= bin/watchman
+PORTDOCS= README.markdown
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^docdir = /d' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/timestamp=/s,%ld,%d,' ${WRKSRC}/root.c
+
+.include <bsd.port.mk>
diff --git a/sysutils/watchman/distinfo b/sysutils/watchman/distinfo
new file mode 100644
index 000000000000..60beecb56ea4
--- /dev/null
+++ b/sysutils/watchman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (facebook-watchman-3.0.0-v3.0.0_GH0.tar.gz) = 9481c801b848acaa2783e511faaeae8d276e624e2703bd53f4e33cc9d0c0f12f
+SIZE (facebook-watchman-3.0.0-v3.0.0_GH0.tar.gz) = 199034
diff --git a/sysutils/watchman/pkg-descr b/sysutils/watchman/pkg-descr
new file mode 100644
index 000000000000..280929f78d46
--- /dev/null
+++ b/sysutils/watchman/pkg-descr
@@ -0,0 +1,4 @@
+Watchman exists to watch files and record when they change. It can also
+trigger actions (such as rebuilding assets) when matching files change.
+
+WWW: https://facebook.github.io/watchman/