aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2017-02-01 19:32:51 +0800
committerolgeni <olgeni@FreeBSD.org>2017-02-01 19:32:51 +0800
commit762648e6f1d05eb601d15b81ee48afb975bc1180 (patch)
tree00ada68292cffb717a4df873b7f1d704002a2793
parentd152c1fc6b32565d49a3621ca103d3acd87231ec (diff)
downloadfreebsd-ports-gnome-762648e6f1d05eb601d15b81ee48afb975bc1180.tar.gz
freebsd-ports-gnome-762648e6f1d05eb601d15b81ee48afb975bc1180.tar.zst
freebsd-ports-gnome-762648e6f1d05eb601d15b81ee48afb975bc1180.zip
lang/erlang-runtime16: fix build with clang 4.0.
PR: 216615 Submitted by: Jan Beich
-rw-r--r--lang/erlang-runtime16/Makefile2
-rw-r--r--lang/erlang-runtime16/files/patch-lib_wx_c__src_wxe__impl.cpp20
2 files changed, 21 insertions, 1 deletions
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index cd642d31558f..d9e8de741928 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -3,7 +3,7 @@
PORTNAME= erlang
PORTVERSION= 16.b.03.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
diff --git a/lang/erlang-runtime16/files/patch-lib_wx_c__src_wxe__impl.cpp b/lang/erlang-runtime16/files/patch-lib_wx_c__src_wxe__impl.cpp
new file mode 100644
index 000000000000..5b1e66586f2f
--- /dev/null
+++ b/lang/erlang-runtime16/files/patch-lib_wx_c__src_wxe__impl.cpp
@@ -0,0 +1,20 @@
+--- lib/wx/c_src/wxe_impl.cpp.orig 2017-01-30 23:13:25 UTC
++++ lib/wx/c_src/wxe_impl.cpp
+@@ -666,7 +666,7 @@ void * WxeApp::getPtr(char * bp, wxeMemE
+ throw wxe_badarg(index);
+ }
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL)))
++ if((index < memenv->next) && ((index == 0) || (temp != NULL)))
+ return temp;
+ else {
+ throw wxe_badarg(index);
+@@ -678,7 +678,7 @@ void WxeApp::registerPid(char * bp, ErlD
+ if(!memenv)
+ throw wxe_badarg(index);
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL))) {
++ if((index < memenv->next) && ((index == 0) || (temp != NULL))) {
+ ptrMap::iterator it;
+ it = ptr2ref.find(temp);
+ if(it != ptr2ref.end()) {