aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-02-03 17:31:08 +0800
committergerald <gerald@FreeBSD.org>2017-02-03 17:31:08 +0800
commit777feeabffb530239fa06b91792eed73dda64923 (patch)
tree48bf6d15f310ecd9cbf72b7a6b00de211899c1a6
parent655dc39ee9121d54df875326484c6d57323985c3 (diff)
downloadfreebsd-ports-gnome-777feeabffb530239fa06b91792eed73dda64923.tar.gz
freebsd-ports-gnome-777feeabffb530239fa06b91792eed73dda64923.tar.zst
freebsd-ports-gnome-777feeabffb530239fa06b91792eed73dda64923.zip
Remove traces of armv6hf which no longer exists as an arch. [1]
Remove redundant definition of DISTVERSION and simplify GCC_VERSION. Reported by: andreast [1]
-rw-r--r--lang/gcc48/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 560463be645b..58b952c7638d 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -27,12 +27,11 @@ BUILD_DEPENDS+= runtest:misc/dejagnu
CPE_VENDOR= gnu
CPE_VERSION= ${GCC_VERSION}
-# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
-# of executables and directories once installed.
-DISTVERSION= ${PORTVERSION}
-GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
+# GCC_VERSION and SUFFIX relate to names of executables and directories
+# once installed.
+GCC_VERSION= ${PORTVERSION}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
-ONLY_FOR_ARCHS= amd64 armv6 armv6hf i386 powerpc powerpc64 sparc64
+ONLY_FOR_ARCHS= amd64 armv6 i386 powerpc powerpc64 sparc64
USES= compiler cpe gmake iconv libtool makeinfo perl5 tar:bzip2
USE_BINUTILS= yes
USE_PERL5= build
@@ -66,7 +65,7 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
CONFIGURE_ENV+= UNAME_m="powerpc64"
.endif
-.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+.if ${ARCH} == "armv6"
# Override sys.mk including -O in CFLAGS which breaks libgomp building.
CFLAGS:= ${CFLAGS:S/-O/-O2/g}
. if ${COMPILER_TYPE} == clang