aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-31 08:46:50 +0800
committeraaron <aaron@FreeBSD.org>2006-05-31 08:46:50 +0800
commit77fce36671d50898106ae8c305ed9973bfaa7447 (patch)
treeb3d520879c393676bef4f0d4dd1260cbcb687f36
parent54a9d1e76b2b99f41336be10bc191fc805bdf42e (diff)
downloadfreebsd-ports-gnome-77fce36671d50898106ae8c305ed9973bfaa7447.tar.gz
freebsd-ports-gnome-77fce36671d50898106ae8c305ed9973bfaa7447.tar.zst
freebsd-ports-gnome-77fce36671d50898106ae8c305ed9973bfaa7447.zip
Adding port devel/p5-Class-MixinFactory, Class Factory with Selection of Mixins.
Approved by: tobez (implicit)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-MixinFactory/Makefile28
-rw-r--r--devel/p5-Class-MixinFactory/distinfo2
-rw-r--r--devel/p5-Class-MixinFactory/pkg-descr9
-rw-r--r--devel/p5-Class-MixinFactory/pkg-plist12
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9b9098075fb2..d9d2a059cc83 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -796,6 +796,7 @@
SUBDIR += p5-Class-MakeMethods
SUBDIR += p5-Class-MethodMaker
SUBDIR += p5-Class-MethodMapper
+ SUBDIR += p5-Class-MixinFactory
SUBDIR += p5-Class-NamedParms
SUBDIR += p5-Class-ObjectTemplate
SUBDIR += p5-Class-ObjectTemplate-DB
diff --git a/devel/p5-Class-MixinFactory/Makefile b/devel/p5-Class-MixinFactory/Makefile
new file mode 100644
index 000000000000..acee590d68d4
--- /dev/null
+++ b/devel/p5-Class-MixinFactory/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Class-MixinFactory
+# Date created: 30 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-MixinFactory
+PORTVERSION= 0.92
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Class Factory with Selection of Mixins
+
+MAN3= Class::MixinFactory.3 \
+ Class::MixinFactory::Changes.3 \
+ Class::MixinFactory::Factory.3 \
+ Class::MixinFactory::HasAFactory.3 \
+ Class::MixinFactory::InsideOutAttr.3 \
+ Class::MixinFactory::NEXT.3 \
+ Class::MixinFactory::ReadMe.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-MixinFactory/distinfo b/devel/p5-Class-MixinFactory/distinfo
new file mode 100644
index 000000000000..62540589697a
--- /dev/null
+++ b/devel/p5-Class-MixinFactory/distinfo
@@ -0,0 +1,2 @@
+MD5 (Class-MixinFactory-0.92.tar.gz) = 577d76cdc3c5b0c313634f783c96c767
+SIZE (Class-MixinFactory-0.92.tar.gz) = 11150
diff --git a/devel/p5-Class-MixinFactory/pkg-descr b/devel/p5-Class-MixinFactory/pkg-descr
new file mode 100644
index 000000000000..498672f83b76
--- /dev/null
+++ b/devel/p5-Class-MixinFactory/pkg-descr
@@ -0,0 +1,9 @@
+This distribution facilitates the run-time generation of classes which
+inherit from a base class and some optional selection of mixin classes.
+
+A factory is provided to generate the mixed classes with multiple
+inheritance. A NEXT method allows method redispatch up the inheritance
+chain.
+
+WWW: http://search.cpan.org/dist/Class-MixinFactory
+Author: Matthew Simon Cavalletto
diff --git a/devel/p5-Class-MixinFactory/pkg-plist b/devel/p5-Class-MixinFactory/pkg-plist
new file mode 100644
index 000000000000..ad2819cb227c
--- /dev/null
+++ b/devel/p5-Class-MixinFactory/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/Class/MixinFactory.pm
+%%SITE_PERL%%/Class/MixinFactory/Changes.pod
+%%SITE_PERL%%/Class/MixinFactory/Factory.pm
+%%SITE_PERL%%/Class/MixinFactory/HasAFactory.pm
+%%SITE_PERL%%/Class/MixinFactory/InsideOutAttr.pm
+%%SITE_PERL%%/Class/MixinFactory/NEXT.pm
+%%SITE_PERL%%/Class/MixinFactory/ReadMe.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/MixinFactory/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/MixinFactory
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrm %%SITE_PERL%%/Class/MixinFactory
+@dirrmtry %%SITE_PERL%%/Class