aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-01 13:29:46 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-01 13:29:46 +0800
commit7a17a608a7a0d21393e04b3762b2fc975e935dcd (patch)
tree1fd862f1b9ffee9e9efcff3ff6840cc691989007
parentb0cde0ef639ef043b0d02e224e8da1578e9c9377 (diff)
downloadfreebsd-ports-gnome-7a17a608a7a0d21393e04b3762b2fc975e935dcd.tar.gz
freebsd-ports-gnome-7a17a608a7a0d21393e04b3762b2fc975e935dcd.tar.zst
freebsd-ports-gnome-7a17a608a7a0d21393e04b3762b2fc975e935dcd.zip
devel/py-jcc: unbreak with clang 4.0
jcc/sources/JArray.cpp:315:66: error: ordered comparison between pointer and zero ('PyObject *' (aka '_object *') and 'int') PyList_Type.tp_as_sequence->sq_inplace_concat(list, arg) < 0) ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~ jcc/sources/JArray.cpp:330:64: error: ordered comparison between pointer and zero ('PyObject *' (aka '_object *') and 'int') PyList_Type.tp_as_sequence->sq_inplace_repeat(list, n) < 0) ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~ Reported by: antoine (via exp-run)
-rw-r--r--devel/py-jcc/Makefile1
-rw-r--r--devel/py-jcc/files/patch-jcc_sources_JArray.cpp20
2 files changed, 21 insertions, 0 deletions
diff --git a/devel/py-jcc/Makefile b/devel/py-jcc/Makefile
index e658fa08d0db..c323163575e2 100644
--- a/devel/py-jcc/Makefile
+++ b/devel/py-jcc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= jcc
PORTVERSION= 2.22
+PORTREVISION= 1
CATEGORIES= devel java python
MASTER_SITES= CHEESESHOP/source/J/JCC
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/devel/py-jcc/files/patch-jcc_sources_JArray.cpp b/devel/py-jcc/files/patch-jcc_sources_JArray.cpp
new file mode 100644
index 000000000000..3624488e62c8
--- /dev/null
+++ b/devel/py-jcc/files/patch-jcc_sources_JArray.cpp
@@ -0,0 +1,20 @@
+--- jcc/sources/JArray.cpp.orig 2014-02-05 23:36:44 UTC
++++ jcc/sources/JArray.cpp
+@@ -312,7 +312,7 @@ static PyObject *seq_concat(U *self, PyO
+ PyObject *list = toSequence<U>(self);
+
+ if (list != NULL &&
+- PyList_Type.tp_as_sequence->sq_inplace_concat(list, arg) < 0)
++ PyList_Type.tp_as_sequence->sq_inplace_concat(list, arg) == NULL)
+ {
+ Py_DECREF(list);
+ return NULL;
+@@ -327,7 +327,7 @@ static PyObject *seq_repeat(U *self, Py_
+ PyObject *list = toSequence<U>(self);
+
+ if (list != NULL &&
+- PyList_Type.tp_as_sequence->sq_inplace_repeat(list, n) < 0)
++ PyList_Type.tp_as_sequence->sq_inplace_repeat(list, n) == NULL)
+ {
+ Py_DECREF(list);
+ return NULL;