aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-10 11:25:19 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-10 11:25:19 +0800
commit7d94d4a1c8e7fd8730fce002477fdb8329967d0a (patch)
treed6a437b13abe0cf9a2bbc7c3ec90a8b74451c924
parent16de4a084913975e393132fa04b8d9faaf5e6043 (diff)
downloadfreebsd-ports-gnome-7d94d4a1c8e7fd8730fce002477fdb8329967d0a.tar.gz
freebsd-ports-gnome-7d94d4a1c8e7fd8730fce002477fdb8329967d0a.tar.zst
freebsd-ports-gnome-7d94d4a1c8e7fd8730fce002477fdb8329967d0a.zip
- Add p5-Tk-Sugar 1.093190
Tk is a great graphical toolkit to write desktop applications. However, one can get bothered with the constant typing of quotes and options. Tk::Sugar provides handy subs for common options used when programming Tk. Benefits are obvious: - Reduced typing: The constant need to type => and '' is fine for one-off cases, but the instant you start using Tk it starts to get annoying. - More compact statements: Reduces much of the redundant typing in most cases, which makes your life easier, and makes it take up less visual space, which makes it faster to read. - No string worries: Strings are often problematic, since they aren't checked at compile-time. Sometimes it makes spotting an error a difficult task. Using this alleviates that worry. WWW: http://search.cpan.org/dist/Tk-Sugar/
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/p5-Tk-Sugar/Makefile25
-rw-r--r--x11-toolkits/p5-Tk-Sugar/distinfo2
-rw-r--r--x11-toolkits/p5-Tk-Sugar/pkg-descr15
-rw-r--r--x11-toolkits/p5-Tk-Sugar/pkg-plist5
5 files changed, 48 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index b683ded431fd..459dde797d3e 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -178,6 +178,7 @@
SUBDIR += p5-Tk-Role-HasWidgets
SUBDIR += p5-Tk-ResizeButton
SUBDIR += p5-Tk-Splashscreen
+ SUBDIR += p5-Tk-Sugar
SUBDIR += p5-Tk-TableMatrix
SUBDIR += p5-Wx
SUBDIR += p5-Wx-Perl-ProcessStream
diff --git a/x11-toolkits/p5-Tk-Sugar/Makefile b/x11-toolkits/p5-Tk-Sugar/Makefile
new file mode 100644
index 000000000000..323d11dac9eb
--- /dev/null
+++ b/x11-toolkits/p5-Tk-Sugar/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Tk-Sugar
+# Date created: 2011-10-10
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tk-Sugar
+PORTVERSION= 1.093.190
+CATEGORIES= x11-toolkits tk perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Sugar syntax for Tk
+
+BUILD_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+RUN_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+
+PERL_CONFIGURE= yes
+
+MAN3= Tk::Sugar.3
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Tk-Sugar/distinfo b/x11-toolkits/p5-Tk-Sugar/distinfo
new file mode 100644
index 000000000000..5f3bf3a1a9be
--- /dev/null
+++ b/x11-toolkits/p5-Tk-Sugar/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Tk-Sugar-1.093190.tar.gz) = 2373e89a7a5127362aa83d0dee611a1e24104c87adf47b5eeffc699021d4a017
+SIZE (Tk-Sugar-1.093190.tar.gz) = 11656
diff --git a/x11-toolkits/p5-Tk-Sugar/pkg-descr b/x11-toolkits/p5-Tk-Sugar/pkg-descr
new file mode 100644
index 000000000000..6a79108673ec
--- /dev/null
+++ b/x11-toolkits/p5-Tk-Sugar/pkg-descr
@@ -0,0 +1,15 @@
+Tk is a great graphical toolkit to write desktop applications. However, one can
+get bothered with the constant typing of quotes and options. Tk::Sugar provides
+handy subs for common options used when programming Tk.
+
+Benefits are obvious:
+- Reduced typing: The constant need to type => and '' is fine for one-off cases,
+ but the instant you start using Tk it starts to get annoying.
+- More compact statements: Reduces much of the redundant typing in most cases,
+ which makes your life easier, and makes it take up less visual space, which
+ makes it faster to read.
+- No string worries: Strings are often problematic, since they aren't checked at
+ compile-time. Sometimes it makes spotting an error a difficult task. Using
+ this alleviates that worry.
+
+WWW: http://search.cpan.org/dist/Tk-Sugar/
diff --git a/x11-toolkits/p5-Tk-Sugar/pkg-plist b/x11-toolkits/p5-Tk-Sugar/pkg-plist
new file mode 100644
index 000000000000..c282f115189b
--- /dev/null
+++ b/x11-toolkits/p5-Tk-Sugar/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Tk/Sugar.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/Sugar/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/Sugar
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk
+@dirrmtry %%SITE_PERL%%/Tk