aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-01 20:25:57 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-01 20:25:57 +0800
commit7e97a8cc9dc4077c22461d96bd200713f806da8c (patch)
tree312bfa8f3c57f67e19322d4426a3d0ff0cdc1177
parentf87d1398d4101c11fd72387554301327a8226e48 (diff)
downloadfreebsd-ports-gnome-7e97a8cc9dc4077c22461d96bd200713f806da8c.tar.gz
freebsd-ports-gnome-7e97a8cc9dc4077c22461d96bd200713f806da8c.tar.zst
freebsd-ports-gnome-7e97a8cc9dc4077c22461d96bd200713f806da8c.zip
games/xjig: unbreak with libc++ 3.9
gif_image.C:61:7: error: assigning to 'char *' from incompatible type 'const char *' name = strrchr(filename,'/'); ^ ~~~~~~~~~~~~~~~~~~~~~ Reported by: pkg-fallout
-rw-r--r--games/xjig/Makefile2
-rw-r--r--games/xjig/files/patch-gif__image.C13
2 files changed, 14 insertions, 1 deletions
diff --git a/games/xjig/Makefile b/games/xjig/Makefile
index dac0ec69ad63..1376f56aa327 100644
--- a/games/xjig/Makefile
+++ b/games/xjig/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xjig
PORTVERSION= 2.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= XCONTRIB/games
diff --git a/games/xjig/files/patch-gif__image.C b/games/xjig/files/patch-gif__image.C
new file mode 100644
index 000000000000..35f007a3c6f9
--- /dev/null
+++ b/games/xjig/files/patch-gif__image.C
@@ -0,0 +1,13 @@
+--- gif_image.C.orig 1996-07-04 21:43:12 UTC
++++ gif_image.C
+@@ -58,8 +58,8 @@ GifImage::GifImage(const char *filename,
+ : lockcount(0) {
+ first=0;
+ LoadGIF( filename );
+- name = strrchr(filename,'/');
+- if (name) name=strdup(name+1);
++ const char *pos = strrchr(filename,'/');
++ if (pos) name=strdup(pos+1);
+ else name=strdup(filename);
+
+ if (autocrop&&!fastinfo_flag) CropImage();