aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2005-12-16 15:40:17 +0800
committerclive <clive@FreeBSD.org>2005-12-16 15:40:17 +0800
commit7edc098b568b56215c498840a72098ec35fbe384 (patch)
tree4d5e3b0dc6781b9d041c23c6cfc15af97655ee8d
parent560dd6b98406a2d72447933f1674af009c5d3e53 (diff)
downloadfreebsd-ports-gnome-7edc098b568b56215c498840a72098ec35fbe384.tar.gz
freebsd-ports-gnome-7edc098b568b56215c498840a72098ec35fbe384.tar.zst
freebsd-ports-gnome-7edc098b568b56215c498840a72098ec35fbe384.zip
Fix post-install target conflicts.
Submitted by: NIIMI Satoshi <sa2c at sa2c dot net>
-rw-r--r--chinese/emacs20/Makefile2
-rw-r--r--editors/emacs20/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/chinese/emacs20/Makefile b/chinese/emacs20/Makefile
index f1548a1b761c..c6e8e379bbbb 100644
--- a/chinese/emacs20/Makefile
+++ b/chinese/emacs20/Makefile
@@ -32,7 +32,7 @@ post-patch:
@${ECHO_CMD} "share/emacs/%%EMACS_VER%%/etc/dot.emacs" >> ${WRKDIR}/pkg-plist
@${CAT} ${MASTERDIR}/pkg-plist >> ${WRKDIR}/pkg-plist
-post-install:
+post-install::
${INSTALL} -c ${.CURDIR}/files/Emacs ${PREFIX}/share/emacs/${PORTVERSION}/etc
${INSTALL} -c ${.CURDIR}/files/dot.emacs ${PREFIX}/share/emacs/${PORTVERSION}/etc
@${CAT} ${PKGMESSAGE}
diff --git a/editors/emacs20/Makefile b/editors/emacs20/Makefile
index 0ead5ed95bfe..5668f6664997 100644
--- a/editors/emacs20/Makefile
+++ b/editors/emacs20/Makefile
@@ -61,7 +61,7 @@ post-build:
)
BINDIR= ${PREFIX}/libexec/emacs/${EMACS_VER}/${CONFIGURE_TARGET}
-post-install:
+post-install::
for f in b2m ctags emacs emacsclient etags rcs-checkin; do \
${LN} -sf ${BINDIR}/$${f} ${PREFIX}/bin/$${f}20; \
done