aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpizzamig <pizzamig@FreeBSD.org>2018-04-20 23:41:33 +0800
committerpizzamig <pizzamig@FreeBSD.org>2018-04-20 23:41:33 +0800
commit825966a994896cc683bebbf0c9001b887fb1b242 (patch)
tree49da9aee60eab438d918bdf339ba2c24de0ee31d
parent1cacabd4359623a48aa7ece9573aaad8f59d718c (diff)
downloadfreebsd-ports-gnome-825966a994896cc683bebbf0c9001b887fb1b242.tar.gz
freebsd-ports-gnome-825966a994896cc683bebbf0c9001b887fb1b242.tar.zst
freebsd-ports-gnome-825966a994896cc683bebbf0c9001b887fb1b242.zip
net-mgmt/collectd5: Add write_prometheus support
The plugin write_promethues, already present in collectd5, is now configuration via the option PROMETHEUS PR: PR227634 Approved by: maintainer Sponsored by: trivago N.V.
-rw-r--r--net-mgmt/collectd5/Makefile10
-rw-r--r--net-mgmt/collectd5/pkg-plist1
2 files changed, 9 insertions, 2 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index b21f33b9cb65..398a63e07f12 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -19,8 +19,8 @@ GNU_CONFIGURE= yes
OPTIONS_DEFINE= CGI JAVA LOGGING GCRYPT LOGSTASH VIRT
OPTIONS_GROUP= INPUT OUTPUT
-OPTIONS_GROUP_OUTPUT= KAFKA MONGODB NOTIFYDESKTOP NOTIFYEMAIL RIEMANN RRDTOOL \
- TSDB
+OPTIONS_GROUP_OUTPUT= KAFKA MONGODB NOTIFYDESKTOP NOTIFYEMAIL PROMETHEUS RIEMANN \
+ RRDTOOL TSDB
OPTIONS_GROUP_INPUT= CHRONY CURL CURL_JSON CURL_XML DBI IPMI JSON \
MEMCACHEC MODBUS MQTT MYSQL NUTUPS OLSRD ONEWIRE OPENLDAP \
PERL PGSQL PINBA PING PYTHON RABBITMQ REDIS ROUTEROS \
@@ -56,6 +56,7 @@ PERL_DESC= Enable libperl plugin and binding
PGSQL_DESC= Enable postgresql-based plugins
PINBA_DESC= Enable pinba plugin (via protobuf-c)
PING_DESC= Enable ping plugin
+PROMETHEUS_DESC= Enable write prometheus plugin
PYTHON_DESC= Enable python-based plugins
RABBITMQ_DESC= Enable rabbitmq-based plugins
REDIS_DESC= Enable redis-based plugins
@@ -215,6 +216,11 @@ PING_LIB_DEPENDS= liboping.so:net/liboping
PING_CONFIGURE_ENABLE= ping
PING_CONFIGURE_WITH= liboping=${LOCALBASE}
+PROMETHEUS_LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c
+PROMETHEUS_LIB_DEPENDS+= libprotoc.so:devel/protobuf
+PROMETHEUS_LIB_DEPENDS+= libmicrohttpd.so:www/libmicrohttpd
+PROMETHEUS_CONFIGURE_ENABLE= write_prometheus
+
PYTHON_USES= python
PYTHON_CONFIGURE_ENABLE= python
PYTHON_CONFIGURE_WITH= python=${PYTHON_CMD}
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index 76aa1c0dbd41..0282137f943b 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -104,6 +104,7 @@ lib/collectd/write_graphite.so
lib/collectd/write_log.so
%%KAFKA%%lib/collectd/write_kafka.so
%%MONGODB%%lib/collectd/write_mongodb.so
+%%PROMETHEUS%%lib/collectd/write_prometheus.so
%%REDIS%%lib/collectd/write_redis.so
%%RIEMANN%%lib/collectd/write_riemann.so
%%TSDB%%lib/collectd/write_tsdb.so