aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-08 01:58:27 +0800
committeraz <az@FreeBSD.org>2013-09-08 01:58:27 +0800
commit83c727fc49bd2ae03edba694bb4a50e985a69059 (patch)
tree6186c19d627cb014b6944a7af856baa65e7a0996
parent1c486dd5e40b3e97464bb5f2073488718c2b364d (diff)
downloadfreebsd-ports-gnome-83c727fc49bd2ae03edba694bb4a50e985a69059.tar.gz
freebsd-ports-gnome-83c727fc49bd2ae03edba694bb4a50e985a69059.tar.zst
freebsd-ports-gnome-83c727fc49bd2ae03edba694bb4a50e985a69059.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
-rw-r--r--devel/avarice/Makefile2
-rw-r--r--devel/p5-Algorithm-Binpack/Makefile3
-rw-r--r--devel/p5-Data-Throttler-Memcached/Makefile9
-rw-r--r--devel/p5-DateTime-Calendar-Japanese/Makefile9
-rw-r--r--devel/p5-Devel-Declare/Makefile3
-rw-r--r--devel/p5-ExtUtils-Install/Makefile8
-rw-r--r--devel/p5-File-Find-Closures/Makefile9
-rw-r--r--devel/p5-File-Tail/Makefile8
-rw-r--r--devel/p5-Hash-WithDefaults/Makefile9
-rw-r--r--devel/p5-IO-MultiPipe/Makefile9
-rw-r--r--devel/p5-Log-Dispatch-DBI/Makefile9
-rw-r--r--devel/p5-MooseX-HasDefaults/Makefile9
-rw-r--r--devel/p5-Perl-Metrics-Simple/Makefile3
-rw-r--r--devel/p5-Perl-PrereqScanner/Makefile9
-rw-r--r--devel/p5-SVN-Hook/Makefile9
-rw-r--r--devel/p5-SVN-Notify-Filter-Watchers/Makefile9
-rw-r--r--devel/p5-Test-Class-Most/Makefile3
-rw-r--r--devel/p5-Test-Fatal/Makefile9
-rw-r--r--devel/p5-Tie-DB_FileLock/Makefile9
19 files changed, 50 insertions, 88 deletions
diff --git a/devel/avarice/Makefile b/devel/avarice/Makefile
index b690db479a0d..727ace683d1a 100644
--- a/devel/avarice/Makefile
+++ b/devel/avarice/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libbfd.a:${PORTSDIR}/devel/libbfd \
${LOCALBASE}/lib/libiberty.a:${PORTSDIR}/devel/gnulibiberty
USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
#CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib CPPFLAGS=-I${LOCALBASE}/include
diff --git a/devel/p5-Algorithm-Binpack/Makefile b/devel/p5-Algorithm-Binpack/Makefile
index a6e439668dba..295637b5f792 100644
--- a/devel/p5-Algorithm-Binpack/Makefile
+++ b/devel/p5-Algorithm-Binpack/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wblock@FreeBSD.org
COMMENT= Efficiently pack items into bins
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Algorithm::BinPack.3
diff --git a/devel/p5-Data-Throttler-Memcached/Makefile b/devel/p5-Data-Throttler-Memcached/Makefile
index f09d0f57f17f..3799b28e124d 100644
--- a/devel/p5-Data-Throttler-Memcached/Makefile
+++ b/devel/p5-Data-Throttler-Memcached/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Data-Throttler-Memcached
-# Date created: 2008-01-30
-# Whom: Masahiro Teramoto <markun@onohara.to>
-#
+# Created by: Masahiro Teramoto <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= Data-Throttler-Memcached
PORTVERSION= 0.00003
@@ -22,7 +18,8 @@ RUN_DEPENDS= p5-Cache-Memcached-Managed>=0:${PORTSDIR}/databases/p5-Cache-Memcac
p5-Data-Throttler>=0:${PORTSDIR}/devel/p5-Data-Throttler \
p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Throttler::Memcached.3 \
Data::Throttler::BucketChain::Memcached.3
diff --git a/devel/p5-DateTime-Calendar-Japanese/Makefile b/devel/p5-DateTime-Calendar-Japanese/Makefile
index 674c04e420b0..ddbd6f9035de 100644
--- a/devel/p5-DateTime-Calendar-Japanese/Makefile
+++ b/devel/p5-DateTime-Calendar-Japanese/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-DateTime-Calendar-Japanese
-# Date created: 2007-11-06
-# Whom: Masahiro Teramoto <markun@onohara.to>
-#
+# Created by: Masahiro Teramoto <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= DateTime-Calendar-Japanese
PORTVERSION= 0.06001
@@ -31,7 +27,8 @@ RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
p5-YAML>0:${PORTSDIR}/textproc/p5-YAML
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DateTime::Calendar::Japanese.3
diff --git a/devel/p5-Devel-Declare/Makefile b/devel/p5-Devel-Declare/Makefile
index 776b8457d9aa..2c8f8ec295a8 100644
--- a/devel/p5-Devel-Declare/Makefile
+++ b/devel/p5-Devel-Declare/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-ExtUtils-Depends>=0.302:${PORTSDIR}/devel/p5-ExtUtils-Depends
${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Devel::Declare.3
diff --git a/devel/p5-ExtUtils-Install/Makefile b/devel/p5-ExtUtils-Install/Makefile
index 1a7ee51f1256..2fa10ccd5128 100644
--- a/devel/p5-ExtUtils-Install/Makefile
+++ b/devel/p5-ExtUtils-Install/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: ExtUtils::Install
-# Date created: 07 Aug 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= ExtUtils-Install
PORTVERSION= 1.54
@@ -15,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to install files from here to there
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ExtUtils::Install.3 \
ExtUtils::Installed.3 \
diff --git a/devel/p5-File-Find-Closures/Makefile b/devel/p5-File-Find-Closures/Makefile
index eeb6e1c4d76a..48eee4881c84 100644
--- a/devel/p5-File-Find-Closures/Makefile
+++ b/devel/p5-File-Find-Closures/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-File-Find-Closures
-# Date created: 2008-11-15
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= File-Find-Closures
PORTVERSION= 1.09
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Functions you can use with File::Find
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= File::Find::Closures.3
diff --git a/devel/p5-File-Tail/Makefile b/devel/p5-File-Tail/Makefile
index d1cbe03f04f3..e45101f1d6e0 100644
--- a/devel/p5-File-Tail/Makefile
+++ b/devel/p5-File-Tail/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: File-Tail
-# Date created: 19 December 2000
-# Whom: Jeremy Shaffner <jeremy@external.org>
-#
+# Created by: Jeremy Shaffner <jeremy@external.org>
# $FreeBSD$
PORTNAME= File-Tail
@@ -13,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl Module to read the end of a file as it\'s appended to
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= File::Tail.3
diff --git a/devel/p5-Hash-WithDefaults/Makefile b/devel/p5-Hash-WithDefaults/Makefile
index 2be050cfb756..a0eadf9e8589 100644
--- a/devel/p5-Hash-WithDefaults/Makefile
+++ b/devel/p5-Hash-WithDefaults/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Hash-WithDefaults
-# Date created: 2006-08-15
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Hash-WithDefaults
PORTVERSION= 0.04
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Class for hashes with key-casing requirements supporting defaults
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Hash::WithDefaults.3
diff --git a/devel/p5-IO-MultiPipe/Makefile b/devel/p5-IO-MultiPipe/Makefile
index dad0aff0b579..2f560572939f 100644
--- a/devel/p5-IO-MultiPipe/Makefile
+++ b/devel/p5-IO-MultiPipe/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-IO-MultiPipe
-# Date created: 2009-01-14
-# Whom: Zane C, Bowers <vvelox@vvelox.net>
-#
+# Created by: Zane C, Bowers <vvelox@vvelox.net>
# $FreeBSD$
-#
PORTNAME= IO-MultiPipe
PORTVERSION= 0.0.0
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vvelox@vvelox.net
COMMENT= Check for errors when running a command through multiple pipes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IO::MultiPipe.3
diff --git a/devel/p5-Log-Dispatch-DBI/Makefile b/devel/p5-Log-Dispatch-DBI/Makefile
index 8a346d6c78b7..1df5c08c411d 100644
--- a/devel/p5-Log-Dispatch-DBI/Makefile
+++ b/devel/p5-Log-Dispatch-DBI/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Log-Dispatch-DBI
-# Date created: 2011-08-22
-# Whom: Ralf Gebhart <gebhart@secnetix.de>
-#
+# Created by: Ralf Gebhart <gebhart@secnetix.de>
# $FreeBSD$
-#
PORTNAME= Log-Dispatch-DBI
PORTVERSION= 0.02
@@ -20,7 +16,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DBD-CSV>0:${PORTSDIR}/databases/p5-DBD-CSV
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Log::Dispatch::DBI.3
diff --git a/devel/p5-MooseX-HasDefaults/Makefile b/devel/p5-MooseX-HasDefaults/Makefile
index c3e61cf5e03f..71d7c054bd4e 100644
--- a/devel/p5-MooseX-HasDefaults/Makefile
+++ b/devel/p5-MooseX-HasDefaults/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Mason
-# Date created: 03 April, 2012
-# Whom: Muhammad Moinur Rahman <5u623l20@gmail.com>
-#
+# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
# $FreeBSD$
-#
PORTNAME= MooseX-HasDefaults
PORTVERSION= 0.03
@@ -17,7 +13,8 @@ COMMENT= Default "is" to "ro" or "rw" for all attributes
BUILD_DEPENDS= p5-Moose>2:${PORTSDIR}/devel/p5-Moose \
p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MooseX::HasDefaults.3
diff --git a/devel/p5-Perl-Metrics-Simple/Makefile b/devel/p5-Perl-Metrics-Simple/Makefile
index c77b7d65afeb..fca1ad623b25 100644
--- a/devel/p5-Perl-Metrics-Simple/Makefile
+++ b/devel/p5-Perl-Metrics-Simple/Makefile
@@ -18,7 +18,8 @@ TEST_DEPENDS= \
p5-Test-Pod>0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= countperl.1
MAN3= Perl::Metrics::Simple.3 \
diff --git a/devel/p5-Perl-PrereqScanner/Makefile b/devel/p5-Perl-PrereqScanner/Makefile
index 8475c8998a2c..539de872e88c 100644
--- a/devel/p5-Perl-PrereqScanner/Makefile
+++ b/devel/p5-Perl-PrereqScanner/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Perl-PrereqScanner
-# Date created: 2011-09-19
-# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
-#
+# Created by: Geraud CONTINSOUZAS <geraud@gcu.info>
# $FreeBSD$
-#
PORTNAME= Perl-PrereqScanner
PORTVERSION= 1.014
@@ -27,7 +23,8 @@ BUILD_DEPENDS= p5-CPAN-Meta>=2.120630:${PORTSDIR}/devel/p5-CPAN-Meta \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= scan_prereqs.1
MAN3= Perl::PrereqScanner.3 \
diff --git a/devel/p5-SVN-Hook/Makefile b/devel/p5-SVN-Hook/Makefile
index 6114898ebb96..6a6f18565b43 100644
--- a/devel/p5-SVN-Hook/Makefile
+++ b/devel/p5-SVN-Hook/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SVN::Hook
-# Date created: 2008-02-12
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Created by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= SVN-Hook
PORTVERSION= 0.28
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
BUILD_DEPENDS= p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= svnhook.1
MAN3= SVN::Hook.3
diff --git a/devel/p5-SVN-Notify-Filter-Watchers/Makefile b/devel/p5-SVN-Notify-Filter-Watchers/Makefile
index 6beb536cab54..dce9170d26dd 100644
--- a/devel/p5-SVN-Notify-Filter-Watchers/Makefile
+++ b/devel/p5-SVN-Notify-Filter-Watchers/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SVN-Notify-Filter-Watchers
-# Date created: 2008-04-22
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Created by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= SVN-Notify-Filter-Watchers
PORTVERSION= 0.10
@@ -17,7 +13,8 @@ COMMENT= Subscribe to SVN::Notify commits with a Subversion property
RUN_DEPENDS= p5-SVN-Notify>=2.72:${PORTSDIR}/devel/p5-SVN-Notify
BUILD_DEPENDS= p5-SVN-Notify>=2.72:${PORTSDIR}/devel/p5-SVN-Notify
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVN::Notify::Filter::Watchers.3
diff --git a/devel/p5-Test-Class-Most/Makefile b/devel/p5-Test-Class-Most/Makefile
index b51d824bd364..20e7f846acbc 100644
--- a/devel/p5-Test-Class-Most/Makefile
+++ b/devel/p5-Test-Class-Most/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Test-Class>=0.38:${PORTSDIR}/devel/p5-Test-Class \
p5-Test-Most>=0.31:${PORTSDIR}/devel/p5-Test-Most
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
PLIST_FILES= %%SITE_PERL%%/Test/Class/Most.pm
PLIST_DIRSTRY= %%SITE_PERL%%/Test/Class %%SITE_PERL%%/Test
diff --git a/devel/p5-Test-Fatal/Makefile b/devel/p5-Test-Fatal/Makefile
index 6b1ed851726e..ba2a84e17b25 100644
--- a/devel/p5-Test-Fatal/Makefile
+++ b/devel/p5-Test-Fatal/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Test-Fatal
-# Date created: 2010-11-15
-# Whom: Frederic Culot <culot@FreeBSD.org>
-#
+# Created by: Frederic Culot <culot@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Test-Fatal
PORTVERSION= 0.010
@@ -20,7 +16,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Try-Tiny>=0.07:${PORTSDIR}/lang/p5-Try-Tiny
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Fatal.3
diff --git a/devel/p5-Tie-DB_FileLock/Makefile b/devel/p5-Tie-DB_FileLock/Makefile
index ba44dd6c92e5..aea13e5a53d5 100644
--- a/devel/p5-Tie-DB_FileLock/Makefile
+++ b/devel/p5-Tie-DB_FileLock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tie-DB_FileLock
-# Date created: August 17 2000
-# Whom: Josh Tiefenbach <josh@zipperup.org>
-#
+# Created by: Josh Tiefenbach <josh@zipperup.org>
# $FreeBSD$
-#
PORTNAME= Tie-DB_FileLock
PORTVERSION= 0.11
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= josh@zipperup.org
COMMENT= Locking access to Berkeley DB v1.x
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tie::DB_FileLock.3