aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-06-20 22:53:58 +0800
committerwg <wg@FreeBSD.org>2014-06-20 22:53:58 +0800
commit83dd2cf3635af916e6c0c1631ad83a6b008c0335 (patch)
treeccc51b07e3c182313740189b8d9590bf121f8b6f
parenta7781d3efbfae60887e631df0b49a5f70784f201 (diff)
downloadfreebsd-ports-gnome-83dd2cf3635af916e6c0c1631ad83a6b008c0335.tar.gz
freebsd-ports-gnome-83dd2cf3635af916e6c0c1631ad83a6b008c0335.tar.zst
freebsd-ports-gnome-83dd2cf3635af916e6c0c1631ad83a6b008c0335.zip
textproc/groff: shebangfix and pet portlint
PR: 189654 Submitted by: paul inetstat net Approved by: maintainer
-rw-r--r--textproc/groff/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/textproc/groff/Makefile b/textproc/groff/Makefile
index 9c90f5f69b5c..77ae1c012363 100644
--- a/textproc/groff/Makefile
+++ b/textproc/groff/Makefile
@@ -3,6 +3,7 @@
PORTNAME= groff
PORTVERSION= 1.22.2
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= groff
@@ -15,10 +16,14 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/bin/psselect:${PORTSDIR}/print/psutils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_GHOSTSCRIPT= yes
-USES= gmake perl5
+USE_GHOSTSCRIPT=yes
+USES= gmake perl5 shebangfix
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-awk=/usr/bin/awk
+CONFIGURE_ENV+= PERLPATH=${perl_CMD} # shebangfix
+
+SHEBANG_FILES= src/utils/afmtodit/afmtodit.pl \
+ contrib/mm/mmroff.pl \
# Canonicalize to A4 if set.
.if defined(A4) || (defined(PAPERSIZE) && ${PAPERSIZE:tu} == "A4")