aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2010-11-25 08:36:58 +0800
committerjkim <jkim@FreeBSD.org>2010-11-25 08:36:58 +0800
commit85a855a0892eaa26d9ee9285b253853b0848c453 (patch)
tree777feeda30762e4c1451296ca1a3e6300fa24fce
parente2b18558284ce7fef33667355f5afc1a3fd63506 (diff)
downloadfreebsd-ports-gnome-85a855a0892eaa26d9ee9285b253853b0848c453.tar.gz
freebsd-ports-gnome-85a855a0892eaa26d9ee9285b253853b0848c453.tar.zst
freebsd-ports-gnome-85a855a0892eaa26d9ee9285b253853b0848c453.zip
- Work around a plugin crash from npw_plugin_instance_is_valid().
- Reduce RPC timeout from 30 to 10 seconds. Obtained from: Fedora Project
-rw-r--r--www/nspluginwrapper-devel/Makefile4
-rw-r--r--www/nspluginwrapper-devel/distinfo6
-rw-r--r--www/nspluginwrapper-devel/files/patch-src-npw-common.h11
-rw-r--r--www/nspluginwrapper-devel/files/patch-src-rpc.c11
4 files changed, 26 insertions, 6 deletions
diff --git a/www/nspluginwrapper-devel/Makefile b/www/nspluginwrapper-devel/Makefile
index e2fb117a4ea5..770627b5fc78 100644
--- a/www/nspluginwrapper-devel/Makefile
+++ b/www/nspluginwrapper-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nspluginwrapper
PORTVERSION= 1.3.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www linux emulators
MASTER_SITES= LOCAL/jkim
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${BINFILE}${EXTRACT_SUFX}
@@ -21,7 +21,7 @@ LATEST_LINK= ${PORTNAME}-devel
CONFLICTS= nspluginwrapper-1.2.*
-BINFILE= ${PORTNAME}-i386-${PORTVERSION}-3
+BINFILE= ${PORTNAME}-i386-${PORTVERSION}-4
ONLY_FOR_ARCHS= i386 amd64
diff --git a/www/nspluginwrapper-devel/distinfo b/www/nspluginwrapper-devel/distinfo
index d660c9fb3c8e..f676e1dc98da 100644
--- a/www/nspluginwrapper-devel/distinfo
+++ b/www/nspluginwrapper-devel/distinfo
@@ -1,6 +1,4 @@
-MD5 (nspluginwrapper-1.3.0.tar.bz2) = 188f77bd3427c131ccba4bfdb25892a9
SHA256 (nspluginwrapper-1.3.0.tar.bz2) = b8900bd5f0bd950f95b963e5c8f5e20d7d15cc70e777b6058289687ad968b21c
SIZE (nspluginwrapper-1.3.0.tar.bz2) = 336049
-MD5 (nspluginwrapper-i386-1.3.0-3.tar.bz2) = 02b0b2628509b01a409c83fa2d5e0224
-SHA256 (nspluginwrapper-i386-1.3.0-3.tar.bz2) = 61c5a0920549e9998d9a210820217cea684f16413ac82e2929d2abfcdc4c2789
-SIZE (nspluginwrapper-i386-1.3.0-3.tar.bz2) = 62053
+SHA256 (nspluginwrapper-i386-1.3.0-4.tar.bz2) = 1db3b9992dd45a3b1e579c18e3b2696103d8fedaa312da71835af55e9a323d0a
+SIZE (nspluginwrapper-i386-1.3.0-4.tar.bz2) = 62112
diff --git a/www/nspluginwrapper-devel/files/patch-src-npw-common.h b/www/nspluginwrapper-devel/files/patch-src-npw-common.h
new file mode 100644
index 000000000000..b3eb062cafba
--- /dev/null
+++ b/www/nspluginwrapper-devel/files/patch-src-npw-common.h
@@ -0,0 +1,11 @@
+--- src/npw-common.h.orig 2009-01-02 15:22:29.000000000 +0100
++++ src/npw-common.h 2009-11-10 09:58:34.000000000 +0100
+@@ -115,7 +115,7 @@ npw_plugin_instance_is_valid(void *ptr)
+ static inline NPW_PluginInstance *
+ _npw_get_plugin_instance (NPP instance)
+ {
+- return (NPW_PluginInstance *)instance->_NPW_INSTANCE_PRIVATE_DATA;
++ return instance ? (NPW_PluginInstance *)instance->_NPW_INSTANCE_PRIVATE_DATA : NULL;
+ }
+
+ static inline NPW_PluginInstance *
diff --git a/www/nspluginwrapper-devel/files/patch-src-rpc.c b/www/nspluginwrapper-devel/files/patch-src-rpc.c
new file mode 100644
index 000000000000..7dbd65179bac
--- /dev/null
+++ b/www/nspluginwrapper-devel/files/patch-src-rpc.c
@@ -0,0 +1,11 @@
+--- src/rpc.c.orig 2009-01-02 15:22:29.000000000 +0100
++++ src/rpc.c 2010-06-29 14:24:39.000000000 +0200
+@@ -68,7 +68,7 @@
+
+ // Define the maximum amount of time (in seconds) to wait for a message
+ #ifndef RPC_MESSAGE_TIMEOUT
+-#define RPC_MESSAGE_TIMEOUT 30
++#define RPC_MESSAGE_TIMEOUT 10
+ #endif
+
+ // Define the maximum amount of time (in seconds) to wait for plugin connection