aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-02-27 06:29:50 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-02-27 06:29:50 +0800
commit85e032f65183f6b349eaa773ee3e16e87794c8f4 (patch)
tree2bf59363d3a92cfd791145f424e43edfd15fd614
parent97bf5aaa25d88d2fda0c54f9a46e3430c6853d22 (diff)
downloadfreebsd-ports-gnome-85e032f65183f6b349eaa773ee3e16e87794c8f4.tar.gz
freebsd-ports-gnome-85e032f65183f6b349eaa773ee3e16e87794c8f4.tar.zst
freebsd-ports-gnome-85e032f65183f6b349eaa773ee3e16e87794c8f4.zip
Add py-jsonlines 1.2.0
jsonlines is a Python library to simplify working with jsonlines and ndjson data. WWW: https://pypi.python.org/pypi/jsonlines WWW: https://github.com/wbolster/jsonlines
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jsonlines/Makefile22
-rw-r--r--devel/py-jsonlines/distinfo3
-rw-r--r--devel/py-jsonlines/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 419b34640530..491b278fe697 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4546,6 +4546,7 @@
SUBDIR += py-json-sempai
SUBDIR += py-jsonlib
SUBDIR += py-jsonlib2
+ SUBDIR += py-jsonlines
SUBDIR += py-jsonpatch
SUBDIR += py-jsonpointer
SUBDIR += py-jsonref
diff --git a/devel/py-jsonlines/Makefile b/devel/py-jsonlines/Makefile
new file mode 100644
index 000000000000..d0fdd041cb7c
--- /dev/null
+++ b/devel/py-jsonlines/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= jsonlines
+PORTVERSION= 1.2.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Library with helpers for the jsonlines file format
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/devel/py-jsonlines/distinfo b/devel/py-jsonlines/distinfo
new file mode 100644
index 000000000000..e8f1be58a966
--- /dev/null
+++ b/devel/py-jsonlines/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1519647064
+SHA256 (jsonlines-1.2.0.tar.gz) = 43b8d5588a9d4862c8a4a49580e38e20ec595aee7ad6fe469b10fb83fbefde88
+SIZE (jsonlines-1.2.0.tar.gz) = 6075
diff --git a/devel/py-jsonlines/pkg-descr b/devel/py-jsonlines/pkg-descr
new file mode 100644
index 000000000000..3f19ea7c3bb6
--- /dev/null
+++ b/devel/py-jsonlines/pkg-descr
@@ -0,0 +1,5 @@
+jsonlines is a Python library to simplify working with jsonlines and ndjson
+data.
+
+WWW: https://pypi.python.org/pypi/jsonlines
+WWW: https://github.com/wbolster/jsonlines