aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2018-05-09 18:49:03 +0800
committermadpilot <madpilot@FreeBSD.org>2018-05-09 18:49:03 +0800
commit87aa8465a113cd108ef67d176ccb4b5bf1110b47 (patch)
tree750451910914b3823a4376bdfc25c8063d1448f8
parent7b0af0c1cd11375a20756311873b91f15197c067 (diff)
downloadfreebsd-ports-gnome-87aa8465a113cd108ef67d176ccb4b5bf1110b47.tar.gz
freebsd-ports-gnome-87aa8465a113cd108ef67d176ccb4b5bf1110b47.tar.zst
freebsd-ports-gnome-87aa8465a113cd108ef67d176ccb4b5bf1110b47.zip
- Fix build when NLS is disabled by adding back required extra patch
- While here, convert port to USES=localbase PR: 227326 Submitted by: guyyur@gmail.com Approved by: portmgr blanket, Maintainer timeout
-rw-r--r--deskutils/parcellite/Makefile4
-rw-r--r--deskutils/parcellite/files/extrapatch-configure.ac27
2 files changed, 28 insertions, 3 deletions
diff --git a/deskutils/parcellite/Makefile b/deskutils/parcellite/Makefile
index 71069719d387..b4a32d06879b 100644
--- a/deskutils/parcellite/Makefile
+++ b/deskutils/parcellite/Makefile
@@ -13,7 +13,7 @@ COMMENT= Lightweight GTK+ clipboard manager
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig
+USES= localbase pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk20 pango
USE_XORG= x11
@@ -21,8 +21,6 @@ CONFIGURE_ARGS+=--disable-appindicator
PORTDOCS= AUTHORS ChangeLog README
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
LIBS+= -lgio-2.0
OPTIONS_DEFINE= DOCS NLS
diff --git a/deskutils/parcellite/files/extrapatch-configure.ac b/deskutils/parcellite/files/extrapatch-configure.ac
new file mode 100644
index 000000000000..5fe9e25e8831
--- /dev/null
+++ b/deskutils/parcellite/files/extrapatch-configure.ac
@@ -0,0 +1,27 @@
+--- configure.ac.orig 2014-10-01 14:43:09 UTC
++++ configure.ac
+@@ -19,15 +19,9 @@ GETTEXT_PACKAGE=parcellite
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [gettext package])
+
+-ALL_LINGUAS="ca cs da de es fr hu it ja nb pl pl_PL pt_BR ro ru sv tr zh_CN"
+-AM_GLIB_GNU_GETTEXT()
+-AC_PROG_INTLTOOL([0.23])
+-
+ parcellitelocaledir='${prefix}/${DATADIRNAME}/locale'
+ AC_SUBST(parcellitelocaledir)
+
+-AM_GNU_GETTEXT([external])
+-
+ # -------------------------------------------------------------------------------
+ # Main settings.
+ # -------------------------------------------------------------------------------
+@@ -104,7 +98,7 @@ AC_CHECK_LIB([$gtk_libs],gtk_status_icon
+ # -------------------------------------------------------------------------------
+ # Checks for header files.
+ # -------------------------------------------------------------------------------
+-AC_CHECK_HEADERS([stdlib.h string.h pthread.h libintl.h])
++AC_CHECK_HEADERS([stdlib.h string.h pthread.h])
+
+ # -------------------------------------------------------------------------------
+ # Checks for typedefs, structures, and compiler characteristics.