aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-08-12 21:31:07 +0800
committerantoine <antoine@FreeBSD.org>2014-08-12 21:31:07 +0800
commit88ca26f6a4303b197caae52c028c6fb3645d7b2c (patch)
tree19c458749d626938fd7a8ad42655afd316872c98
parent22c57b79424f9abe96351a82ef60bc96abb0489e (diff)
downloadfreebsd-ports-gnome-88ca26f6a4303b197caae52c028c6fb3645d7b2c.tar.gz
freebsd-ports-gnome-88ca26f6a4303b197caae52c028c6fb3645d7b2c.tar.zst
freebsd-ports-gnome-88ca26f6a4303b197caae52c028c6fb3645d7b2c.zip
Stage support
-rw-r--r--sysutils/libutempter/Makefile1
-rw-r--r--sysutils/libutempter/files/patch-Makefile21
2 files changed, 10 insertions, 12 deletions
diff --git a/sysutils/libutempter/Makefile b/sysutils/libutempter/Makefile
index a88be831d350..1711f8d3cef0 100644
--- a/sysutils/libutempter/Makefile
+++ b/sysutils/libutempter/Makefile
@@ -13,7 +13,6 @@ COMMENT= Interface to record user sessions to utmp and wtmp files
USES= gmake tar:bzip2
USE_LDCONFIG= yes
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 900004
diff --git a/sysutils/libutempter/files/patch-Makefile b/sysutils/libutempter/files/patch-Makefile
index 380890cda3d2..47025fc6dda0 100644
--- a/sysutils/libutempter/files/patch-Makefile
+++ b/sysutils/libutempter/files/patch-Makefile
@@ -1,31 +1,30 @@
---- Makefile.orig 2007-02-19 13:14:08.000000000 +0100
-+++ Makefile 2007-07-17 23:42:11.000000000 +0200
-@@ -30,18 +30,18 @@
+--- Makefile.orig 2007-02-19 12:14:08 UTC
++++ Makefile
+@@ -30,9 +30,9 @@ MAP = lib$(PROJECT).map
TARGETS = $(PROJECT) $(SHAREDLIB) $(STATICLIB)
INSTALL = install
-libdir = /usr/lib
-libexecdir = /usr/lib
-includedir = /usr/include
--DESTDIR =
-+libdir = /lib
-+libexecdir = /libexec
-+includedir = /include
-+DESTDIR = $(PREFIX)
++libdir = $(PREFIX)/lib
++libexecdir = $(PREFIX)/libexec
++includedir = $(PREFIX)/include
+ DESTDIR =
WARNINGS = -W -Wall -Waggregate-return -Wcast-align -Wconversion \
- -Wdisabled-optimization -Wmissing-declarations \
+@@ -40,8 +40,8 @@ WARNINGS = -W -Wall -Waggregate-return -
-Wmissing-format-attribute -Wmissing-noreturn \
-Wmissing-prototypes -Wpointer-arith -Wredundant-decls \
-Wshadow -Wstrict-prototypes -Wwrite-strings
-CPPFLAGS = -std=gnu99 $(WARNINGS) -DLIBEXECDIR=\"$(libexecdir)\"
-CFLAGS = $(RPM_OPT_FLAGS)
+CPPFLAGS = -std=gnu99 $(WARNINGS)
-+CFLAGS+= -DLIBEXECDIR=\"$(PREFIX)$(libexecdir)\"
++CFLAGS+= -DLIBEXECDIR=\"$(libexecdir)\"
LDLIBS =
all: $(TARGETS)
-@@ -63,15 +63,20 @@
+@@ -63,15 +63,20 @@ $(STATICLIB): iface.o
iface.o: iface.c utempter.h