aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-03 16:25:31 +0800
committerantoine <antoine@FreeBSD.org>2017-12-03 16:25:31 +0800
commit8a95dfb7081713d43136314a1408503a79a9464d (patch)
tree19fcb52e1a08c10e10288210eaf522890abc2def
parent326e1340140c5561cf3279055ceed8b18d4d6b69 (diff)
downloadfreebsd-ports-gnome-8a95dfb7081713d43136314a1408503a79a9464d.tar.gz
freebsd-ports-gnome-8a95dfb7081713d43136314a1408503a79a9464d.tar.zst
freebsd-ports-gnome-8a95dfb7081713d43136314a1408503a79a9464d.zip
- Add explicit FLAVOR to a few dependencies
- Remove FLAVOR from py-docutils dependency in comms/uhd, in this case it needs the rst2html command, not the docutils module - Mark some ports as not compatible with python3
-rw-r--r--comms/congruity/Makefile2
-rw-r--r--comms/uhd/Makefile2
-rw-r--r--databases/mtools-mongodb/Makefile2
-rw-r--r--deskutils/anamnesis/Makefile8
-rw-r--r--devel/hg-git/Makefile2
-rw-r--r--devel/py-mongokit/Makefile2
-rw-r--r--finance/electrum2/Makefile4
-rw-r--r--games/craft/Makefile4
-rw-r--r--games/ninix-aya/Makefile4
-rw-r--r--games/ptkei/Makefile4
-rw-r--r--games/pysolfc/Makefile4
-rw-r--r--graphics/commons-utilities/Makefile4
-rw-r--r--misc/gimp-help-en/Makefile2
-rw-r--r--multimedia/mythtv/Makefile14
-rw-r--r--multimedia/pyjama/Makefile10
-rw-r--r--net-im/emesene/Makefile16
-rw-r--r--net-im/telepathy-python/Makefile4
-rw-r--r--net-mgmt/pdagent-integrations/Makefile2
-rw-r--r--net/fb/Makefile8
-rw-r--r--news/papercut/Makefile4
-rw-r--r--ports-mgmt/porttree/Makefile4
-rw-r--r--sysutils/uefi-edk2-bhyve/Makefile2
-rw-r--r--www/py-kallithea/Makefile2
-rw-r--r--www/py-rhodecode/Makefile2
24 files changed, 56 insertions, 56 deletions
diff --git a/comms/congruity/Makefile b/comms/congruity/Makefile
index 40e4dc6de629..00bfebefdd47 100644
--- a/comms/congruity/Makefile
+++ b/comms/congruity/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libconcord>=0:comms/py-libconcord@${PY_FLAVOR}
MAKE_ARGS= MANDIR=${PREFIX}/man
-USES= desktop-file-utils gmake tar:bzip2 python:2.7+
+USES= desktop-file-utils gmake tar:bzip2 python:2.7
USE_WX= 2.8+
WX_COMPS= python
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index 627ab5dbc60b..303911533803 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -14,7 +14,7 @@ COMMENT= Ettus Research UHD driver framework
LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs \
cheetah-analyze:devel/py-cheetah@${PY_FLAVOR} \
- rst2html:textproc/py-docutils@${PY_FLAVOR} \
+ rst2html:textproc/py-docutils \
orcc:devel/orc \
${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR}
diff --git a/databases/mtools-mongodb/Makefile b/databases/mtools-mongodb/Makefile
index 5935e7900f9b..a3a17b2a5bfc 100644
--- a/databases/mtools-mongodb/Makefile
+++ b/databases/mtools-mongodb/Makefile
@@ -14,7 +14,7 @@ COMMENT= Setup test environments; parse, filter and visualize MongoDB log files
LICENSE= APACHE20
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>=2.0:sysutils/py-psutil@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pymongo>0:databases/pymongo \
+ ${PYTHON_PKGNAMEPREFIX}pymongo>0:databases/pymongo@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${FLAVOR}
USE_PYTHON= autoplist distutils
diff --git a/deskutils/anamnesis/Makefile b/deskutils/anamnesis/Makefile
index fbc8dcd8738f..34fa3258d715 100644
--- a/deskutils/anamnesis/Makefile
+++ b/deskutils/anamnesis/Makefile
@@ -12,11 +12,11 @@ COMMENT= Clipboard manager that stores all clipboard history
LICENSE= GPLv3
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}gtk2>0:x11-toolkits/py-gtk2 \
- ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gtk2>0:x11-toolkits/py-gtk2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg@${PY_FLAVOR}
-USES= python shebangfix
+USES= python:2.7 shebangfix
PORTDOCS= ChangeLog README
OPTIONS_DEFINE= DOCS
NO_ARCH= yes
diff --git a/devel/hg-git/Makefile b/devel/hg-git/Makefile
index 781381269b7b..3c8955f1a99d 100644
--- a/devel/hg-git/Makefile
+++ b/devel/hg-git/Makefile
@@ -14,7 +14,7 @@ COMMENT= Mercurial extension to pull from or push to a Git repository
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dulwich>=*:devel/dulwich \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dulwich>=*:devel/dulwich@${FLAVOR} \
mercurial>=*:devel/mercurial
PORTDOCS= README.md
diff --git a/devel/py-mongokit/Makefile b/devel/py-mongokit/Makefile
index 3368804d23ee..7937d73b2e3c 100644
--- a/devel/py-mongokit/Makefile
+++ b/devel/py-mongokit/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= mail@derzinn.de
COMMENT= Python ORM-like layer on top of pymongo
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pymongo>=2.0.1:databases/pymongo
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pymongo>=2.0.1:databases/pymongo@${FLAVOR}
USES= python:2
USE_PYTHON= distutils autoplist
diff --git a/finance/electrum2/Makefile b/finance/electrum2/Makefile
index 858db12ff625..fa0f8719f2d8 100644
--- a/finance/electrum2/Makefile
+++ b/finance/electrum2/Makefile
@@ -41,8 +41,8 @@ OPTIONS_DEFAULT=LEDGER TREZOR
LEDGER_DESC= Enable LEDGER Bitcoin hardware wallet support
TREZOR_DESC= Enable TREZOR Bitcoin hardware wallet support
-LEDGER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}btchip-python>0:security/py-btchip-python
-TREZOR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}trezor>0:security/py-trezor
+LEDGER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}btchip-python>0:security/py-btchip-python@${FLAVOR}
+TREZOR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}trezor>0:security/py-trezor@${FLAVOR}
LEDGER_PLIST_FILES= "@sample etc/devd/ledger_wallet.conf.sample"
TREZOR_PLIST_FILES= "@sample etc/devd/trezor_wallet.conf.sample"
diff --git a/games/craft/Makefile b/games/craft/Makefile
index 1adc271533df..5a83b3bbcfe3 100644
--- a/games/craft/Makefile
+++ b/games/craft/Makefile
@@ -27,8 +27,8 @@ USE_XORG= x11 xi xrandr
USE_GL= gl glu
SERVER_USES= python:2.7
-SERVER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.2:www/py-requests \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3
+SERVER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.2:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR}
SERVER_CMAKE_ON= -DSERVER:BOOL=ON
.include <bsd.port.options.mk>
diff --git a/games/ninix-aya/Makefile b/games/ninix-aya/Makefile
index dd8044c58137..cc5be5dc3245 100644
--- a/games/ninix-aya/Makefile
+++ b/games/ninix-aya/Makefile
@@ -14,12 +14,12 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>0:textproc/py-chardet \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>0:textproc/py-chardet@${PY_FLAVOR} \
${PYNUMPY}
NO_ARCH= yes
-USES= gmake python tar:tgz
+USES= gmake python:2.7 tar:tgz
USE_GNOME= pygtk2
USE_GSTREAMER= python
diff --git a/games/ptkei/Makefile b/games/ptkei/Makefile
index 06291acbf890..f9031425b6ad 100644
--- a/games/ptkei/Makefile
+++ b/games/ptkei/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= SF/ptkei2
MAINTAINER= johans@FreeBSD.org
COMMENT= Python/Tk graphical client for Wolfpack Empire servers
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter \
- ${PYTHON_SITELIBDIR}/Pmw/__init__.py:x11-toolkits/py-Pmw
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/Pmw/__init__.py:x11-toolkits/py-Pmw@${PY_FLAVOR}
USES= python:2.7 shebangfix
SHEBANG_FILES= empire.py scripts/*.py
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
index b53f4e89ba84..f8111d693108 100644
--- a/games/pysolfc/Makefile
+++ b/games/pysolfc/Makefile
@@ -15,8 +15,8 @@ COMMENT= Solitaire game, written in Python and the successor of PySol
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${FLAVOR}
USES= python:2.7 shebangfix tar:bzip2
USE_PYTHON= autoplist distutils
diff --git a/graphics/commons-utilities/Makefile b/graphics/commons-utilities/Makefile
index d3fb58d0d42c..832286e6fc69 100644
--- a/graphics/commons-utilities/Makefile
+++ b/graphics/commons-utilities/Makefile
@@ -16,10 +16,10 @@ RUN_DEPENDS= p5-Image-ExifTool>=0:graphics/p5-Image-ExifTool \
p5-Term-ReadKey>=0:devel/p5-Term-ReadKey \
p5-Text-CSV_XS>=0:textproc/p5-Text-CSV_XS \
p5-Text-CSV-Encoded>=0:textproc/p5-Text-CSV-Encoded \
- ${PYTHON_PKGNAMEPREFIX}mechanize>=0.2:www/py-mechanize \
+ ${PYTHON_PKGNAMEPREFIX}mechanize>=0.2:www/py-mechanize@${PY_FLAVOR} \
exiv2:graphics/exiv2
-USES= jpeg perl5 python shebangfix
+USES= jpeg perl5 python:2.7 shebangfix
SHEBANG_FILES= commons-csv-creator
USE_PERL5= run
NO_BUILD= yes
diff --git a/misc/gimp-help-en/Makefile b/misc/gimp-help-en/Makefile
index 5bc3eb05ee9a..6babed3c1866 100644
--- a/misc/gimp-help-en/Makefile
+++ b/misc/gimp-help-en/Makefile
@@ -16,7 +16,7 @@ COMMENT?= GIMP User Manual in English
LICENSE= GFDL
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:textproc/py-libxml2 \
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:textproc/py-libxml2@${PY_FLAVOR} \
${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:textproc/docbook-xsl
USES= gettext-tools gmake perl5 pkgconfig python:2 shebangfix tar:bzip2
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index d7b0ede13c68..2b6b122a5c0a 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -91,22 +91,22 @@ SUB_FILES= pkg-message
.if ${PORT_OPTIONS:MBINDINGS}
CONFIGURE_ARGS+= --python=${PYTHON_CMD}
-USES+= python
+USES+= python:2.7
PYDISTUTILS_PKGNAME=MythTV
PYDISTUTILS_PKGVERSION=0.27._1
-BUILD_DEPENDS+= py*-lxml>=0:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb \
- ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:www/py-urlgrabber \
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:www/py-urlgrabber@${PY_FLAVOR} \
p5-HTTP-Request-Params>=0:www/p5-HTTP-Request-Params \
p5-LWP-UserAgent-Determined>=0:www/p5-LWP-UserAgent-Determined \
p5-Net-UPnP>=0:multimedia/p5-Net-UPnP \
p5-IO-Socket-INET6>=2.51:net/p5-IO-Socket-INET6 \
p5-DBI>=0:databases/p5-DBI \
p5-DBD-mysql>0:databases/p5-DBD-mysql
-RUN_DEPENDS+= py*-lxml>=0:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb \
- ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:www/py-urlgrabber \
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:www/py-urlgrabber@${PY_FLAVOR} \
p5-HTTP-Request-Params>=0:www/p5-HTTP-Request-Params \
p5-LWP-UserAgent-Determined>=0:www/p5-LWP-UserAgent-Determined \
p5-Net-UPnP>=0:multimedia/p5-Net-UPnP \
diff --git a/multimedia/pyjama/Makefile b/multimedia/pyjama/Makefile
index 76c0b00d0ac8..084e56ab8f2f 100644
--- a/multimedia/pyjama/Makefile
+++ b/multimedia/pyjama/Makefile
@@ -14,12 +14,12 @@ COMMENT= Frontend to the Jamendo music network
LICENSE= GPLv2 CC-BY-NC-SA-3.0 PD
LICENSE_COMB= multi
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}lxml>=2.2:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:devel/py-simplejson \
- ${PYTHON_PKGNAMEPREFIX}gstreamer>=0.10:multimedia/py-gstreamer
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=2.2:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:devel/py-simplejson@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gstreamer>=0.10:multimedia/py-gstreamer@${PY_FLAVOR}
-USES= gettext python shebangfix
+USES= gettext python:2.7 shebangfix
SHEBANG_FILES= src/pyjama.py
USE_GSTREAMER= core good bad gnomevfs
USE_GNOME= pygtk2
diff --git a/net-im/emesene/Makefile b/net-im/emesene/Makefile
index ab6d9aab454a..20a5a51f5322 100644
--- a/net-im/emesene/Makefile
+++ b/net-im/emesene/Makefile
@@ -12,13 +12,13 @@ COMMENT= Instant messenging client written in python
LICENSE= GPLv3+
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython \
- ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus \
- ${PYTHON_PKGNAMEPREFIX}notify>0:devel/py-notify \
- ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}webkitgtk>0:www/py-webkitgtk \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}notify>0:devel/py-notify@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}webkitgtk>0:www/py-webkitgtk@${PY_FLAVOR} \
xprop:x11/xprop
NO_ARCH= yes
@@ -26,7 +26,7 @@ NO_BUILD= yes
USE_GITHUB= yes
-USES= desktop-file-utils gettext-runtime python shebangfix
+USES= desktop-file-utils gettext-runtime python:2.7 shebangfix
USE_GNOME= pygtk2:run
USE_GSTREAMER= python
INSTALLS_ICONS= yes
diff --git a/net-im/telepathy-python/Makefile b/net-im/telepathy-python/Makefile
index bf68fd8d6aea..336b70f447c7 100644
--- a/net-im/telepathy-python/Makefile
+++ b/net-im/telepathy-python/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Python bindings for the Telepathy framework
-BUILD_DEPENDS= py2?-dbus>=0:devel/py-dbus
-RUN_DEPENDS= py2?-dbus>=0:devel/py-dbus
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
USES= gmake python:2
USE_GNOME= libxslt:build
diff --git a/net-mgmt/pdagent-integrations/Makefile b/net-mgmt/pdagent-integrations/Makefile
index 5696c2de2cdf..2b0fd8ef3277 100644
--- a/net-mgmt/pdagent-integrations/Makefile
+++ b/net-mgmt/pdagent-integrations/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pdagent>0:net-mgmt/py-pdagent
-USES= python shebangfix
+USES= python:2.7 shebangfix
USE_GITHUB= yes
GH_ACCOUNT= PagerDuty
diff --git a/net/fb/Makefile b/net/fb/Makefile
index 9ec41f82c19e..9ac8c63df4cd 100644
--- a/net/fb/Makefile
+++ b/net/fb/Makefile
@@ -11,11 +11,11 @@ COMMENT= Client for paste.xinu.at
LICENSE= GPLv3
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyliblzma>0:archivers/py-pyliblzma \
- ${PYTHON_PKGNAMEPREFIX}pycurl>0:ftp/py-pycurl \
- ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyliblzma>0:archivers/py-pyliblzma@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycurl>0:ftp/py-pycurl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg@${PY_FLAVOR}
-USES= python shebangfix
+USES= python:2.7 shebangfix
NO_ARCH= yes
SHEBANG_FILES= ${WRKSRC}/fb
diff --git a/news/papercut/Makefile b/news/papercut/Makefile
index acbe2e1ddeeb..77e2a8ed0ceb 100644
--- a/news/papercut/Makefile
+++ b/news/papercut/Makefile
@@ -13,9 +13,9 @@ COMMENT= Papercut is a news server written in Python, using a MySQL backend
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb@${PY_FLAVOR}
-USES= python shebangfix
+USES= python:2.7 shebangfix
NO_BUILD= yes
NO_ARCH= yes
SHEBANG_FILES= *.py auth/*.py storage/*.py
diff --git a/ports-mgmt/porttree/Makefile b/ports-mgmt/porttree/Makefile
index 4097bfe1cfd9..bcda290171b5 100644
--- a/ports-mgmt/porttree/Makefile
+++ b/ports-mgmt/porttree/Makefile
@@ -12,9 +12,9 @@ COMMENT= Show dependences of FreeBSD port as pseudo graphical tree
LICENSE= MIT
-USES= python tar:bzip2 shebangfix
+USES= python:2.7 tar:bzip2 shebangfix
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}networkx>=1.5:math/py-networkx
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}networkx>=1.5:math/py-networkx@${PY_FLAVOR}
.if target(gen-dist)
FETCH_DEPENDS+= svn:devel/subversion
diff --git a/sysutils/uefi-edk2-bhyve/Makefile b/sysutils/uefi-edk2-bhyve/Makefile
index 85b75513ba96..3ab42f0b17c4 100644
--- a/sysutils/uefi-edk2-bhyve/Makefile
+++ b/sysutils/uefi-edk2-bhyve/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD2CLAUSE
BUILD_DEPENDS= bash:shells/bash \
nasm:devel/nasm \
- ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:databases/py-sqlite3
+ ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:databases/py-sqlite3@${PY_FLAVOR}
USES= gmake \
python:2.7,build
diff --git a/www/py-kallithea/Makefile b/www/py-kallithea/Makefile
index 2b4c00652583..ef471b6f79e4 100644
--- a/www/py-kallithea/Makefile
+++ b/www/py-kallithea/Makefile
@@ -35,7 +35,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}waitress>=0.8.8:www/py-waitress@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urlobject>=2.3.4:www/py-urlobject@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}routes>=1.13:www/py-routes@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dulwich>=0.9.9:devel/dulwich \
+ ${PYTHON_PKGNAMEPREFIX}dulwich>=0.9.9:devel/dulwich@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bcrypt>=0.3.0:security/py-bcrypt@${FLAVOR} \
mercurial>=2.9:devel/mercurial
diff --git a/www/py-rhodecode/Makefile b/www/py-rhodecode/Makefile
index 06ad3ae6c721..b6dc191c4294 100644
--- a/www/py-rhodecode/Makefile
+++ b/www/py-rhodecode/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pylons>=1.0:www/py-pylons@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}whoosh>=2.4.0:textproc/py-whoosh@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Babel>=0.9.6:devel/py-babel@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=1.5:devel/py-dateutil@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dulwich>=0.8.7:devel/dulwich \
+ ${PYTHON_PKGNAMEPREFIX}dulwich>=0.8.7:devel/dulwich@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}markdown>=2.2.1:textproc/py-markdown@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}docutils>=0.8.1:textproc/py-docutils@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${FLAVOR} \