aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-09-04 10:04:45 +0800
committerjylefort <jylefort@FreeBSD.org>2005-09-04 10:04:45 +0800
commit8b323e47bbca1ead8c933f9c5964311e79b3aacf (patch)
tree8a6a7aa1b3e64b65ba1747162c3a41c47f11001a
parent8f34d8fe4f844dd2c86cf7a8f370be9762987606 (diff)
downloadfreebsd-ports-gnome-8b323e47bbca1ead8c933f9c5964311e79b3aacf.tar.gz
freebsd-ports-gnome-8b323e47bbca1ead8c933f9c5964311e79b3aacf.tar.zst
freebsd-ports-gnome-8b323e47bbca1ead8c933f9c5964311e79b3aacf.zip
If X_WINDOW_SYSTEM is xfree86-3, depend on graphics/linux_glx.
-rw-r--r--games/linux-virtual-jay-peak/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/games/linux-virtual-jay-peak/Makefile b/games/linux-virtual-jay-peak/Makefile
index fff2d9bdbec0..3f53e94f1bc2 100644
--- a/games/linux-virtual-jay-peak/Makefile
+++ b/games/linux-virtual-jay-peak/Makefile
@@ -15,12 +15,6 @@ DISTNAME= virtual_jay_peak_linux_1_1a
MAINTAINER= jylefort@FreeBSD.org
COMMENT= A simulation of snowboarding at the Jay Peak resort in Vermont
-.if defined(WITH_NVIDIA_GL)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
-.else
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
-.endif
-
WRKSRC= ${WRKDIR}/soulride
ONLY_FOR_ARCHS= i386
USE_X_PREFIX= yes
@@ -48,4 +42,16 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
+.if defined(WITH_NVIDIA_GL)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+.endif
+.else
+RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so.1:${PORTSDIR}/graphics/linux_glx
+.endif
+
+.include <bsd.port.post.mk>