aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-08-26 14:35:58 +0800
committerbapt <bapt@FreeBSD.org>2013-08-26 14:35:58 +0800
commit8b8f4bf32933ca619a1709fc87429fc2c18c65bf (patch)
tree413aae0ffa218d35ed17a1fd414b854bcc34b53d
parent173bc2544f240979a259f94398fd234c5ec9b506 (diff)
downloadfreebsd-ports-gnome-8b8f4bf32933ca619a1709fc87429fc2c18c65bf.tar.gz
freebsd-ports-gnome-8b8f4bf32933ca619a1709fc87429fc2c18c65bf.tar.zst
freebsd-ports-gnome-8b8f4bf32933ca619a1709fc87429fc2c18c65bf.zip
fix build without gcc in base
Always use gcc whatever the default compiler is to build openjdk (it needs gcc -dumpspecs) Define HOST_CC to ${CC} to make avoir direct call to "/usr/bin/gcc"
-rw-r--r--java/openjdk7/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index cd980999b2ee..7b996df7d9b9 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: openjdk7
-# Date created: 2 January 2010
-# Whom: Greg Lewis <glewis@FreeBSD.org>
-#
+# Created by: Greg Lewis <glewis@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${PORT_MINOR_VERSION}.${PORT_BUILD_NUMBER}
@@ -29,10 +25,11 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_ZIP= yes
-USE_GMAKE= yes
-USES= iconv
+USES= iconv gmake
USE_XORG+= x11 xext xi xrender xt xtst
+MAKE_ARGS= CC=${CC} CXX=${CXX} HOST_CC=${CC}
MAKE_JOBS_UNSAFE= yes
+USE_GCC= any
OPTIONS_DEFINE= DEBUG POLICY TZUPDATE
OPTIONS_DEFAULT= POLICY TZUPDATE