aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-14 00:05:48 +0800
committerantoine <antoine@FreeBSD.org>2017-12-14 00:05:48 +0800
commit8baa14e264b4d93309c75c29a7eae5101304b37d (patch)
tree327fdff56dc4779407a7a80f5e68d09784124ee9
parent096d959851db69121a0ae6f42a205c8471a38abf (diff)
downloadfreebsd-ports-gnome-8baa14e264b4d93309c75c29a7eae5101304b37d.tar.gz
freebsd-ports-gnome-8baa14e264b4d93309c75c29a7eae5101304b37d.tar.zst
freebsd-ports-gnome-8baa14e264b4d93309c75c29a7eae5101304b37d.zip
- Those ports fail to build with python3
- Add some explicit FLAVOR to dependencies where needed - For totem, the pylint command is needed, not the pylint module
-rw-r--r--deskutils/gnome-documents/Makefile4
-rw-r--r--deskutils/spice-gtk/Makefile3
-rw-r--r--multimedia/totem/Makefile2
-rw-r--r--net/cjdns/Makefile2
-rw-r--r--print/system-config-printer/Makefile4
5 files changed, 8 insertions, 7 deletions
diff --git a/deskutils/gnome-documents/Makefile b/deskutils/gnome-documents/Makefile
index 2c73575ebcc8..82ac70ee2aff 100644
--- a/deskutils/gnome-documents/Makefile
+++ b/deskutils/gnome-documents/Makefile
@@ -25,14 +25,14 @@ LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libgjs.so:lang/gjs \
libtracker-sparql-1.0.so:sysutils/tracker \
libzapojit-0.0.so:net/libzapojit
-RUN_DEPENDS= py2?-dbus>0:devel/py-dbus \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss \
unoconv:textproc/unoconv
PORTSCOUT= limitw:1,even
USES= compiler:c++11-lib gettext gmake gnome libtool pathfix \
- pkgconfig tar:xz
+ pkgconfig python:2.7 tar:xz
USE_GNOME= gnomedesktop3 gtk30 intlhack \
introspection:build librsvg2 libxml2
GNU_CONFIGURE= yes
diff --git a/deskutils/spice-gtk/Makefile b/deskutils/spice-gtk/Makefile
index 7de50c6a148d..34985f8ff973 100644
--- a/deskutils/spice-gtk/Makefile
+++ b/deskutils/spice-gtk/Makefile
@@ -19,13 +19,14 @@ USES= autoreconf cpe gmake jpeg libtool pkgconfig tar:bzip2 \
CPE_VENDOR= redhat
BUILD_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol \
- ${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.1:devel/py-pyparsing
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.1:devel/py-pyparsing@${PY_FLAVOR}
RUN_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol
.if defined(SPICE_SLAVE)
PORTREVISION= 1
CATEGORIES+= python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+USES:= ${USES:Npython} python:2.7
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:x11-toolkits/py-gtk2
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:x11-toolkits/py-gtk2
CONFIGURE_ARGS+= --with-python
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 134e9f1c1051..b688767253b6 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -13,7 +13,7 @@ COMMENT= Gstreamer-based video player for the GNOME 3 Desktop
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:misc/gnome-icon-theme \
- pylint${PYTHON_PKGNAMESUFFIX}>=0:devel/pylint \
+ pylint:devel/pylint \
appstream-glib>=0:devel/appstream-glib \
itstool:textproc/itstool \
grilo-plugins2>=0:net/grilo-plugins2
diff --git a/net/cjdns/Makefile b/net/cjdns/Makefile
index a5d8ea0198a1..bff9afe52c67 100644
--- a/net/cjdns/Makefile
+++ b/net/cjdns/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= node:www/node \
USE_GITHUB= yes
GH_ACCOUNT= cjdelisle
-USES= gmake python
+USES= gmake python:2.7
USE_RC_SUBR= cjdns
SUB_FILES= cjdns pkg-message
SUB_LIST= LOCALBASE=${LOCALBASE}
diff --git a/print/system-config-printer/Makefile b/print/system-config-printer/Makefile
index 74a0e3621ea8..27a4f25e9534 100644
--- a/print/system-config-printer/Makefile
+++ b/print/system-config-printer/Makefile
@@ -13,8 +13,8 @@ COMMENT= CUPS configuration Gtk+2.0 GUI
BUILD_DEPENDS= xmlto:textproc/xmlto \
docbook-xml>0:textproc/docbook-xml
LIB_DEPENDS= libcups.so:print/cups
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cups.so:print/py-pycups \
- ${PYTHON_SITELIBDIR}/pycurl.so:ftp/py-pycurl \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycups>=0:print/py-pycups@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycurl>=0:ftp/py-pycurl@${PY_FLAVOR} \
${LOCALBASE}/libexec/cups-pk-helper-mechanism:print/cups-pk-helper
# 1.5 series is python3 ignore them for now.