aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2012-02-12 14:02:52 +0800
committerdanfe <danfe@FreeBSD.org>2012-02-12 14:02:52 +0800
commit8d69c100b8033c3ff3abed08ccb6714d10aca203 (patch)
tree27f3bb7a603a578626db73eb1fda5b32ee3f8f31
parent9f72c9681fc15d9f16ac2b38c4b10c056dcb088e (diff)
downloadfreebsd-ports-gnome-8d69c100b8033c3ff3abed08ccb6714d10aca203.tar.gz
freebsd-ports-gnome-8d69c100b8033c3ff3abed08ccb6714d10aca203.tar.zst
freebsd-ports-gnome-8d69c100b8033c3ff3abed08ccb6714d10aca203.zip
- Do not force our CFLAGS in src/backend, it must be compiled with -O0, or
smartdimmer will fail with "init_nvclock() failed!" message; bump port revision due to importance of this change (fixing a run-time crash) - Define LICENSE (GPLv2) and cleanup Makefile a bit while I am here Reported by: Lucas Hosseini
-rw-r--r--sysutils/nvclock/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/sysutils/nvclock/Makefile b/sysutils/nvclock/Makefile
index 6de766fa33ca..3feb9a7ba60c 100644
--- a/sysutils/nvclock/Makefile
+++ b/sysutils/nvclock/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nvclock
DISTVERSION= 0.8b4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.8%20%28beta4%29
DISTNAME= nvclock${DISTVERSION}
@@ -15,16 +15,17 @@ DISTNAME= nvclock${DISTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= NVidia graphic card status and overclocking tool
+LICENSE= GPLv2
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
-PLIST_FILES= bin/nvclock \
- bin/smartdimmer
+PLIST_FILES= bin/nvclock bin/smartdimmer
MAN1= nvclock.1
PORTDOCS= ABOUT AUTHORS ChangeLog FAQ README
OPTIONS= NVCONTROL "Enable NV-CONTROL support" on \
- GTK2 "Build GTK user interface" on \
+ GTK "Build GTK+ user interface" on \
QT "Build Qt 3.x user interface" off
.include <bsd.port.options.mk>
@@ -36,7 +37,7 @@ USE_GNOME= pkgconfig
CONFIGURE_ARGS+= --disable-nvcontrol
.endif
-.if defined(WITH_GTK2)
+.if defined(WITH_GTK)
USE_GNOME= gtk20
PLIST_FILES+= bin/nvclock_gtk
.else
@@ -50,8 +51,8 @@ PLIST_FILES+= bin/nvclock_qt
.endif
post-patch:
+# Uphold our C[XX]FLAGS except for backend part, it must be compiled with -O0
@${REINPLACE_CMD} -E 's|^(C(XX)?FLAGS)=|\1+=|' \
- ${WRKSRC}/src/backend/Makefile.in \
${WRKSRC}/src/gtk/Makefile.in \
${WRKSRC}/src/qt/Makefile.in \
${WRKSRC}/src/nvcontrol/Makefile.in