aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-08-21 22:58:55 +0800
committerkoobs <koobs@FreeBSD.org>2014-08-21 22:58:55 +0800
commit8ed56e8e1cc10eacd7658fa48f353a9d263c2e08 (patch)
treeecb0a6537a902edefef93a3ce0cc6c003c88cda4
parentaed182e5db2726c9376ecf2621881dbd0171e264 (diff)
downloadfreebsd-ports-gnome-8ed56e8e1cc10eacd7658fa48f353a9d263c2e08.tar.gz
freebsd-ports-gnome-8ed56e8e1cc10eacd7658fa48f353a9d263c2e08.tar.zst
freebsd-ports-gnome-8ed56e8e1cc10eacd7658fa48f353a9d263c2e08.zip
security/libprelude: Take MAINTAINER'ship, STAGE & Modernize
- Take Maintainership - Enable STAGE support - Tweak MASTER_SITES https -> http (portlint) - Add LICENSE and LICENSE_FILE - Deprecate USE_AUTOTOOLS for libtool (-> USES) - Sort USES and OPTIONS - Use OPTIONS helpers as much as possible for now [1] - Add --enable-static to CONFIGURE_ARGS to retain the static lib - Assign and Use ETCDIR rather than hardcoding - Use the install-strip install target - Update pkg-plist, use @sample and other goodies While I'm here, bump dependent ports since our SHLIB major version has changed [1] https://reviews.freebsd.org/D665 Approved by: portmgr (implicit, bump unstaged port)
-rw-r--r--net/nepenthes/Makefile2
-rw-r--r--security/libprelude/Makefile64
-rw-r--r--security/libprelude/pkg-plist31
-rw-r--r--security/libpreludedb/Makefile2
-rw-r--r--security/prelude-lml/Makefile2
-rw-r--r--security/prelude-manager/Makefile2
-rw-r--r--security/prelude-pflogger/Makefile2
-rw-r--r--security/samhain/Makefile1
-rw-r--r--security/suricata/Makefile2
-rw-r--r--www/py-prewikka/Makefile1
10 files changed, 50 insertions, 59 deletions
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index 0fb687b7dc3f..105e1c88d1f7 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nepenthes
PORTVERSION= 0.2.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/Nepenthes%20development/${PORTVERSION}
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index ce115d8b38f7..b2ad8d379c1c 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -3,13 +3,16 @@
PORTNAME= libprelude
PORTVERSION= 1.0.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security
-MASTER_SITES= https://www.prelude-ids.org/attachments/download/241/
+MASTER_SITES= http://www.prelude-ids.org/attachments/download/241/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= koobs@FreeBSD.org
COMMENT= Framework library for Prelude NIDS
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.README
+
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
libgnutls.so:${PORTSDIR}/security/gnutls \
libgcrypt.so:${PORTSDIR}/security/libgcrypt \
@@ -17,40 +20,34 @@ LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
libnettle.so:${PORTSDIR}/security/nettle \
libp11-kit.so:${PORTSDIR}/security/p11-kit
-OPTIONS_DEFINE= PERL PYTHON DOCS
+OPTIONS_DEFINE= DOCS PERL PYTHON
+OPTIONS_SUB= yes
-USE_AUTOTOOLS= libtool libltdl
-CONFIGURE_ARGS= --localstatedir=/var \
+USES= charsetfix gettext gmake iconv libtool pathfix pkgconfig
+USE_AUTOTOOLS= libltdl
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-static \
+ --localstatedir=/var \
--enable-gtk-doc=no \
--with-html-dir=${PREFIX}/share/doc
-USES= pathfix pkgconfig gettext iconv charsetfix gmake
-USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
-MAN1= prelude-admin.1
+ETCDIR= ${PREFIX}/etc/prelude
PORTDOCS= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+PERL_CONFIGURE_WITH= perl
+PERL_USES= perl5
+PYTHON_CONFIGURE_WITH= python
+PYTHON_USES= python
-.if ${PORT_OPTIONS:MPERL}
-USES+= perl5
-CONFIGURE_ARGS+=--with-perl
-PLIST_SUB+= PERL=""
-.else
-CONFIGURE_ARGS+=--without-perl
-PLIST_SUB+= PERL="@comment "
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
-CONFIGURE_ARGS+=--with-python
-PLIST_SUB+= PYTHON="" PYTHON_VER="${PYTHON_VER}" VERSION="${PORTVERSION}"
-.else
-CONFIGURE_ARGS+=--without-python
-PLIST_SUB+= PYTHON="@comment "
+PLIST_SUB+= PYTHON_VER="${PYTHON_VER}" VERSION="${PORTVERSION}"
.endif
.include <bsd.port.pre.mk>
@@ -60,27 +57,26 @@ BROKEN= Does not compile
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- '/^install-data-am:/s|install-data-local||' ${WRKSRC}/docs/api/Makefile.in
@${REINPLACE_CMD} '\,gnutls/extra\.h,d' \
${WRKSRC}/prelude-admin/prelude-admin.c \
${WRKSRC}/prelude-admin/server.c
post-install:
- ${INSTALL_MAN} ${WRKSRC}/docs/manpages/*.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/docs/manpages/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
.for f in client.conf global.conf idmef-client.conf tls.conf
${INSTALL_DATA} ${WRKSRC}/${f} \
- ${PREFIX}/etc/prelude/default/${f}-dist
-.if !exists(${PREFIX}/etc/prelude/default/${f})
- (cd ${PREFIX}/etc/prelude/default && ${CP} -p ${f}-dist ${f})
-.endif
+ ${STAGEDIR}${ETCDIR}/default/${f}.sample
+ ${RM} ${STAGEDIR}${ETCDIR}/default/${f} # Remove files install-data-local installs
.endfor
+
.if ${PORT_OPTIONS:MPERL}
-@${RM} -f ${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal.pod
.endif
+
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/security/libprelude/pkg-plist b/security/libprelude/pkg-plist
index 512ce14fdf18..6fe2bdd7c8e9 100644
--- a/security/libprelude/pkg-plist
+++ b/security/libprelude/pkg-plist
@@ -1,18 +1,10 @@
bin/libprelude-config
bin/prelude-adduser
bin/prelude-admin
-@unexec if cmp -s %D/etc/prelude/default/client.conf %D/etc/prelude/default/client.conf-dist; then rm -f %D/etc/prelude/default/client.conf; fi
-etc/prelude/default/client.conf-dist
-@exec if [ ! -f %D/etc/prelude/default/client.conf ] ; then cp -p %D/%F %B/client.conf; fi
-@unexec if cmp -s %D/etc/prelude/default/global.conf %D/etc/prelude/default/global.conf-dist; then rm -f %D/etc/prelude/default/global.conf; fi
-etc/prelude/default/global.conf-dist
-@exec if [ ! -f %D/etc/prelude/default/global.conf ] ; then cp -p %D/%F %B/global.conf; fi
-@unexec if cmp -s %D/etc/prelude/default/idmef-client.conf %D/etc/prelude/default/idmef-client.conf-dist; then rm -f %D/etc/prelude/default/idmef-client.conf; fi
-etc/prelude/default/idmef-client.conf-dist
-@exec if [ ! -f %D/etc/prelude/default/idmef-client.conf ] ; then cp -p %D/%F %B/idmef-client.conf; fi
-@unexec if cmp -s %D/etc/prelude/default/tls.conf %D/etc/prelude/default/tls.conf-dist; then rm -f %D/etc/prelude/default/tls.conf; fi
-etc/prelude/default/tls.conf-dist
-@exec if [ ! -f %D/etc/prelude/default/tls.conf ] ; then cp -p %D/%F %B/tls.conf; fi
+@sample %%ETCDIR%%/default/client.conf.sample
+@sample %%ETCDIR%%/default/global.conf.sample
+@sample %%ETCDIR%%/default/idmef-client.conf.sample
+@sample %%ETCDIR%%/default/tls.conf.sample
include/libprelude/common.h
include/libprelude/daemonize.h
include/libprelude/idmef.h
@@ -72,13 +64,14 @@ include/libprelude/prelude-string.h
include/libprelude/prelude-thread.h
include/libprelude/prelude-timer.h
lib/libprelude.a
-lib/libprelude.la
lib/libprelude.so
-lib/libprelude.so.21
+lib/libprelude.so.2
+lib/libprelude.so.2.19.1
lib/libpreludecpp.a
-lib/libpreludecpp.la
lib/libpreludecpp.so
-lib/libpreludecpp.so.3
+lib/libpreludecpp.so.0
+lib/libpreludecpp.so.0.3.0
+man/man1/prelude-admin.1.gz
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Prelude.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude/.packlist
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude/Prelude.so
@@ -96,8 +89,8 @@ share/aclocal/libprelude.m4
%%PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeEasy
%%PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude
@dirrm include/libprelude
-@dirrm etc/prelude/default
-@dirrmtry etc/prelude/profile
-@dirrmtry etc/prelude
+@dirrmtry %%ETCDIR%%/default
+@dirrmtry %%ETCDIR%%/profile
+@dirrmtry %%ETCDIR%%
@exec install -d -o root -g wheel -m 711 /var/spool/prelude
@unexec rmdir /var/spool/prelude 2>/dev/null || true
diff --git a/security/libpreludedb/Makefile b/security/libpreludedb/Makefile
index 96e39c42c3a0..a69442ac991c 100644
--- a/security/libpreludedb/Makefile
+++ b/security/libpreludedb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libpreludedb
PORTVERSION= 1.0.1p1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security
MASTER_SITES= https://www.prelude-ids.org/attachments/download/287/
diff --git a/security/prelude-lml/Makefile b/security/prelude-lml/Makefile
index 6f690f552e1f..6bf3667557a4 100644
--- a/security/prelude-lml/Makefile
+++ b/security/prelude-lml/Makefile
@@ -3,7 +3,7 @@
PORTNAME= prelude-lml
PORTVERSION= 1.0.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= security
MASTER_SITES= https://www.prelude-ids.org/attachments/download/242/
diff --git a/security/prelude-manager/Makefile b/security/prelude-manager/Makefile
index a6fb80fcbf55..beb94bb4b7a2 100644
--- a/security/prelude-manager/Makefile
+++ b/security/prelude-manager/Makefile
@@ -3,7 +3,7 @@
PORTNAME= prelude-manager
PORTVERSION= 1.0.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security
MASTER_SITES= https://www.prelude-ids.org/attachments/download/243/
diff --git a/security/prelude-pflogger/Makefile b/security/prelude-pflogger/Makefile
index 1e16dafd3e37..26d4d41a1e11 100644
--- a/security/prelude-pflogger/Makefile
+++ b/security/prelude-pflogger/Makefile
@@ -3,7 +3,7 @@
PORTNAME= prelude-pflogger
DISTVERSION= 0.9.0-rc2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= http://www.prelude-ids.com/download/releases/${PORTNAME}/
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index b3534b26aeba..0d9374b6111e 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -3,6 +3,7 @@
PORTNAME= samhain
PORTVERSION= 3.0.13
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://la-samhna.de/archive/ \
http://redundancy.redundancy.org/mirror/
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index a916a9d064e3..83d4114465ee 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -3,7 +3,7 @@
PORTNAME= suricata
PORTVERSION= 1.4.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://www.openinfosecfoundation.org/download/ \
http://mirrors.rit.edu/zi/
diff --git a/www/py-prewikka/Makefile b/www/py-prewikka/Makefile
index efa570d51989..a97353be25c8 100644
--- a/www/py-prewikka/Makefile
+++ b/www/py-prewikka/Makefile
@@ -3,6 +3,7 @@
PORTNAME= prewikka
PORTVERSION= 1.0.1p1
+PORTREVISION= 1
CATEGORIES= www security python
MASTER_SITES= https://www.prelude-ids.org/attachments/download/286/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}