aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2007-03-18 01:02:33 +0800
committerclement <clement@FreeBSD.org>2007-03-18 01:02:33 +0800
commit8fa7e6013955588a1ce3271cddd84d693e1251b3 (patch)
tree7c1ce26565b20c488eb8f2b84a1ddad6446ba921
parent2ca1b4ccc46b1e025006f78b36bf14fb1aea9018 (diff)
downloadfreebsd-ports-gnome-8fa7e6013955588a1ce3271cddd84d693e1251b3.tar.gz
freebsd-ports-gnome-8fa7e6013955588a1ce3271cddd84d693e1251b3.tar.zst
freebsd-ports-gnome-8fa7e6013955588a1ce3271cddd84d693e1251b3.zip
- backout OpenSSL part of previous commit.
Forcing -rpath can lead to strange side effects when using apxs
-rw-r--r--www/apache22/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index e10af55e2733..b88768c24746 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/%SUBDIR%\//clement\/:aprmysql/}
@@ -90,6 +90,10 @@ CONFIGURE_ARGS+= --enable-v4-mapped
. endif
.endif
+.if !defined(WITHOUT_SSL_MODULES)
+USE_OPENSSL= yes
+.endif
+
.if defined(WITH_STATIC_SUPPORT)
CONFIGURE_ARGS+= --enable-static-support
.endif
@@ -124,11 +128,6 @@ CONFIGURE_ARGS+= --with-ldap \
.include "${APACHEDIR}/Makefile.modules"
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_SSL_MODULES)
-USE_OPENSSL_RPATH=yes
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-.endif
-
.if defined(WITH_APR_FROM_PORTS)
PLIST_SUB+= APR_PORTS="@comment "
LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr