aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2017-02-25 01:57:08 +0800
committerdim <dim@FreeBSD.org>2017-02-25 01:57:08 +0800
commit92fe6f7efd74bafffba624075d430728e7d8a50e (patch)
tree65a7c34fafb5cffb64378f4da68ea5a02d049b0e
parente16bf492d50fb3e9221d67779c7056010eb4e153 (diff)
downloadfreebsd-ports-gnome-92fe6f7efd74bafffba624075d430728e7d8a50e.tar.gz
freebsd-ports-gnome-92fe6f7efd74bafffba624075d430728e7d8a50e.tar.zst
freebsd-ports-gnome-92fe6f7efd74bafffba624075d430728e7d8a50e.zip
Remove the devel/libc++ and devel/libcxxrt ports.
Since all supported versions of FreeBSD now have libc++ and libcxxrt in the base system, and these ports were outdated, remove them, and update any ports that still depended on them: * graphics/gnash * textproc/hs-double-conversion * x11-toolkits/hs-wxc * math/parmetis Approved by: portmgr (antoine) Exp-run by: antoine PR: 217257 MFH: 2017Q1
-rw-r--r--MOVED2
-rw-r--r--devel/Makefile2
-rw-r--r--devel/libc++/Makefile73
-rw-r--r--devel/libc++/Makefile.svn_rev1
-rw-r--r--devel/libc++/distinfo2
-rw-r--r--devel/libc++/files/patch-include____config37
-rw-r--r--devel/libc++/files/patch-include____locale32
-rw-r--r--devel/libc++/files/patch-include__support__solaris__xlocale.h13
-rw-r--r--devel/libc++/files/patch-include_locale11
-rw-r--r--devel/libc++/files/patch-include_type__traits25
-rw-r--r--devel/libc++/files/patch-src__string.cpp10
-rw-r--r--devel/libc++/files/patch-src__support__solaris__xlocale.c11
-rw-r--r--devel/libc++/files/patch-src_locale.cpp11
-rw-r--r--devel/libc++/files/patch-test_utilities_meta_meta.unary_meta.unary.cat_function.pass.cpp58
-rw-r--r--devel/libc++/pkg-descr4
-rw-r--r--devel/libc++/pkg-plist237
-rw-r--r--devel/libcxxrt/Makefile26
-rw-r--r--devel/libcxxrt/distinfo2
-rw-r--r--devel/libcxxrt/pkg-descr8
-rw-r--r--devel/libcxxrt/pkg-plist11
-rw-r--r--graphics/gnash/Makefile3
-rw-r--r--math/parmetis/Makefile7
-rw-r--r--textproc/hs-double-conversion/Makefile1
-rw-r--r--x11-toolkits/hs-wxc/Makefile4
24 files changed, 4 insertions, 587 deletions
diff --git a/MOVED b/MOVED
index 92fd4070ca75..754b49f7a3c9 100644
--- a/MOVED
+++ b/MOVED
@@ -9086,3 +9086,5 @@ net/nos-ttb||2017-02-20|Has expired: does not work due to protocol changes
sysutils/filebeat|sysutils/beats|2017-02-21|merged beats to one port
sysutils/metricbeat|sysutils/beats|2017-02-21|merged beats to one port
sysutils/packetbeat|sysutils/beats|2017-02-21|merged beats to one port
+devel/libc++||2017-02-24|Obsolete, all supported FreeBSD versions have libc++ in the base system
+devel/libcxxrt||2017-02-24|Obsolete, all supported FreeBSD versions have libcxxrt in the base system
diff --git a/devel/Makefile b/devel/Makefile
index d4babaace615..94b120068922 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1226,7 +1226,6 @@
SUBDIR += libbrotli
SUBDIR += libbson
SUBDIR += libburn
- SUBDIR += libc++
SUBDIR += libccid
SUBDIR += libcfg
SUBDIR += libcfu
@@ -1242,7 +1241,6 @@
SUBDIR += libcrossguid
SUBDIR += libcutl
SUBDIR += libcwd
- SUBDIR += libcxxrt
SUBDIR += libdaemon
SUBDIR += libdap
SUBDIR += libdatrie
diff --git a/devel/libc++/Makefile b/devel/libc++/Makefile
deleted file mode 100644
index fb1e0997740c..000000000000
--- a/devel/libc++/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# Created by: Koop Mast <kwm@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME?= libc++
-DISTNAME= libc++-${PORTVERSION}
-PORTVERSION= ${SVN_REV}
-CATEGORIES= devel
-MASTER_SITES= http://files.etoilebsd.net/libc++/ \
- LOCAL/bapt
-
-MAINTAINER= dim@FreeBSD.org
-COMMENT?= LLVM C++ standard library with c++11 support
-
-USES= tar:xz
-
-.ifndef MASTERDIR
-LICENSE_GROUP= MIT UIUC
-LICENSE_NAME_UIUC= University of Illinois/NCSA Open Source License
-LICENSE_PERMS_UIUC= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-
-USES+= cmake:outsource compiler:c++11-lang
-USE_LDCONFIG= yes
-LDFLAGS+= -L${LOCALBASE}/lib
-
-.if exists(/usr/lib/libcxxrt.so)
-CXXRT_INCS= /usr/include/c++/v1/
-CXXRT_LIB= /usr/lib/libcxxrt.so
-.else
-CXXRT_INCS= ${LOCALBASE}/include/cxxrt/
-CXXRT_LIB= ${LOCALBASE}/lib/libcxxrt.so
-LIB_DEPENDS+= libcxxrt.so:devel/libcxxrt
-.endif
-
-.include <bsd.port.options.mk>
-
-CMAKE_ARGS= -DLIBCXX_CXX_ABI=libcxxrt -DLIBCXX_LIBCXXRT_INCLUDE_PATHS=${CXXRT_INCS}
-
-.if !defined(SVN_REV)
-.if defined(BOOTSTRAP)
-SVN_REV!= svn info http://llvm.org/svn/llvm-project/ | ${GREP} Revision | cut -d' ' -f2
-.else
-.include "Makefile.svn_rev"
-.endif
-.endif
-
-.if defined(BOOTSTRAP) || defined(SVN_FETCH)
-FETCH_DEPENDS+= svn:devel/subversion
-
-post-patch:
- # remove .orig files because they can get installed in stagedir
- @${FIND} ${WRKSRC} -name "*.orig" -type f -delete
-
-do-fetch:
- ${MKDIR} ${WRKDIR}
- svn export -r ${SVN_REV} \
- http://llvm.org/svn/llvm-project/libcxx/trunk \
- ${WRKSRC}
- cd ${WRKDIR}; tar cfJ ${DISTDIR}/${DISTNAME}.tar.xz ${DISTNAME}
- echo "SVN_REV= ${SVN_REV}" > ${MASTERDIR}/Makefile.svn_rev
-.endif
-
-post-install:
- ${LN} -sf c++/v1 ${STAGEDIR}${PREFIX}/include/c++/v1/tr1
- ${RM} ${STAGEDIR}${PREFIX}/lib/libc++.so
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/c++/
- ${ECHO} 'GROUP ( ${PREFIX}/lib/libc++.so.1 ${CXXRT_LIB} ${EXTRALIB})' > ${STAGEDIR}${PREFIX}/lib/libc++.so
- ${ECHO} 'GROUP ( ${PREFIX}/lib/libc++.so.1 ${CXXRT_LIB} ${EXTRALIB})' > ${STAGEDIR}${PREFIX}/lib/c++/libstdc++.so
-
-regression-test: build
- cd ${WRKSRC}/test && ${SH} ./testit
-
-.endif
-.include <bsd.port.mk>
diff --git a/devel/libc++/Makefile.svn_rev b/devel/libc++/Makefile.svn_rev
deleted file mode 100644
index 2e7e1b9d4fc4..000000000000
--- a/devel/libc++/Makefile.svn_rev
+++ /dev/null
@@ -1 +0,0 @@
-SVN_REV= 208080
diff --git a/devel/libc++/distinfo b/devel/libc++/distinfo
deleted file mode 100644
index 7e4840c7d9c2..000000000000
--- a/devel/libc++/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (libc++-208080.tar.xz) = e764167cef1b73f03f2e736eedb2d45d0d2247590de8c878f8ca0bba6f2a9cfc
-SIZE (libc++-208080.tar.xz) = 867788
diff --git a/devel/libc++/files/patch-include____config b/devel/libc++/files/patch-include____config
deleted file mode 100644
index 5cbf2b96606a..000000000000
--- a/devel/libc++/files/patch-include____config
+++ /dev/null
@@ -1,37 +0,0 @@
---- include/__config.orig 2014-04-14 15:44:57 UTC
-+++ include/__config
-@@ -42,7 +42,7 @@
- #endif // __BIG_ENDIAN__
- #endif // __BIG_ENDIAN__
-
--#ifdef __FreeBSD__
-+#if defined(__FreeBSD__) || defined(__DragonFly__)
- # include <sys/endian.h>
- # if _BYTE_ORDER == _LITTLE_ENDIAN
- # define _LIBCPP_LITTLE_ENDIAN 1
-@@ -314,7 +314,10 @@ typedef __char32_t char32_t;
- #endif
-
- #if __ISO_C_VISIBLE >= 2011 || __cplusplus >= 201103L
--#if defined(__FreeBSD__)
-+#if defined(__DragonFly__)
-+#define _LIBCPP_HAS_QUICK_EXIT
-+#define _LIBCPP_HAS_C11_FEATURES
-+#elif defined(__FreeBSD__) && _FreeBSD_version >= 901501
- #define _LIBCPP_HAS_QUICK_EXIT
- #define _LIBCPP_HAS_C11_FEATURES
- #elif defined(__linux__)
-@@ -601,6 +604,13 @@ template <unsigned> struct __static_asse
- #define _LIBCPP_WCTYPE_IS_MASK
- #endif
-
-+#ifdef __DragonFly__
-+#define _LIBCPP_LOCALE__L_EXTENSIONS 1
-+#define _DECLARE_C99_LDBL_MATH 1
-+#define _LIBCPP_HAS_DEFAULTRUNELOCALE
-+#define _LIBCPP_WCTYPE_IS_MASK
-+#endif
-+
- #ifndef _LIBCPP_TRIVIAL_PAIR_COPY_CTOR
- # define _LIBCPP_TRIVIAL_PAIR_COPY_CTOR 1
- #endif
diff --git a/devel/libc++/files/patch-include____locale b/devel/libc++/files/patch-include____locale
deleted file mode 100644
index b710617a3be3..000000000000
--- a/devel/libc++/files/patch-include____locale
+++ /dev/null
@@ -1,32 +0,0 @@
---- include/__locale.orig 2014-03-11 17:18:47 UTC
-+++ include/__locale
-@@ -23,7 +23,15 @@
- # include <support/win32/locale_win32.h>
- #elif defined(_AIX)
- # include <support/ibm/xlocale.h>
--#elif (defined(__GLIBC__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__sun__)) || defined(__EMSCRIPTEN__) || defined(__IBMCPP__)
-+#elif defined (__FreeBSD__)
-+# include <sys/param.h>
-+# if __FreeBSD_version < 900000
-+# define __LONG_LONG_SUPPORTED
-+# include <stdlib.h>
-+# include <limits.h>
-+# endif
-+# include <xlocale.h>
-+#elif (defined(__GLIBC__) || defined(__APPLE__) || defined(__sun__)) || defined(__EMSCRIPTEN__) || defined(__IBMCPP__) || defined(__DragonFly__)
- # include <xlocale.h>
- #endif // _WIN32 || __GLIBC__ || __APPLE__ || __FreeBSD__ || __sun__ || __EMSCRIPTEN__ || __IBMCPP__
-
-@@ -341,10 +349,10 @@ public:
- static const mask punct = _PUNCT;
- static const mask xdigit = _HEX;
- static const mask blank = _BLANK;
--#elif defined(__APPLE__) || defined(__FreeBSD__) || defined(__EMSCRIPTEN__) || defined(__NetBSD__)
-+#elif defined(__APPLE__) || defined(__FreeBSD__) || defined(__EMSCRIPTEN__) || defined(__NetBSD__) || defined(__DragonFly__)
- #ifdef __APPLE__
- typedef __uint32_t mask;
--#elif defined(__FreeBSD__)
-+#elif defined(__FreeBSD__) || defined(__DragonFly__)
- typedef unsigned long mask;
- #elif defined(__EMSCRIPTEN__) || defined(__NetBSD__)
- typedef unsigned short mask;
diff --git a/devel/libc++/files/patch-include__support__solaris__xlocale.h b/devel/libc++/files/patch-include__support__solaris__xlocale.h
deleted file mode 100644
index ddc3add4534b..000000000000
--- a/devel/libc++/files/patch-include__support__solaris__xlocale.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./include/support/solaris/xlocale.h.orig 2014-01-16 17:58:45.000000000 +0100
-+++ ./include/support/solaris/xlocale.h 2014-05-06 16:11:11.135199398 +0200
-@@ -32,8 +32,8 @@
-
- #define LC_GLOBAL_LOCALE ((locale_t)-1)
-
--size_t __mb_cur_max(locale_t l);
--#define MB_CUR_MAX_L(l) __mb_cur_max(l)
-+size_t __mb_cur_max_l(locale_t l);
-+#define MB_CUR_MAX_L(l) __mb_cur_max_l(l)
-
- locale_t newlocale(int mask, const char * locale, locale_t base);
- void freelocale(locale_t loc);
diff --git a/devel/libc++/files/patch-include_locale b/devel/libc++/files/patch-include_locale
deleted file mode 100644
index 1e0c913de8b6..000000000000
--- a/devel/libc++/files/patch-include_locale
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/locale.orig 2014-02-07 21:14:29 UTC
-+++ include/locale
-@@ -209,7 +209,7 @@ template <class charT> class messages_by
-
- _LIBCPP_BEGIN_NAMESPACE_STD
-
--#if defined(__APPLE__) || defined(__FreeBSD__)
-+#if defined(__APPLE__) || defined(__FreeBSD__) || defined(__DragonFly__)
- # define _LIBCPP_GET_C_LOCALE 0
- #elif defined(__NetBSD__)
- # define _LIBCPP_GET_C_LOCALE LC_C_LOCALE
diff --git a/devel/libc++/files/patch-include_type__traits b/devel/libc++/files/patch-include_type__traits
deleted file mode 100644
index 058788e660a4..000000000000
--- a/devel/libc++/files/patch-include_type__traits
+++ /dev/null
@@ -1,25 +0,0 @@
---- include/type_traits.orig 2016-11-30 20:55:20 UTC
-+++ include/type_traits
-@@ -424,9 +424,12 @@ template <class _Tp> struct _
-
- namespace __libcpp_is_function_imp
- {
-+struct __dummy_type {};
- template <class _Tp> char __test(_Tp*);
-+template <class _Tp> char __test(__dummy_type);
- template <class _Tp> __two __test(...);
--template <class _Tp> _Tp& __source();
-+template <class _Tp> _Tp& __source(int);
-+template <class _Tp> __dummy_type __source(long);
- }
-
- template <class _Tp, bool = is_class<_Tp>::value ||
-@@ -435,7 +438,7 @@ template <class _Tp, bool = is_class<_Tp
- is_reference<_Tp>::value ||
- __is_nullptr_t<_Tp>::value >
- struct __libcpp_is_function
-- : public integral_constant<bool, sizeof(__libcpp_is_function_imp::__test<_Tp>(__libcpp_is_function_imp::__source<_Tp>())) == 1>
-+ : public integral_constant<bool, sizeof(__libcpp_is_function_imp::__test<_Tp>(__libcpp_is_function_imp::__source<_Tp>(0))) == 1>
- {};
- template <class _Tp> struct __libcpp_is_function<_Tp, true> : public false_type {};
-
diff --git a/devel/libc++/files/patch-src__string.cpp b/devel/libc++/files/patch-src__string.cpp
deleted file mode 100644
index 553e7caa5e77..000000000000
--- a/devel/libc++/files/patch-src__string.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/string.cpp.orig 2014-05-06 16:01:31.219239454 +0200
-+++ ./src/string.cpp 2014-05-06 15:59:03.134249779 +0200
-@@ -19,6 +19,7 @@
- #include "support/win32/support.h"
- #endif // _LIBCPP_MSVCRT
- #include <stdio.h>
-+#include <stdlib.h>
-
- _LIBCPP_BEGIN_NAMESPACE_STD
-
diff --git a/devel/libc++/files/patch-src__support__solaris__xlocale.c b/devel/libc++/files/patch-src__support__solaris__xlocale.c
deleted file mode 100644
index f908f4fa8986..000000000000
--- a/devel/libc++/files/patch-src__support__solaris__xlocale.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/support/solaris/xlocale.c.orig 2014-01-16 17:58:45.000000000 +0100
-+++ ./src/support/solaris/xlocale.c 2014-05-06 15:50:38.219287659 +0200
-@@ -26,7 +26,7 @@
- #include "mbsnrtowcs.inc"
- #include "wcsnrtombs.inc"
-
--size_t __mb_cur_max(locale_t __l) {
-+size_t __mb_cur_max_l(locale_t __l) {
- FIX_LOCALE(__l);
- return (__l->lc_ctype->cmapp->cm_mb_cur_max);
- }
diff --git a/devel/libc++/files/patch-src_locale.cpp b/devel/libc++/files/patch-src_locale.cpp
deleted file mode 100644
index 9698d42aafe9..000000000000
--- a/devel/libc++/files/patch-src_locale.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/locale.cpp.orig 2014-01-04 17:43:00 UTC
-+++ src/locale.cpp
-@@ -1021,7 +1021,7 @@ extern "C" const int ** __ctype_toupper_
- const ctype<char>::mask*
- ctype<char>::classic_table() _NOEXCEPT
- {
--#if defined(__APPLE__) || defined(__FreeBSD__)
-+#if defined(__APPLE__) || defined(__FreeBSD__) || defined(__DragonFly__)
- return _DefaultRuneLocale.__runetype;
- #elif defined(__NetBSD__)
- return _C_ctype_tab_ + 1;
diff --git a/devel/libc++/files/patch-test_utilities_meta_meta.unary_meta.unary.cat_function.pass.cpp b/devel/libc++/files/patch-test_utilities_meta_meta.unary_meta.unary.cat_function.pass.cpp
deleted file mode 100644
index c50965f910d5..000000000000
--- a/devel/libc++/files/patch-test_utilities_meta_meta.unary_meta.unary.cat_function.pass.cpp
+++ /dev/null
@@ -1,58 +0,0 @@
---- test/utilities/meta/meta.unary/meta.unary.cat/function.pass.cpp.orig 2013-10-05 21:21:17 UTC
-+++ test/utilities/meta/meta.unary/meta.unary.cat/function.pass.cpp
-@@ -14,7 +14,7 @@
- #include <type_traits>
-
- template <class T>
--void test_function_imp()
-+void test()
- {
- static_assert(!std::is_void<T>::value, "");
- #if _LIBCPP_STD_VER > 11
-@@ -34,19 +34,34 @@ void test_function_imp()
- static_assert( std::is_function<T>::value, "");
- }
-
--template <class T>
--void test_function()
--{
-- test_function_imp<T>();
-- test_function_imp<const T>();
-- test_function_imp<volatile T>();
-- test_function_imp<const volatile T>();
--}
-+// Since we can't actually add the const volatile and ref qualifiers once
-+// later let's use a macro to do it.
-+#define TEST_REGULAR(...) \
-+ test<__VA_ARGS__>(); \
-+ test<__VA_ARGS__ const>(); \
-+ test<__VA_ARGS__ volatile>(); \
-+ test<__VA_ARGS__ cons volatile>()
-+
-+#define TEST_REF_QUALIFIED(...) \
-+ test<__VA_ARGS__ &>(); \
-+ test<__VA_ARGS__ const &>(); \
-+ test<__VA_ARGS__ volatile &>(); \
-+ test<__VA_ARGS__ const volatile &>(); \
-+ test<__VA_ARGS__ &&>(); \
-+ test<__VA_ARGS__ const &&>(); \
-+ test<__VA_ARGS__ volatile &&>(); \
-+ test<__VA_ARGS__ const volatile &&>()
-
- int main()
- {
-- test_function<void ()>();
-- test_function<void (int)>();
-- test_function<int (double)>();
-- test_function<int (double, char)>();
-+ TEST_REGULAR( void () );
-+ TEST_REGULAR( void (int) );
-+ TEST_REGULAR( int (double) );
-+ TEST_REGULAR( int (double, char) );
-+#if __cplusplus >= 201103L
-+ TEST_REF_QUALIFIED( void () );
-+ TEST_REF_QUALIFIED( void (int) );
-+ TEST_REF_QUALIFIED( int (double) );
-+ TEST_REF_QUALIFIED( int (double, char) );
-+#endif
- }
diff --git a/devel/libc++/pkg-descr b/devel/libc++/pkg-descr
deleted file mode 100644
index 781d8a26fd32..000000000000
--- a/devel/libc++/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-libc++ is a new implementation of the C++ standard library made by the
-llvm project targeting C++11.
-
-WWW: http://libcxx.llvm.org/
diff --git a/devel/libc++/pkg-plist b/devel/libc++/pkg-plist
deleted file mode 100644
index fc81498dcda8..000000000000
--- a/devel/libc++/pkg-plist
+++ /dev/null
@@ -1,237 +0,0 @@
-include/c++/v1/CMakeFiles/CMakeDirectoryInformation.cmake
-include/c++/v1/CMakeFiles/progress.marks
-include/c++/v1/Makefile
-include/c++/v1/__bit_reference
-include/c++/v1/__config
-include/c++/v1/__debug
-include/c++/v1/__functional_03
-include/c++/v1/__functional_base
-include/c++/v1/__functional_base_03
-include/c++/v1/__hash_table
-include/c++/v1/__locale
-include/c++/v1/__mutex_base
-include/c++/v1/__refstring
-include/c++/v1/__split_buffer
-include/c++/v1/__sso_allocator
-include/c++/v1/__std_stream
-include/c++/v1/__tree
-include/c++/v1/__tuple
-include/c++/v1/__tuple_03
-include/c++/v1/__undef_min_max
-include/c++/v1/algorithm
-include/c++/v1/array
-include/c++/v1/atomic
-include/c++/v1/bitset
-include/c++/v1/c++/v1/__bit_reference
-include/c++/v1/c++/v1/__config
-include/c++/v1/c++/v1/__debug
-include/c++/v1/c++/v1/__functional_03
-include/c++/v1/c++/v1/__functional_base
-include/c++/v1/c++/v1/__functional_base_03
-include/c++/v1/c++/v1/__hash_table
-include/c++/v1/c++/v1/__locale
-include/c++/v1/c++/v1/__mutex_base
-include/c++/v1/c++/v1/__refstring
-include/c++/v1/c++/v1/__split_buffer
-include/c++/v1/c++/v1/__sso_allocator
-include/c++/v1/c++/v1/__std_stream
-include/c++/v1/c++/v1/__tree
-include/c++/v1/c++/v1/__tuple
-include/c++/v1/c++/v1/__tuple_03
-include/c++/v1/c++/v1/__undef_min_max
-include/c++/v1/c++/v1/algorithm
-include/c++/v1/c++/v1/array
-include/c++/v1/c++/v1/atomic
-include/c++/v1/c++/v1/bitset
-include/c++/v1/c++/v1/cassert
-include/c++/v1/c++/v1/ccomplex
-include/c++/v1/c++/v1/cctype
-include/c++/v1/c++/v1/cerrno
-include/c++/v1/c++/v1/cfenv
-include/c++/v1/c++/v1/cfloat
-include/c++/v1/c++/v1/chrono
-include/c++/v1/c++/v1/cinttypes
-include/c++/v1/c++/v1/ciso646
-include/c++/v1/c++/v1/climits
-include/c++/v1/c++/v1/clocale
-include/c++/v1/c++/v1/cmath
-include/c++/v1/c++/v1/codecvt
-include/c++/v1/c++/v1/complex
-include/c++/v1/c++/v1/complex.h
-include/c++/v1/c++/v1/condition_variable
-include/c++/v1/c++/v1/csetjmp
-include/c++/v1/c++/v1/csignal
-include/c++/v1/c++/v1/cstdarg
-include/c++/v1/c++/v1/cstdbool
-include/c++/v1/c++/v1/cstddef
-include/c++/v1/c++/v1/cstdint
-include/c++/v1/c++/v1/cstdio
-include/c++/v1/c++/v1/cstdlib
-include/c++/v1/c++/v1/cstring
-include/c++/v1/c++/v1/ctgmath
-include/c++/v1/c++/v1/ctime
-include/c++/v1/c++/v1/cwchar
-include/c++/v1/c++/v1/cwctype
-include/c++/v1/c++/v1/deque
-include/c++/v1/c++/v1/exception
-include/c++/v1/c++/v1/experimental/dynarray
-include/c++/v1/c++/v1/experimental/optional
-include/c++/v1/c++/v1/ext/__hash
-include/c++/v1/c++/v1/ext/hash_map
-include/c++/v1/c++/v1/ext/hash_set
-include/c++/v1/c++/v1/forward_list
-include/c++/v1/c++/v1/fstream
-include/c++/v1/c++/v1/functional
-include/c++/v1/c++/v1/future
-include/c++/v1/c++/v1/initializer_list
-include/c++/v1/c++/v1/iomanip
-include/c++/v1/c++/v1/ios
-include/c++/v1/c++/v1/iosfwd
-include/c++/v1/c++/v1/iostream
-include/c++/v1/c++/v1/istream
-include/c++/v1/c++/v1/iterator
-include/c++/v1/c++/v1/limits
-include/c++/v1/c++/v1/list
-include/c++/v1/c++/v1/locale
-include/c++/v1/c++/v1/map
-include/c++/v1/c++/v1/memory
-include/c++/v1/c++/v1/mutex
-include/c++/v1/c++/v1/new
-include/c++/v1/c++/v1/numeric
-include/c++/v1/c++/v1/ostream
-include/c++/v1/c++/v1/queue
-include/c++/v1/c++/v1/random
-include/c++/v1/c++/v1/ratio
-include/c++/v1/c++/v1/regex
-include/c++/v1/c++/v1/scoped_allocator
-include/c++/v1/c++/v1/set
-include/c++/v1/c++/v1/shared_mutex
-include/c++/v1/c++/v1/sstream
-include/c++/v1/c++/v1/stack
-include/c++/v1/c++/v1/stdexcept
-include/c++/v1/c++/v1/streambuf
-include/c++/v1/c++/v1/string
-include/c++/v1/c++/v1/strstream
-include/c++/v1/c++/v1/support/ibm/limits.h
-include/c++/v1/c++/v1/support/ibm/support.h
-include/c++/v1/c++/v1/support/ibm/xlocale.h
-include/c++/v1/c++/v1/support/solaris/floatingpoint.h
-include/c++/v1/c++/v1/support/solaris/wchar.h
-include/c++/v1/c++/v1/support/solaris/xlocale.h
-include/c++/v1/c++/v1/support/win32/limits_win32.h
-include/c++/v1/c++/v1/support/win32/locale_win32.h
-include/c++/v1/c++/v1/support/win32/math_win32.h
-include/c++/v1/c++/v1/support/win32/support.h
-include/c++/v1/c++/v1/system_error
-include/c++/v1/c++/v1/tgmath.h
-include/c++/v1/c++/v1/thread
-include/c++/v1/c++/v1/tuple
-include/c++/v1/c++/v1/type_traits
-include/c++/v1/c++/v1/typeindex
-include/c++/v1/c++/v1/typeinfo
-include/c++/v1/c++/v1/unordered_map
-include/c++/v1/c++/v1/unordered_set
-include/c++/v1/c++/v1/utility
-include/c++/v1/c++/v1/valarray
-include/c++/v1/c++/v1/vector
-include/c++/v1/cassert
-include/c++/v1/ccomplex
-include/c++/v1/cctype
-include/c++/v1/cerrno
-include/c++/v1/cfenv
-include/c++/v1/cfloat
-include/c++/v1/chrono
-include/c++/v1/cinttypes
-include/c++/v1/ciso646
-include/c++/v1/climits
-include/c++/v1/clocale
-include/c++/v1/cmake_install.cmake
-include/c++/v1/cmath
-include/c++/v1/codecvt
-include/c++/v1/complex
-include/c++/v1/complex.h
-include/c++/v1/condition_variable
-include/c++/v1/csetjmp
-include/c++/v1/csignal
-include/c++/v1/cstdarg
-include/c++/v1/cstdbool
-include/c++/v1/cstddef
-include/c++/v1/cstdint
-include/c++/v1/cstdio
-include/c++/v1/cstdlib
-include/c++/v1/cstring
-include/c++/v1/ctgmath
-include/c++/v1/ctime
-include/c++/v1/cwchar
-include/c++/v1/cwctype
-include/c++/v1/cxxabi.h
-include/c++/v1/deque
-include/c++/v1/exception
-include/c++/v1/experimental/dynarray
-include/c++/v1/experimental/optional
-include/c++/v1/ext/__hash
-include/c++/v1/ext/hash_map
-include/c++/v1/ext/hash_set
-include/c++/v1/forward_list
-include/c++/v1/fstream
-include/c++/v1/functional
-include/c++/v1/future
-include/c++/v1/initializer_list
-include/c++/v1/iomanip
-include/c++/v1/ios
-include/c++/v1/iosfwd
-include/c++/v1/iostream
-include/c++/v1/istream
-include/c++/v1/iterator
-include/c++/v1/limits
-include/c++/v1/list
-include/c++/v1/locale
-include/c++/v1/map
-include/c++/v1/memory
-include/c++/v1/mutex
-include/c++/v1/new
-include/c++/v1/numeric
-include/c++/v1/ostream
-include/c++/v1/queue
-include/c++/v1/random
-include/c++/v1/ratio
-include/c++/v1/regex
-include/c++/v1/scoped_allocator
-include/c++/v1/set
-include/c++/v1/shared_mutex
-include/c++/v1/sstream
-include/c++/v1/stack
-include/c++/v1/stdexcept
-include/c++/v1/streambuf
-include/c++/v1/string
-include/c++/v1/strstream
-include/c++/v1/support/ibm/limits.h
-include/c++/v1/support/ibm/support.h
-include/c++/v1/support/ibm/xlocale.h
-include/c++/v1/support/solaris/floatingpoint.h
-include/c++/v1/support/solaris/wchar.h
-include/c++/v1/support/solaris/xlocale.h
-include/c++/v1/support/win32/limits_win32.h
-include/c++/v1/support/win32/locale_win32.h
-include/c++/v1/support/win32/math_win32.h
-include/c++/v1/support/win32/support.h
-include/c++/v1/system_error
-include/c++/v1/tgmath.h
-include/c++/v1/thread
-include/c++/v1/tr1
-include/c++/v1/tuple
-include/c++/v1/type_traits
-include/c++/v1/typeindex
-include/c++/v1/typeinfo
-include/c++/v1/unordered_map
-include/c++/v1/unordered_set
-include/c++/v1/unwind-arm.h
-include/c++/v1/unwind-itanium.h
-include/c++/v1/unwind.h
-include/c++/v1/utility
-include/c++/v1/valarray
-include/c++/v1/vector
-lib/libc++.so
-lib/libc++.so.1
-lib/libc++.so.1.0
-lib/c++/libstdc++.so
diff --git a/devel/libcxxrt/Makefile b/devel/libcxxrt/Makefile
deleted file mode 100644
index 0ab48e41a232..000000000000
--- a/devel/libcxxrt/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= libcxxrt
-PORTVERSION= 20160529
-CATEGORIES= devel
-
-MAINTAINER= mmokhi@FreeBSD.org
-COMMENT= Implementation of the Code Sourcery C++ ABI
-
-LICENSE= BSD2CLAUSE
-
-USE_GITHUB= yes
-GH_ACCOUNT= pathscale
-GH_TAGNAME= 516a65c
-
-USES= cmake compiler:c++11-lang
-USE_LDCONFIG= yes
-CXXFLAGS+= -nostdlib
-
-do-install:
- ${INSTALL_LIB} ${WRKSRC}/lib/libcxxrt.so ${STAGEDIR}${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/lib/libcxxrt.a ${STAGEDIR}${PREFIX}/lib
- @${MKDIR} ${STAGEDIR}${PREFIX}/include/cxxrt
- ${INSTALL_DATA} ${WRKSRC}/src/*.h ${STAGEDIR}${PREFIX}/include/cxxrt
-
-.include <bsd.port.mk>
diff --git a/devel/libcxxrt/distinfo b/devel/libcxxrt/distinfo
deleted file mode 100644
index 228145b1f406..000000000000
--- a/devel/libcxxrt/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (pathscale-libcxxrt-20160529-516a65c_GH0.tar.gz) = 5d2b943fb8bcce453d3453246dd25242a01b2107631c52c90dbefff13fec1f65
-SIZE (pathscale-libcxxrt-20160529-516a65c_GH0.tar.gz) = 73293
diff --git a/devel/libcxxrt/pkg-descr b/devel/libcxxrt/pkg-descr
deleted file mode 100644
index 7535b61f7890..000000000000
--- a/devel/libcxxrt/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-This library implements the Code Sourcery C++ ABI, as documented here:
-
-WWW: http://www.codesourcery.com/public/cxx-abi/abi.html
-
-It is intended to sit below an STL implementation, and provide features required
-by the compiler for implementation of the C++ language.
-
-WWW: https://github.com/pathscale/libcxxrt
diff --git a/devel/libcxxrt/pkg-plist b/devel/libcxxrt/pkg-plist
deleted file mode 100644
index 7692a5636dd8..000000000000
--- a/devel/libcxxrt/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-include/cxxrt/abi_namespace.h
-include/cxxrt/atomic.h
-include/cxxrt/cxxabi.h
-include/cxxrt/dwarf_eh.h
-include/cxxrt/stdexcept.h
-include/cxxrt/typeinfo.h
-include/cxxrt/unwind-arm.h
-include/cxxrt/unwind-itanium.h
-include/cxxrt/unwind.h
-lib/libcxxrt.a
-lib/libcxxrt.so
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 145113aa57d5..f7c393a2c522 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnash
PORTVERSION= 0.8.10
-PORTREVISION= 23
+PORTREVISION= 24
CATEGORIES= graphics
MASTER_SITES= http://git.savannah.gnu.org/cgit/gnash.git/snapshot/
DISTNAME= gnash-2b3bdede0305c4fc3ad21a0a4197330606c9b880
@@ -15,7 +15,6 @@ LICENSE= GPLv3
LIB_DEPENDS= libltdl.so:devel/libltdl \
libnspr4.so:devel/nspr \
- libc++.so.1:devel/libc++ \
libgif.so:graphics/giflib \
libpng.so:graphics/png \
libcurl.so:ftp/curl \
diff --git a/math/parmetis/Makefile b/math/parmetis/Makefile
index 0ffc481d1318..0ddf4c758e20 100644
--- a/math/parmetis/Makefile
+++ b/math/parmetis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ParMetis
PORTVERSION= 4.0
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= math parallel
MASTER_SITES= http://glaros.dtc.umn.edu/gkhome/fetch/sw/parmetis/%SUBDIR%/
MASTER_SITE_SUBDIR= . OLD
@@ -17,15 +17,10 @@ LICENSE_NAME= University of Minnesota METIS License
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= auto-accept
-# libc++.so is a linker script, not a symlink.
-# Ignore portlint, the linker needs the actual library specified
-LIB_DEPENDS= libc++.so.1:devel/libc++
-
OPTIONS_DEFINE= OPENMPI DOCS
OPENMPI_DESC= Use openmpi instead of mpich2
USES= cmake gmake
-LDFLAGS+= -L${LOCALBASE}/lib -lc++
PLIST_FILES= include/parmetis/metis.h \
include/parmetis/parmetis.h \
diff --git a/textproc/hs-double-conversion/Makefile b/textproc/hs-double-conversion/Makefile
index 488b9ecc76af..2628827a08a8 100644
--- a/textproc/hs-double-conversion/Makefile
+++ b/textproc/hs-double-conversion/Makefile
@@ -15,7 +15,6 @@ USE_CABAL= text>=0.11.0.8
.if ${PORT_OPTIONS:MPCLANG} || ${PORT_OPTIONS:MBCLANG}
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-double-conversion.cabal
-LIB_DEPENDS+= libcxxrt.so:devel/libcxxrt
.endif
.include <bsd.port.mk>
diff --git a/x11-toolkits/hs-wxc/Makefile b/x11-toolkits/hs-wxc/Makefile
index 47b8550ab27a..89fdcb69c68c 100644
--- a/x11-toolkits/hs-wxc/Makefile
+++ b/x11-toolkits/hs-wxc/Makefile
@@ -24,8 +24,4 @@ post-patch::
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.if ${PORT_OPTIONS:MPCLANG} || ${PORT_OPTIONS:MBCLANG}
-LIB_DEPENDS+= libc++.so.1:devel/libc++
-.endif
-
.include <bsd.port.mk>