aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-05-10 04:20:21 +0800
committerpi <pi@FreeBSD.org>2018-05-10 04:20:21 +0800
commit936d9f9c7105a771ae48ce5cdb255ce7326f2dd8 (patch)
tree184772f4f150bda16999edaf0c4f1988d6c08a97
parent69b96b07b299120d716f871a770503fc9d779e1e (diff)
downloadfreebsd-ports-gnome-936d9f9c7105a771ae48ce5cdb255ce7326f2dd8.tar.gz
freebsd-ports-gnome-936d9f9c7105a771ae48ce5cdb255ce7326f2dd8.tar.zst
freebsd-ports-gnome-936d9f9c7105a771ae48ce5cdb255ce7326f2dd8.zip
New port: security/p5-Crypt-X509-CRL
Crypt::X509::CRL is an object oriented X.509 certificate revocation list parser with numerous methods for directly extracting information from certificate revocation lists WWW: http://search.cpan.org/dist/Crypt-X509-CRL/ PR: 228074 Submitted by: Sergei Vyshenski <svysh.fbsd@gmail.com>
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-X509-CRL/Makefile28
-rw-r--r--security/p5-Crypt-X509-CRL/distinfo3
-rw-r--r--security/p5-Crypt-X509-CRL/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 816219176c58..ccf06e4be05e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -638,6 +638,7 @@
SUBDIR += p5-Crypt-UnixCrypt
SUBDIR += p5-Crypt-UnixCrypt_XS
SUBDIR += p5-Crypt-X509
+ SUBDIR += p5-Crypt-X509-CRL
SUBDIR += p5-Crypt-XTEA
SUBDIR += p5-Crypt-xDBM_File
SUBDIR += p5-CryptX
diff --git a/security/p5-Crypt-X509-CRL/Makefile b/security/p5-Crypt-X509-CRL/Makefile
new file mode 100644
index 000000000000..66e229f7d103
--- /dev/null
+++ b/security/p5-Crypt-X509-CRL/Makefile
@@ -0,0 +1,28 @@
+# Created by: Sergei Vyshenski <svysh.fbsd@gmail.com>
+# $FreeBSD$
+
+PORTNAME= Crypt-X509-CRL
+PORTVERSION= 0.1
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svysh.fbsd@gmail.com
+COMMENT= Object oriented X.509 certificate revocation list parser
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/README
+
+BUILD_DEPENDS= p5-Convert-ASN1>=0.19:converters/p5-Convert-ASN1
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_ARCH= yes
+
+PLIST_FILES= ${SITE_MAN3_REL}/Crypt::X509::CRL.3.gz \
+ ${SITE_PERL_REL}/Crypt/X509/CRL.pm
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-X509-CRL/distinfo b/security/p5-Crypt-X509-CRL/distinfo
new file mode 100644
index 000000000000..27b9f8304ae3
--- /dev/null
+++ b/security/p5-Crypt-X509-CRL/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1525708759
+SHA256 (Crypt-X509-CRL-0.1.tar.gz) = 1eeeb5661133285dbe4d1558259fce6100b7e806a0dfb18bb67b87b0b76f188b
+SIZE (Crypt-X509-CRL-0.1.tar.gz) = 14574
diff --git a/security/p5-Crypt-X509-CRL/pkg-descr b/security/p5-Crypt-X509-CRL/pkg-descr
new file mode 100644
index 000000000000..a3216c24edcc
--- /dev/null
+++ b/security/p5-Crypt-X509-CRL/pkg-descr
@@ -0,0 +1,5 @@
+Crypt::X509::CRL is an object oriented X.509 certificate
+revocation list parser with numerous methods for directly
+extracting information from certificate revocation lists
+
+WWW: http://search.cpan.org/dist/Crypt-X509-CRL/