aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-02-04 03:19:47 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-02-04 03:19:47 +0800
commit9465906f495857575e9cc29d61712f2aece9a9d3 (patch)
tree91534926b0810e27d2f6f59a6ba701fee0578451
parentc12c8d0f77b00f245e925e979c6903289c33656d (diff)
downloadfreebsd-ports-gnome-9465906f495857575e9cc29d61712f2aece9a9d3.tar.gz
freebsd-ports-gnome-9465906f495857575e9cc29d61712f2aece9a9d3.tar.zst
freebsd-ports-gnome-9465906f495857575e9cc29d61712f2aece9a9d3.zip
- Fix build by not modifying file under DISTDIR
- Don't include PORTREVISION into DIST_SUBDIR
-rw-r--r--devel/easygit/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/devel/easygit/Makefile b/devel/easygit/Makefile
index 24dfe6ad40d1..2579b242efb7 100644
--- a/devel/easygit/Makefile
+++ b/devel/easygit/Makefile
@@ -7,24 +7,28 @@ CATEGORIES= devel
MASTER_SITES= http://www.gnome.org/~newren/eg/download/${PORTVERSION}/
DISTNAME= eg
EXTRACT_SUFX= # none
-EXTRACT_ONLY= # none
MAINTAINER= ports@FreeBSD.org
COMMENT= Easy wrapper for git
RUN_DEPENDS= git:${PORTSDIR}/devel/git
-DIST_SUBDIR= eg/${PORTVERSION}_${PORTREVISION}
+DISTREVISION= 0 # bump this if distfile is changed inplace
+
+DIST_SUBDIR= eg/${PORTVERSION}_${DISTREVISION}
USES= perl5 shebangfix
-SHEBANG_FILES= ${_DISTDIR}/eg
+SHEBANG_FILES= ${WRKDIR}/eg
USE_PERL5= run
NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= bin/eg bin/easygit
+do-extract:
+ @${CP} ${_DISTDIR}/${DISTNAME} ${WRKDIR}
+
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${_DISTDIR}/eg ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKDIR}/eg ${STAGEDIR}${PREFIX}/bin/
cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s ./eg ${STAGEDIR}${PREFIX}/bin/easygit
.include <bsd.port.mk>