aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoremaste <emaste@FreeBSD.org>2018-09-26 21:55:28 +0800
committeremaste <emaste@FreeBSD.org>2018-09-26 21:55:28 +0800
commit959aeaee6834bd683b7917c3561013c28461811f (patch)
tree4343be6def803e00873eb4da7b96c1a20b473058
parent5b940cd23ae279c922f116f8ed54337b0d828770 (diff)
downloadfreebsd-ports-gnome-959aeaee6834bd683b7917c3561013c28461811f.tar.gz
freebsd-ports-gnome-959aeaee6834bd683b7917c3561013c28461811f.tar.zst
freebsd-ports-gnome-959aeaee6834bd683b7917c3561013c28461811f.zip
emulators/tuxnes: set LLD_UNSAFE on i386
This port builds and runs a build tool, which segfaults when lld is the i386 system linker: cc -O2 -pipe -fstack-protector -fno-strict-aliasing -pipe -Wall -I/usr/local/include -I/usr/local/include -fstack-protector -o comptbl comptbl.o -lm -lz -lXext -lXpm -lSM -lICE -lX11 -L/usr/local/lib ./comptbl gmake[1]: *** [Makefile:414: compdata] Segmentation fault (core dumped) PR: 214864 Approved by: portmgr (lld blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--emulators/tuxnes/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/emulators/tuxnes/Makefile b/emulators/tuxnes/Makefile
index 2d16b07c417f..bb2754c2100d 100644
--- a/emulators/tuxnes/Makefile
+++ b/emulators/tuxnes/Makefile
@@ -30,6 +30,10 @@ DESKTOP_ENTRIES="TuxNES" "" "${PREFIX}/share/pixmaps/tuxnes.xpm" \
.if ${COMPILER_TYPE} == "clang"
CPPFLAGS+= -no-integrated-as
.endif
+.if ${ARCH} == "i386"
+# Build tool "compdata" segfaults when linked with lld
+LLD_UNSAFE= yes
+.endif
post-patch:
@${REINPLACE_CMD} -e \