aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2004-01-14 01:57:36 +0800
committerbms <bms@FreeBSD.org>2004-01-14 01:57:36 +0800
commit9791f713a2a35722a649e8f598850f7790adbac4 (patch)
tree572e951619d1e9a4d6fdca9627a3a928a8b8a058
parente852dba7ef2c1db7eefb4dfb35f0b00977acb12c (diff)
downloadfreebsd-ports-gnome-9791f713a2a35722a649e8f598850f7790adbac4.tar.gz
freebsd-ports-gnome-9791f713a2a35722a649e8f598850f7790adbac4.tar.zst
freebsd-ports-gnome-9791f713a2a35722a649e8f598850f7790adbac4.zip
Update tcpdump port to latest beta with fixes for security vulnerabilities
in tandem with vendor branch in src tree. Add an option to overwrite the base system tcpdump. PR: ports/61103 Submitted by: edwin
-rw-r--r--net/tcpdump/Makefile25
-rw-r--r--net/tcpdump/distinfo2
-rw-r--r--net/tcpdump/files/pkg-message-base7
3 files changed, 32 insertions, 2 deletions
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index 1ee23e841214..17e21f438005 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -7,14 +7,19 @@
PORTNAME= tcpdump
PORTVERSION= 3.8.1
+PORTREVISION= 351
CATEGORIES= net
MASTER_SITES= http://www.tcpdump.org/beta/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-316
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PORTREVISION}
MAINTAINER= bms@FreeBSD.org
COMMENT= Ubiquitous network traffic analysis tool
+.if defined(TCPDUMP_OVERWRITE_BASE)
+LIB_DEPENDS= pcap.2:${PORTSDIR}/net/libpcap
+.else
BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
+.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -22,6 +27,19 @@ MAN1= tcpdump.1
GNU_CONFIGURE= yes
+.if defined(TCPDUMP_OVERWRITE_BASE)
+PREFIX= /usr
+PKGNAMESUFFIX= -overwrite-base
+MANPREFIX= ${PREFIX}/share
+CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man
+PLIST_SUB+= NOTBASE="@comment "
+PLIST_SUB+= BASE=""
+PKGMESSAGE= ${FILESDIR}/pkg-message-base
+.else
+PLIST_SUB+= BASE="@comment "
+PLIST_SUB+= NOTBASE=""
+.endif
+
.if !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
@@ -55,4 +73,9 @@ pre-configure:
${LN} -s ${LOCALBASE}/$i ${LOCALPCAPDIR}
.endfor
+.if defined(TCPDUMP_OVERWRITE_BASE)
+post-install:
+ ${CAT} ${PKGMESSAGE}
+.endif
+
.include <bsd.port.mk>
diff --git a/net/tcpdump/distinfo b/net/tcpdump/distinfo
index 05b49cfaac10..e42e76b3c3f4 100644
--- a/net/tcpdump/distinfo
+++ b/net/tcpdump/distinfo
@@ -1 +1 @@
-MD5 (tcpdump-3.8.1-316.tar.gz) = 7149aeee925a4b05ac9d07aed3beb546
+MD5 (tcpdump-3.8.1-351.tar.gz) = d4dad7a6e4728e23238fc01b18b2c866
diff --git a/net/tcpdump/files/pkg-message-base b/net/tcpdump/files/pkg-message-base
new file mode 100644
index 000000000000..8856bffafd42
--- /dev/null
+++ b/net/tcpdump/files/pkg-message-base
@@ -0,0 +1,7 @@
+***************************************
+* You can always reinstall the older *
+* tcpdump via the source directory *
+* of the base system: *
+* $ cd /usr/src/usr.sbin/tcpdump *
+* $ make && make install *
+***************************************