aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-07-29 21:39:12 +0800
committertijl <tijl@FreeBSD.org>2015-07-29 21:39:12 +0800
commit98664e3d6aac774d054fea2ed37aa7ddc5faed4b (patch)
tree4e50dcd4e9b31183d619ce6b3ee398795e784672
parent82d9d9f26623f570b21e413d5758726065d3d432 (diff)
downloadfreebsd-ports-gnome-98664e3d6aac774d054fea2ed37aa7ddc5faed4b.tar.gz
freebsd-ports-gnome-98664e3d6aac774d054fea2ed37aa7ddc5faed4b.tar.zst
freebsd-ports-gnome-98664e3d6aac774d054fea2ed37aa7ddc5faed4b.zip
Libarchive can use either libxml2 or libexpat for xar support, but the
LIBXML2 option currently makes libarchive link to both libxml2 and libbsdxml (base system private copy of libexpat). Replace this with a simple depdendency on libexpat. Also remove PATCH_STRIP because there are no patches, replace MAKE with MAKE_CMD and add INSTALL_TARGET=install-strip. PR: 201948 Approved by: glewis (maintainer)
-rw-r--r--archivers/libarchive/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 1e4cef09de5d..624a274a399c 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libarchive
PORTVERSION= 3.1.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= archivers
MASTER_SITES= http://libarchive.org/downloads/
@@ -10,19 +10,20 @@ MASTER_SITES= http://libarchive.org/downloads/
MAINTAINER= glewis@FreeBSD.org
COMMENT= Library to create and read several streaming archive formats
-OPTIONS_DEFINE= LIBXML2 LZO NETTLE
-OPTIONS_DEFAULT=LIBXML2 LZO
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+
+OPTIONS_DEFINE= LZO NETTLE
+OPTIONS_DEFAULT=LZO
-LIBXML2_DESC= Support writing xar via libxml2
LZO_DESC= Support lzo compression via liblzo2
NETTLE_DESC= Use Nettle instead of OpenSSL
USES= cpe libtool pathfix
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-PATCH_STRIP= -p1
-CONFIGURE_ARGS+= --without-expat
+CONFIGURE_ARGS= --without-xml2
PLIST_FILES= bin/bsdcpio \
bin/bsdtar \
@@ -78,11 +79,6 @@ CFLAGS+= "-I${LOCALBASE}/include"
CPPFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= "-L${LOCALBASE}/lib"
-LIBXML2_USE= GNOME=libxml2
-LIBXML2_CONFIGURE_WITH= xml2
-LIBXML2_CFLAGS= -DHAVE_BSDXML_H=1
-LIBXML2_LDFLAGS= -lbsdxml
-
LZO_LIB_DEPENDS= liblzo2.so:${PORTSDIR}/archivers/lzo2
LZO_CONFIGURE_WITH= lzo2
@@ -93,6 +89,6 @@ NETTLE_USE_OFF= OPENSSL=yes
NETTLE_CONFIGURE_OFF= --with-openssl
check:
- (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} check)
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check)
.include <bsd.port.mk>