aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-31 06:54:37 +0800
committerkrion <krion@FreeBSD.org>2003-08-31 06:54:37 +0800
commit991df8ab845731139744befc391de0ca1704fdf8 (patch)
tree582811c7f9296d7bc50e4edc0eac4e6e89c49534
parentb40eb044f87247fd1fba0e669e27b023abc75104 (diff)
downloadfreebsd-ports-gnome-991df8ab845731139744befc391de0ca1704fdf8.tar.gz
freebsd-ports-gnome-991df8ab845731139744befc391de0ca1704fdf8.tar.zst
freebsd-ports-gnome-991df8ab845731139744befc391de0ca1704fdf8.zip
- Fix build on -current
o varargs -> stdarg o remove non-existant host from {MASTER,PATCH}_SITES: PR: 56214 Submitted by: Michael Edenfield <kutulu@kutulu.org>
-rw-r--r--net/cap/Makefile7
-rw-r--r--net/cap/files/patch-lib-cap-ablog.c40
2 files changed, 38 insertions, 9 deletions
diff --git a/net/cap/Makefile b/net/cap/Makefile
index 110b68110ec7..33f0a3467df6 100644
--- a/net/cap/Makefile
+++ b/net/cap/Makefile
@@ -9,9 +9,7 @@ PORTNAME= cap
PORTVERSION= 6.0.198
PORTREVISION= 1
CATEGORIES= net
-MASTER_SITES= ftp://ftp-ns.rutgers.edu/pub/cap/ \
- ftp://ftp-ns.rutgers.edu/pub/cap/cap.patches/ \
- ftp://munnari.OZ.AU/mac/ \
+MASTER_SITES= ftp://munnari.OZ.AU/mac/ \
ftp://munnari.OZ.AU/mac/cap.patches/ \
ftp://ftp.kuis.kyoto-u.ac.jp/net/cap/ \
ftp://ftp.kuis.kyoto-u.ac.jp/net/cap/cap60.patches/
@@ -19,8 +17,7 @@ DISTFILES= cap60.pl100.tar.Z patches.101-126.tar.Z patches.127-143.tar.Z \
patches.144-154.tar.Z patches.155-162.tar.Z \
patches.163-182.tar.Z patches.183-192.tar.Z
-PATCH_SITES= ftp://ftp-ns.rutgers.edu/pub/cap/cap.patches/ \
- ftp://munnari.OZ.AU/mac/cap.patches/
+PATCH_SITES= ftp://munnari.OZ.AU/mac/cap.patches/
PATCHFILES= cap60.patch193 cap60.patch194 cap60.patch195 cap60.patch196 \
cap60.patch197 cap60.patch198
diff --git a/net/cap/files/patch-lib-cap-ablog.c b/net/cap/files/patch-lib-cap-ablog.c
index 06613e45587c..c3baa70fe94a 100644
--- a/net/cap/files/patch-lib-cap-ablog.c
+++ b/net/cap/files/patch-lib-cap-ablog.c
@@ -1,6 +1,6 @@
---- lib/cap/ablog.c.orig Mon Feb 3 01:16:00 2003
-+++ lib/cap/ablog.c Mon Feb 3 03:48:59 2003
-@@ -24,6 +24,7 @@
+--- lib/cap/ablog.c.orig Sat Aug 30 18:19:18 2003
++++ lib/cap/ablog.c Sat Aug 30 18:25:05 2003
+@@ -24,13 +24,14 @@
*
*/
@@ -8,6 +8,14 @@
#include <stdio.h>
#include <sys/types.h>
#include <sys/time.h>
+ #include <netat/appletalk.h>
+
+ #ifdef USEVPRINTF
+-# include <varargs.h>
++# include <stdarg.h>
+ #endif USEVPRINTF
+ #ifdef USETIMES
+ # include <time.h>
@@ -66,8 +67,13 @@
* This is something all machine should, but don't have :-)
*/
@@ -23,7 +31,20 @@
#ifndef USEVPRINTF
/* Bletch - gotta do it because pyramids don't work the other way */
-@@ -91,7 +97,7 @@
+@@ -79,19 +85,16 @@
+ char *fmt;
+ #else USEVPRINTF
+ /*VARARGS*/
+-logit(va_alist)
+-va_dcl
++logit(int level, char *fmt, ...)
+ #endif USEVPRINTF
+ {
+ static char *mytod();
+ #ifdef USEVPRINTF
+- register char *fmt;
+ va_list args;
+- int level;
#endif USEVPRINTF
int saveerr;
extern int errno;
@@ -32,3 +53,14 @@
#ifndef __FreeBSD__
extern char *sys_errlist[];
#endif
+@@ -101,9 +104,7 @@
+
+ saveerr = errno;
+ #ifdef USEVPRINTF
+- va_start(args);
+- level = va_arg(args, int);
+- fmt = va_arg(args, char *);
++ va_start(args, fmt);
+ #endif USEVPRINTF
+
+ if (dlevel < (level & L_LVL))