aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2003-05-16 16:12:37 +0800
committerume <ume@FreeBSD.org>2003-05-16 16:12:37 +0800
commit9d0fca17f5477feee4dde7d372fa3a24f03b0df8 (patch)
tree9fb10bfdbead8af972bc9a8867ff6933aabca679
parent5fba3ff76657fef62ee5ab63e1482fa5557530c7 (diff)
downloadfreebsd-ports-gnome-9d0fca17f5477feee4dde7d372fa3a24f03b0df8.tar.gz
freebsd-ports-gnome-9d0fca17f5477feee4dde7d372fa3a24f03b0df8.tar.zst
freebsd-ports-gnome-9d0fca17f5477feee4dde7d372fa3a24f03b0df8.zip
Sync the way how to handle Kerberos with latest security/cyrus-sasl.
Obtained from: security/cyrus-sasl
-rw-r--r--security/cyrus-sasl2/Makefile23
-rw-r--r--security/cyrus-sasl2/scripts/configure.sasl2
2 files changed, 20 insertions, 5 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index e54dcba3179f..be2bc1036042 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -88,23 +88,38 @@ NTLM= "@comment "
CONFIGURE_ARGS+= --enable-ntlm
.endif
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+.if !defined(WITHOUT_GSSAPI) && defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
-.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME})
+.elif !defined(WITHOUT_GSSAPI) && defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
CONFIGURE_ARGS+= --enable-gssapi=${HEIMDAL_HOME}
+.elif !defined(WITHOUT_GSSAPI) && defined(MAKE_KERBEROS5) && exists(/usr/lib/libkrb5.a)
+CONFIGURE_ARGS+= --enable-gssapi
.else
CONFIGURE_ARGS+= --disable-gssapi
GSSAPI= "@comment "
.endif
-.if exists(/usr/lib/libkrb.a) && !defined(WITHOUT_KERBEROS)
+.include <bsd.port.pre.mk>
+
+# KERBEROS 4 was removed in FreeBSD 5.0-CURRENT
+.if ${OSVERSION} > 500105
+.if defined(WITH_KERBEROS4)
+LIB_DEPENDS+= krb.2:${PORTSDIR}/security/krb4
+CONFIGURE_ARGS+= --enable-krb4=${LOCALBASE}/krb4
+.else
+CONFIGURE_ARGS+= --disable-krb4
+EBONES= "@comment "
+.endif
+.elif exists(/usr/lib/libkrb.a) && defined(MAKE_KERBEROS4) && !defined(WITHOUT_KERBEROS4)
CONFIGURE_ARGS+= --enable-krb4
+.elif !exists(/usr/lib/libkrb.a) && defined(WITH_KERBEROS4)
+LIB_DEPENDS+= krb.2:${PORTSDIR}/security/krb4
+CONFIGURE_ARGS+= --enable-krb4=${LOCALBASE}/krb4
.else
CONFIGURE_ARGS+= --disable-krb4
EBONES= "@comment "
.endif
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
.if !defined(WITH_OPENSSL_BASE)
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
diff --git a/security/cyrus-sasl2/scripts/configure.sasl b/security/cyrus-sasl2/scripts/configure.sasl
index 06837e7fc850..732683f6e83d 100644
--- a/security/cyrus-sasl2/scripts/configure.sasl
+++ b/security/cyrus-sasl2/scripts/configure.sasl
@@ -66,7 +66,7 @@ else
SET_LDAP="ON"
fi
- /usr/bin/dialog --title "Additional SASL options" --clear \
+ /usr/bin/dialog --title "Additional SASL2 options" --clear \
--checklist "\n\
Please select desired options:" -1 -1 16 \
NDBM "ndbm DB" ${SET_NDBM} \