aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-04-14 14:49:21 +0800
committerperky <perky@FreeBSD.org>2004-04-14 14:49:21 +0800
commit9d3d93abf1c0793485256e0efc18a1cd3ae3417f (patch)
treef8c9bb9d4adde3fbdd5eee76293271d16e55547d
parentb9afde5e269c7a7c2433de3203557ac5773b37d4 (diff)
downloadfreebsd-ports-gnome-9d3d93abf1c0793485256e0efc18a1cd3ae3417f.tar.gz
freebsd-ports-gnome-9d3d93abf1c0793485256e0efc18a1cd3ae3417f.tar.zst
freebsd-ports-gnome-9d3d93abf1c0793485256e0efc18a1cd3ae3417f.zip
Fixed a bug where the configure script couldn't detect getaddrinfo()
properly if the KAME stack had SCTP support. Submitted by: suz
-rw-r--r--lang/python/Makefile2
-rw-r--r--lang/python/files/patch-configure10
-rw-r--r--lang/python22/Makefile2
-rw-r--r--lang/python22/files/patch-configure10
-rw-r--r--lang/python23/Makefile2
-rw-r--r--lang/python23/files/patch-configure10
-rw-r--r--lang/python24/Makefile2
-rw-r--r--lang/python24/files/patch-configure10
8 files changed, 41 insertions, 7 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 3fd4cb0ff30a..3495e7ec11c2 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python/files/patch-configure b/lang/python/files/patch-configure
index ef9326985205..40e715f8aa0e 100644
--- a/lang/python/files/patch-configure
+++ b/lang/python/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Wed Nov 19 04:59:36 2003
-+++ configure Mon Feb 9 17:39:34 2004
++++ configure Wed Apr 14 15:37:53 2004
@@ -1321,7 +1321,7 @@
VERSION=2.3
@@ -31,3 +31,11 @@
else
echo "$as_me: program exited with status $ac_status" >&5
echo "$as_me: failed program was:" >&5
+@@ -15001,6 +15007,7 @@
+ hints.ai_family = AF_UNSPEC;
+ hints.ai_flags = passive ? AI_PASSIVE : 0;
+ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
+ if ((gaierr = getaddrinfo(NULL, "54321", &hints, &aitop)) != 0) {
+ (void)gai_strerror(gaierr);
+ goto bad;
diff --git a/lang/python22/Makefile b/lang/python22/Makefile
index 1ddb3c24e2f8..c8a4818d4722 100644
--- a/lang/python22/Makefile
+++ b/lang/python22/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python22/files/patch-configure b/lang/python22/files/patch-configure
new file mode 100644
index 000000000000..1ed245321f04
--- /dev/null
+++ b/lang/python22/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Apr 14 15:29:28 2004
++++ configure Wed Apr 14 15:30:25 2004
+@@ -5523,6 +5523,7 @@
+ hints.ai_family = AF_UNSPEC;
+ hints.ai_flags = passive ? AI_PASSIVE : 0;
+ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
+ if ((gaierr = getaddrinfo(NULL, "54321", &hints, &aitop)) != 0) {
+ (void)gai_strerror(gaierr);
+ goto bad;
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 3fd4cb0ff30a..3495e7ec11c2 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python23/files/patch-configure b/lang/python23/files/patch-configure
index ef9326985205..40e715f8aa0e 100644
--- a/lang/python23/files/patch-configure
+++ b/lang/python23/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Wed Nov 19 04:59:36 2003
-+++ configure Mon Feb 9 17:39:34 2004
++++ configure Wed Apr 14 15:37:53 2004
@@ -1321,7 +1321,7 @@
VERSION=2.3
@@ -31,3 +31,11 @@
else
echo "$as_me: program exited with status $ac_status" >&5
echo "$as_me: failed program was:" >&5
+@@ -15001,6 +15007,7 @@
+ hints.ai_family = AF_UNSPEC;
+ hints.ai_flags = passive ? AI_PASSIVE : 0;
+ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
+ if ((gaierr = getaddrinfo(NULL, "54321", &hints, &aitop)) != 0) {
+ (void)gai_strerror(gaierr);
+ goto bad;
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 3fd4cb0ff30a..3495e7ec11c2 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python24/files/patch-configure b/lang/python24/files/patch-configure
index ef9326985205..40e715f8aa0e 100644
--- a/lang/python24/files/patch-configure
+++ b/lang/python24/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Wed Nov 19 04:59:36 2003
-+++ configure Mon Feb 9 17:39:34 2004
++++ configure Wed Apr 14 15:37:53 2004
@@ -1321,7 +1321,7 @@
VERSION=2.3
@@ -31,3 +31,11 @@
else
echo "$as_me: program exited with status $ac_status" >&5
echo "$as_me: failed program was:" >&5
+@@ -15001,6 +15007,7 @@
+ hints.ai_family = AF_UNSPEC;
+ hints.ai_flags = passive ? AI_PASSIVE : 0;
+ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
+ if ((gaierr = getaddrinfo(NULL, "54321", &hints, &aitop)) != 0) {
+ (void)gai_strerror(gaierr);
+ goto bad;