aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-07-25 17:03:33 +0800
committerhrs <hrs@FreeBSD.org>2013-07-25 17:03:33 +0800
commit9e88f8de7382e30b4ba40ffc369a77a3c5e59d83 (patch)
tree3c3883f44d4e136305876342d9f86977c799ca2a
parent0f57fb08767415cf5d2e7cb1f304399a9de4fd90 (diff)
downloadfreebsd-ports-gnome-9e88f8de7382e30b4ba40ffc369a77a3c5e59d83.tar.gz
freebsd-ports-gnome-9e88f8de7382e30b4ba40ffc369a77a3c5e59d83.tar.zst
freebsd-ports-gnome-9e88f8de7382e30b4ba40ffc369a77a3c5e59d83.zip
Fix hidden dependency due to USE_FOO=yes after including bsd.port.pre.mk.
-rw-r--r--print/ghostscript7/Makefile7
-rw-r--r--print/ghostscript7/files/Makefile.drivers_post36
-rw-r--r--print/ghostscript8/Makefile8
-rw-r--r--print/ghostscript8/files/Makefile.drivers_post6
-rw-r--r--print/ghostscript9-agpl/Makefile8
-rw-r--r--print/ghostscript9-agpl/files/Makefile.drivers_post6
-rw-r--r--print/ghostscript9/Makefile8
-rw-r--r--print/ghostscript9/files/Makefile.drivers_post6
8 files changed, 42 insertions, 43 deletions
diff --git a/print/ghostscript7/Makefile b/print/ghostscript7/Makefile
index cc35ce7f1b79..aa02b04407ef 100644
--- a/print/ghostscript7/Makefile
+++ b/print/ghostscript7/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ghostscript
PORTVERSION= 7.07
-PORTREVISION= 28
+PORTREVISION= 29
CATEGORIES= print
MASTER_SITES= SF/ghostscript/gnu-gs/${PORTVERSION}:gs_srcs \
ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/gnu/gs${PORTVERSION:S/.//}/:gs_srcs \
@@ -82,8 +82,7 @@ post-extract: post-extract-all
USE_GNOME= gtk12
.endif
-.include <bsd.port.pre.mk>
-.include "${FILESDIR}/Makefile.drivers_post"
+.include "files/Makefile.drivers_post"
.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//} \
${OPTIONS_MULTI_X11:MGS_*:S/^GS_//} \
@@ -177,4 +176,4 @@ post-install:
post-install: post-install-docs
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/ghostscript7/files/Makefile.drivers_post b/print/ghostscript7/files/Makefile.drivers_post
index 09bda6899c83..00254eba0e2c 100644
--- a/print/ghostscript7/files/Makefile.drivers_post
+++ b/print/ghostscript7/files/Makefile.drivers_post
@@ -3,17 +3,17 @@
# dmprt specific
.if ${PORT_OPTIONS:MGS_dmprt}
-.include "${FILESDIR}/Makefile.dmprt"
+.include "files/Makefile.dmprt"
.endif
# epag specific
.if ${PORT_OPTIONS:MGS_epag}
-.include "${FILESDIR}/Makefile.epag"
+.include "files/Makefile.epag"
.endif
# pcl3 specific
.if ${PORT_OPTIONS:MGS_pcl3}
-.include "${FILESDIR}/Makefile.pcl3"
+.include "files/Makefile.pcl3"
.endif
# vgalib specific
@@ -64,35 +64,35 @@ CONFLICTS_INSTALL+= ghostscript7-[0-9]*
${PORT_OPTIONS:MGS_cdj880} || \
${PORT_OPTIONS:MGS_cdj890} || \
${PORT_OPTIONS:MGS_cdj1600}
-.include "${FILESDIR}/Makefile.cdj880"
+.include "files/Makefile.cdj880"
.endif
.if ${PORT_OPTIONS:MGS_cdj970}
-.include "${FILESDIR}/Makefile.cdj970"
+.include "files/Makefile.cdj970"
.endif
-.include "${FILESDIR}/Makefile.gprint"
+.include "files/Makefile.gprint"
.if ${PORT_OPTIONS:MGS_md2k} || \
${PORT_OPTIONS:MGS_md5k}
-.include "${FILESDIR}/Makefile.md2k"
+.include "files/Makefile.md2k"
.endif
.if ${PORT_OPTIONS:MGS_md50Mono} || \
${PORT_OPTIONS:MGS_md50Eco} || \
${PORT_OPTIONS:MGS_md1xMono}
-.include "${FILESDIR}/Makefile.alps"
+.include "files/Makefile.alps"
.endif
.if ${PORT_OPTIONS:MGS_bj10v} || \
${PORT_OPTIONS:Mbj10vh}
-.include "${FILESDIR}/Makefile.bj10v"
+.include "files/Makefile.bj10v"
.endif
.if ${PORT_OPTIONS:MGS_bjccmyk} || \
${PORT_OPTIONS:MGS_bjccolor} || \
${PORT_OPTIONS:MGS_bjcgray} || \
${PORT_OPTIONS:MGS_bjcmono}
-.include "${FILESDIR}/Makefile.bjc250"
+.include "files/Makefile.bjc250"
.endif
.if ${PORT_OPTIONS:MGS_lbp1310} || \
@@ -101,7 +101,7 @@ CONFLICTS_INSTALL+= ghostscript7-[0-9]*
${PORT_OPTIONS:MGS_lbp1710} || \
${PORT_OPTIONS:MGS_lbp1810} || \
${PORT_OPTIONS:MGS_lbp1910}
-.include "${FILESDIR}/Makefile.cpca"
+.include "files/Makefile.cpca"
.endif
.if ${PORT_OPTIONS:MGS_lips2p} || \
@@ -113,7 +113,7 @@ CONFLICTS_INSTALL+= ghostscript7-[0-9]*
${PORT_OPTIONS:MGS_lp2000} || \
${PORT_OPTIONS:MGS_npdl} || \
${PORT_OPTIONS:MGS_rpdl}
-.include "${FILESDIR}/Makefile.lips"
+.include "files/Makefile.lips"
.endif
.if ${PORT_OPTIONS:MGS_alc8600} || \
@@ -160,33 +160,33 @@ CONFLICTS_INSTALL+= ghostscript7-[0-9]*
${PORT_OPTIONS:MGS_lp9600} || \
${PORT_OPTIONS:MGS_lp8600} || \
${PORT_OPTIONS:MGS_lp1800}
-.include "${FILESDIR}/Makefile.eplaser"
+.include "files/Makefile.eplaser"
.endif
.if ${PORT_OPTIONS:MGS_mjc180} || \
${PORT_OPTIONS:MGS_mjc360} || \
${PORT_OPTIONS:MGS_mjc720} || \
${PORT_OPTIONS:MGS_mj500c}
-.include "${FILESDIR}/Makefile.mjc"
+.include "files/Makefile.mjc"
.endif
.if ${PORT_OPTIONS:MGS_gdi}
-.include "${FILESDIR}/Makefile.gdi"
+.include "files/Makefile.gdi"
.endif
.if ${PORT_OPTIONS:MGS_lxm3200}
-.include "${FILESDIR}/Makefile.lxm3200"
+.include "files/Makefile.lxm3200"
.endif
.if ${PORT_OPTIONS:MGS_lx5000}
-.include "${FILESDIR}/Makefile.lx5000"
+.include "files/Makefile.lx5000"
.endif
.if ${PORT_OPTIONS:MGS_lex2050} || \
${PORT_OPTIONS:MGS_lex3200} || \
${PORT_OPTIONS:MGS_lex5700} || \
${PORT_OPTIONS:MGS_lex7000}
-.include "${FILESDIR}/Makefile.lex7000"
+.include "files/Makefile.lex7000"
.endif
# pre-defined order
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 1bac0ed5a71b..f5e23505bccb 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ghostscript
PORTVERSION= 8.71
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -93,8 +93,8 @@ CIDFONTDIR= ${DATADIR}/${PORTVERSION}/Resource
EXCLUDE_DIRS= jbig2dec jpeg expat jasper libpng tiff zlib
.include "Makefile.drivers"
-.include <bsd.port.pre.mk>
-.include "${FILESDIR}/Makefile.drivers_post"
+.include <bsd.port.options.mk>
+.include "files/Makefile.drivers_post"
.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//} \
${OPTIONS_MULTI_X11:MGS_*:S/^GS_//} \
@@ -215,4 +215,4 @@ post-install:
post-install: post-install-docs
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/ghostscript8/files/Makefile.drivers_post b/print/ghostscript8/files/Makefile.drivers_post
index 463cfa997f17..b4a62b0b155f 100644
--- a/print/ghostscript8/files/Makefile.drivers_post
+++ b/print/ghostscript8/files/Makefile.drivers_post
@@ -3,12 +3,12 @@
# dmprt specific
.if ${PORT_OPTIONS:MGS_dmprt}
-.include "${FILESDIR}/Makefile.dmprt"
+.include "files/Makefile.dmprt"
.endif
# epag specific
.if ${PORT_OPTIONS:MGS_epag}
-.include "${FILESDIR}/Makefile.epag"
+.include "files/Makefile.epag"
.endif
EPAG_BASE= epag
@@ -24,7 +24,7 @@ post-extract: post-extract-epag
# pcl3 specific
.if ${PORT_OPTIONS:MGS_pcl3}
-.include "${FILESDIR}/Makefile.pcl3"
+.include "files/Makefile.pcl3"
.endif
# cups specific
diff --git a/print/ghostscript9-agpl/Makefile b/print/ghostscript9-agpl/Makefile
index 0829495c4705..3625a4eb6f6b 100644
--- a/print/ghostscript9-agpl/Makefile
+++ b/print/ghostscript9-agpl/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ghostscript
PORTVERSION= 9.07
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -95,8 +95,8 @@ MLINKS= gslp.1 gsbj.1 \
EXCLUDE_DIRS= freetype jbig2dec jpeg expat jasper lcms libpng tiff zlib
.include "Makefile.drivers"
-.include <bsd.port.pre.mk>
-.include "${FILESDIR}/Makefile.drivers_post"
+.include <bsd.port.options.mk>
+.include "files/Makefile.drivers_post"
.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//} \
${OPTIONS_MULTI_X11:MGS_*:S/^GS_//} \
@@ -199,4 +199,4 @@ post-install:
post-install: post-install-docs
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/ghostscript9-agpl/files/Makefile.drivers_post b/print/ghostscript9-agpl/files/Makefile.drivers_post
index 09230870cc8c..30acb96978b8 100644
--- a/print/ghostscript9-agpl/files/Makefile.drivers_post
+++ b/print/ghostscript9-agpl/files/Makefile.drivers_post
@@ -3,12 +3,12 @@
# dmprt specific
.if ${PORT_OPTIONS:MGS_dmprt}
-.include "${FILESDIR}/Makefile.dmprt"
+.include "files/Makefile.dmprt"
.endif
# epag specific
.if ${PORT_OPTIONS:MGS_epag}
-.include "${FILESDIR}/Makefile.epag"
+.include "files/Makefile.epag"
.endif
EPAG_BASE= epag
@@ -24,7 +24,7 @@ post-extract: post-extract-epag
# pcl3 specific
.if ${PORT_OPTIONS:MGS_pcl3}
-.include "${FILESDIR}/Makefile.pcl3"
+.include "files/Makefile.pcl3"
.endif
# cups specific
diff --git a/print/ghostscript9/Makefile b/print/ghostscript9/Makefile
index 2dcb924513c1..63dbd254f41a 100644
--- a/print/ghostscript9/Makefile
+++ b/print/ghostscript9/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ghostscript
PORTVERSION= 9.06
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -97,8 +97,8 @@ MLINKS= gslp.1 gsbj.1 \
EXCLUDE_DIRS= freetype jbig2dec jpeg expat jasper lcms lcms2 libpng tiff zlib
.include "Makefile.drivers"
-.include <bsd.port.pre.mk>
-.include "${FILESDIR}/Makefile.drivers_post"
+.include <bsd.port.options.mk>
+.include "files/Makefile.drivers_post"
.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//} \
${OPTIONS_MULTI_X11:MGS_*:S/^GS_//} \
@@ -201,4 +201,4 @@ post-install:
post-install: post-install-docs
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/ghostscript9/files/Makefile.drivers_post b/print/ghostscript9/files/Makefile.drivers_post
index 8e8c4edf2163..e342f9d8ef60 100644
--- a/print/ghostscript9/files/Makefile.drivers_post
+++ b/print/ghostscript9/files/Makefile.drivers_post
@@ -3,12 +3,12 @@
# dmprt specific
.if ${PORT_OPTIONS:MGS_dmprt}
-.include "${FILESDIR}/Makefile.dmprt"
+.include "files/Makefile.dmprt"
.endif
# epag specific
.if ${PORT_OPTIONS:MGS_epag}
-.include "${FILESDIR}/Makefile.epag"
+.include "files/Makefile.epag"
.endif
EPAG_BASE= epag
@@ -24,7 +24,7 @@ post-extract: post-extract-epag
# pcl3 specific
.if ${PORT_OPTIONS:MGS_pcl3}
-.include "${FILESDIR}/Makefile.pcl3"
+.include "files/Makefile.pcl3"
.endif
# cups specific