aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-02-21 21:03:23 +0800
committermarino <marino@FreeBSD.org>2015-02-21 21:03:23 +0800
commit9e9da6939b2b3017005eb9159367c567b098bffc (patch)
tree7562b612be78ad101ca463c24b175a769fe764cd
parent250e46e8fe059c492ec92cd2145503cb25e4acdc (diff)
downloadfreebsd-ports-gnome-9e9da6939b2b3017005eb9159367c567b098bffc.tar.gz
freebsd-ports-gnome-9e9da6939b2b3017005eb9159367c567b098bffc.tar.zst
freebsd-ports-gnome-9e9da6939b2b3017005eb9159367c567b098bffc.zip
databases/rocksdb: Remove -Werror from flags
RocksDB defines a number of variables it doesn't use, so it fails Werror on modern compilers that check for this. Remove the -Werror flag from the Makefile with sed since we are using it anyway. Approved by: blanket
-rw-r--r--databases/rocksdb/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index ed5b5b4a9261..1e19075added 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -31,7 +31,8 @@ PROGRAMS= blob_store_bench db_bench db_repl_stress db_sanity_test \
table_reader_bench
post-patch:
- @${REINPLACE_CMD} -e '/^all: / s| $$(TESTS)||' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^all: / s| $$(TESTS)||' \
+ -e 's| -Werror||' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|-lpthread|-pthread|; s| -fno-builtin-memcmp||; s| -ltcmalloc||' ${WRKSRC}/build_tools/build_detect_platform
@${REINPLACE_CMD} -e '/PLATFORM_IS_LITTLE_ENDIAN/ s|__|_|g' ${WRKSRC}/port/port_posix.h
.if defined(WITHOUT_PROFILE)