aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-06 21:01:53 +0800
committerbapt <bapt@FreeBSD.org>2013-09-06 21:01:53 +0800
commit9f16a4e58a80e0bb4b5a0fff030ff416dba10992 (patch)
tree60e6bd0c1da61d32c96b74fbcafd43dc4b21eaa6
parent58933da8b9c1e700f7139194f89eec65c1c57f66 (diff)
downloadfreebsd-ports-gnome-9f16a4e58a80e0bb4b5a0fff030ff416dba10992.tar.gz
freebsd-ports-gnome-9f16a4e58a80e0bb4b5a0fff030ff416dba10992.tar.zst
freebsd-ports-gnome-9f16a4e58a80e0bb4b5a0fff030ff416dba10992.zip
Add an explicit dependency on pkgconf
-rw-r--r--accessibility/at-poke/Makefile2
-rw-r--r--audio/deadbeef-mpris-plugin/Makefile1
-rw-r--r--chinese/scim-pinyin/Makefile3
-rw-r--r--ftp/bareftp/Makefile3
-rw-r--r--games/ember/Makefile2
-rw-r--r--graphics/amide/Makefile2
-rw-r--r--graphics/exact-image/Makefile3
-rw-r--r--graphics/f-spot/Makefile3
-rw-r--r--japanese/scim-honoka-plugin-romkan/Makefile9
-rw-r--r--mail/bbmail/Makefile7
-rw-r--r--mail/contact-lookup-applet/Makefile4
-rw-r--r--math/scilab/Makefile3
-rw-r--r--misc/cdcollect/Makefile3
-rw-r--r--misc/quick-lounge-applet/Makefile7
-rw-r--r--multimedia/banshee/Makefile4
-rw-r--r--net/blam/Makefile9
-rw-r--r--net/netspeed_applet/Makefile8
-rw-r--r--net/tsclient/Makefile3
-rw-r--r--science/chemtool-devel/Makefile2
-rw-r--r--science/chemtool/Makefile7
-rw-r--r--sysutils/bubblemon2/Makefile8
-rw-r--r--sysutils/dvdisaster/Makefile2
-rw-r--r--www/mod_auth_openid/Makefile2
-rw-r--r--x11-toolkits/gai/Makefile8
-rw-r--r--x11-toolkits/gtkada/Makefile4
-rw-r--r--x11-wm/bbkeys/Makefile3
-rw-r--r--x11-wm/compiz-plugins-unsupported/Makefile3
-rw-r--r--x11/fluxbg/Makefile8
28 files changed, 41 insertions, 82 deletions
diff --git a/accessibility/at-poke/Makefile b/accessibility/at-poke/Makefile
index 9207bd1c3346..893680b00543 100644
--- a/accessibility/at-poke/Makefile
+++ b/accessibility/at-poke/Makefile
@@ -11,7 +11,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= mva@FreeBSD.org
COMMENT= Accessibility testing and poking tool
-USES= gmake
+USES= gmake pkgconfig
USE_GNOME= gnomeprefix libglade2 libgailgnome
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/audio/deadbeef-mpris-plugin/Makefile b/audio/deadbeef-mpris-plugin/Makefile
index d1ccca0b0a1d..500fe746935d 100644
--- a/audio/deadbeef-mpris-plugin/Makefile
+++ b/audio/deadbeef-mpris-plugin/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USE_GNOME= glib20
+USES= pkgconfig
WRKSRC= ${WRKDIR}/deadbeef-${PORTVERSION}
diff --git a/chinese/scim-pinyin/Makefile b/chinese/scim-pinyin/Makefile
index be337d36c429..0f572a68f544 100644
--- a/chinese/scim-pinyin/Makefile
+++ b/chinese/scim-pinyin/Makefile
@@ -13,8 +13,7 @@ BUILD_DEPENDS= scim>=1.2.0:${PORTSDIR}/textproc/scim
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GNOME= lthack
-USES= pathfix iconv
-USE_GMAKE= yes
+USES= pathfix iconv gmake pkgconfig
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS+= --disable-skim-support
diff --git a/ftp/bareftp/Makefile b/ftp/bareftp/Makefile
index fb32d95f503c..013aa6d0f78b 100644
--- a/ftp/bareftp/Makefile
+++ b/ftp/bareftp/Makefile
@@ -16,9 +16,8 @@ CONFIGURE_ARGS= --datarootdir="${PREFIX}/share" \
--includedir="${LOCALBASE}/include"
INSTALLS_ICONS= yes
-USES= gettext
+USES= gettext gmake pkgconfig
USE_GNOME= gtksharp20 gnomesharp20
-USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 36e3f1e370ae..16a4760edb46 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -36,7 +36,7 @@ USE_LDCONFIG= YES
USE_LUA= 5.1
LUA_COMPS= toluaxx
USE_OPENAL= al alut
-USES= pathfix
+USES= pathfix pkgconfig
USE_BZIP2= YES
CPPFLAGS+= -DBR_NO_MACROS
diff --git a/graphics/amide/Makefile b/graphics/amide/Makefile
index adb8c439f1e1..725c2d23c5a7 100644
--- a/graphics/amide/Makefile
+++ b/graphics/amide/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
GNU_CONFIGURE= yes
USE_CSTD= gnu89
MAKE_JOBS_UNSAFE= yes
-USES= gettext gmake
+USES= gettext gmake pkgconfig
USE_GNOME= gtk20 libgnomecanvas libgnomeui libxml2
INSTALLS_OMF= yes
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 8b868a186c21..b5839ba53941 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -28,8 +28,7 @@ CFLAGS+= -fPIC
#broken headers on c++ in base system:
CPPFLAGS+= -fpermissive -I${LOCALBASE}/include/libpng15
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5= yes
+USES= gmake perl5 pkgconfig
USE_PYTHON= 2.5+
USE_XORG= x11
USE_EFL= evas
diff --git a/graphics/f-spot/Makefile b/graphics/f-spot/Makefile
index a48bb01617a3..e5229195bba7 100644
--- a/graphics/f-spot/Makefile
+++ b/graphics/f-spot/Makefile
@@ -29,8 +29,7 @@ USE_BZIP2= yes
USE_SQLITE= yes
USE_GNOME= gnomehack gnomeprefix intlhack gnomedesktopsharp20
GNU_CONFIGURE= yes
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake pkgconfig
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
diff --git a/japanese/scim-honoka-plugin-romkan/Makefile b/japanese/scim-honoka-plugin-romkan/Makefile
index a81a3ce7aaa0..ed64bb33c4a5 100644
--- a/japanese/scim-honoka-plugin-romkan/Makefile
+++ b/japanese/scim-honoka-plugin-romkan/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ja-scim-honoka-plugin-romkan
-# Date created: 3 Jun 2006
-# Whom: Masashi CHIBA
-#
+# Created by: Masashi CHIBA
# $FreeBSD$
-#
PORTNAME= scim-honoka-plugin-romkan
PORTVERSION= 0.9.0
@@ -19,9 +15,8 @@ BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/honoka.so:${PORTSDIR}/japanese/scim-honoka
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gettext iconv pathfix
+USES= gettext iconv pathfix gmake pkgconfig
USE_GNOME= lthack
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
diff --git a/mail/bbmail/Makefile b/mail/bbmail/Makefile
index ba80addf4676..0f3d8a810d8e 100644
--- a/mail/bbmail/Makefile
+++ b/mail/bbmail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bbmail
-# Date created: May 3 1999
-# Whom: Chris Piazza <cpiazza@FreeBSD.org>
-#
+# Created by: Chris Piazza <cpiazza@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= bbmail
PORTVERSION= 0.9.3
@@ -15,6 +11,7 @@ COMMENT= A tool intended for Blackbox that checks for new mail
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libbt.pc:${PORTSDIR}/x11-wm/blackbox
+USES= pkgconfig
USE_XORG= xext
GNU_CONFIGURE= yes
diff --git a/mail/contact-lookup-applet/Makefile b/mail/contact-lookup-applet/Makefile
index 6f9a0d22ede8..70936de3d484 100644
--- a/mail/contact-lookup-applet/Makefile
+++ b/mail/contact-lookup-applet/Makefile
@@ -1,6 +1,7 @@
# Created by: kwm@rainbow-runner.nl
# $FreeBSD$
# $MCom: ports/mail/contact-lookup-applet/Makefile,v 1.15 2007/07/29 22:17:31 mezz Exp $
+
PORTNAME= contact
PORTVERSION= 0.17
PORTREVISION= 8
@@ -12,10 +13,9 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Gnome panel applet for easy Evolution contact book access
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= evolutiondataserver gnomepanel gnomeprefix \
libgnomeui
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 11ccb36ae201..3fb19f7d3ab2 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -23,9 +23,8 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
USE_FORTRAN= yes
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/misc/cdcollect/Makefile b/misc/cdcollect/Makefile
index 9c29e2cd44cf..89c8424cc0e6 100644
--- a/misc/cdcollect/Makefile
+++ b/misc/cdcollect/Makefile
@@ -15,8 +15,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix intlhack libgnome gnomesharp20
GCONF_SCHEMAS= cdcollect.schemas
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/misc/quick-lounge-applet/Makefile b/misc/quick-lounge-applet/Makefile
index fb266ec555c2..dd2c11a22ea6 100644
--- a/misc/quick-lounge-applet/Makefile
+++ b/misc/quick-lounge-applet/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: quick-lounge-applet
-# Date created: 01 March 2003
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/misc/quick-lounge-applet/Makefile,v 1.15 2010/11/16 10:06:22 kwm Exp $
-#
PORTNAME= quick-lounge-applet
PORTVERSION= 2.14.1
@@ -19,6 +15,7 @@ COMMENT= Applet to originize your preferred applications on the GNOME Panel
USE_BZIP2= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
+USES= gmake pkgconfig
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomepanel
GNU_CONFIGURE= yes
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
index 67a507eb26f4..38aee17623e8 100644
--- a/multimedia/banshee/Makefile
+++ b/multimedia/banshee/Makefile
@@ -34,8 +34,8 @@ YOUTUBE_DESC= Build and/or install the Youtube extension
OPTIONS_DEFAULT=BPMDETECT GIO MTP WEBKIT YOUTUBE
USE_XZ= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USES= gmake perl5 pkgconfig
+USE_PERL5= build
GNU_CONFIGURE= yes
USE_GNOME= gnomehack gtksharp20 gnomesharp20
USE_GSTREAMER= cdparanoia
diff --git a/net/blam/Makefile b/net/blam/Makefile
index ec31f55b064c..724e30102ded 100644
--- a/net/blam/Makefile
+++ b/net/blam/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: blam
-# Date created: 20040812
-# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
-#
+# Created by: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
# $FreeBSD$
# $Id: Makefile,v 1.22 2006/10/26 05:32:53 tmclau02 Exp $
-#
PORTNAME= blam
PORTVERSION= 1.8.7
@@ -20,10 +16,9 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/webkit-sharp-1.0.pc:${PORTSDIR}/ww
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
-USE_GMAKE= yes
CONFIGURE_ENV= GMSGFMT="${LOCALBASE}/bin/msgfmt" DATADIRNAME="share"
USE_GNOME= gnomesharp20
-USES= gettext
+USES= gettext gmake pkgconfig
INSTALLS_ICONS= yes
GCONF_SCHEMAS= blam.schemas
diff --git a/net/netspeed_applet/Makefile b/net/netspeed_applet/Makefile
index d9a38db61410..f01bdcbacf31 100644
--- a/net/netspeed_applet/Makefile
+++ b/net/netspeed_applet/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: netspeed_applet
-# Date created: 08 February 2003
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/net/netspeed_applet/Makefile,v 1.2 2007/05/19 21:36:17 marcus Exp $
@@ -17,9 +14,8 @@ COMMENT= Applet that shows how much network traffic occurs on an interface
LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop
INSTALLS_OMF= yes
-USE_GMAKE= yes
USE_GNOME= gnomehier intlhack gnomeprefix gnomehack gnomepanel
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/tsclient/Makefile b/net/tsclient/Makefile
index 48d4345b0b4e..8c82ecbf958b 100644
--- a/net/tsclient/Makefile
+++ b/net/tsclient/Makefile
@@ -14,8 +14,7 @@ RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
USE_AUTOTOOLS= libtool
USE_GNOME= gtk20
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="`pkg-config --libs libgnomeui-2.0`"
CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
diff --git a/science/chemtool-devel/Makefile b/science/chemtool-devel/Makefile
index cca7295a9df3..76a5b6eb01a7 100644
--- a/science/chemtool-devel/Makefile
+++ b/science/chemtool-devel/Makefile
@@ -20,7 +20,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-1.7alpha15/
USE_GNOME= gtk20
#USE_AUTOTOOLS= autoconf213
GNU_CONFIGURE= yes
-USES= gettext gmake
+USES= gettext gmake pkgconfig
CONFIGURE_ARGS= --enable-emf=yes
PKGNAMESUFFIX= -devel
MAN1= chemtool.1 cht.1
diff --git a/science/chemtool/Makefile b/science/chemtool/Makefile
index 564616a08bf1..d1680ac5cc07 100644
--- a/science/chemtool/Makefile
+++ b/science/chemtool/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: chemtool
-# Date created: Mar 31, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
PORTNAME= chemtool
@@ -16,7 +13,7 @@ COMMENT= Draw organic molecules easily and store them
RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
USE_GNOME= gtk20
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/sysutils/bubblemon2/Makefile b/sysutils/bubblemon2/Makefile
index 9888a3b134d4..825c6f3ecd83 100644
--- a/sysutils/bubblemon2/Makefile
+++ b/sysutils/bubblemon2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sysutils/bubblemon2
-# Date created: 08 Jul 2002
-# Whom: Juan Salaverria <rael@vectorstar.net>
-#
+# Created by: Juan Salaverria <rael@vectorstar.net>
# $FreeBSD$
-#
PORTNAME= bubblemon2
PORTVERSION= 2.0.17
@@ -18,7 +14,7 @@ COMMENT= A system CPU and memory load monitor for GNOME2
LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop
USE_GNOME= gnomehack gnomepanel gnomeprefix intlhack libgnomeui
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
LDFLAGS+= -L${LOCALBASE}/lib `pkg-config --libs libgnomeui-2.0`
diff --git a/sysutils/dvdisaster/Makefile b/sysutils/dvdisaster/Makefile
index 0310ed42b476..4a6272a3127a 100644
--- a/sysutils/dvdisaster/Makefile
+++ b/sysutils/dvdisaster/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
MAKEFILE= GNUmakefile
USE_BZIP2= yes
-USES= gettext
+USES= gettext pkgconfig
USE_GNOME= gtk20
CONFIGURE_ARGS= --prefix=${PREFIX} \
--docsubdir="/" \
diff --git a/www/mod_auth_openid/Makefile b/www/mod_auth_openid/Makefile
index e396b0f7be07..8e3156096512 100644
--- a/www/mod_auth_openid/Makefile
+++ b/www/mod_auth_openid/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= opkele:${PORTSDIR}/devel/libopkele \
PLIST_FILES= ${APACHEMODDIR}/mod_auth_openid.so
USE_APACHE= 22
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pcre=${LOCALBASE}
diff --git a/x11-toolkits/gai/Makefile b/x11-toolkits/gai/Makefile
index 6279df22ad16..5aa5be91f5d2 100644
--- a/x11-toolkits/gai/Makefile
+++ b/x11-toolkits/gai/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: gai
-# Date created: Feb 16, 2004
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= gai
PORTVERSION= 0.5.10
@@ -18,6 +13,7 @@ COMMENT= General Applet Interface Library
LIB_DEPENDS= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
USE_BZIP2= yes
+USES= pkgconfig
USE_GL= gl
USE_SDL= sdl
USE_GNOME= gnomepanel libgnomeui
diff --git a/x11-toolkits/gtkada/Makefile b/x11-toolkits/gtkada/Makefile
index 78cc50b0ea3e..98d4bd84f4e1 100644
--- a/x11-toolkits/gtkada/Makefile
+++ b/x11-toolkits/gtkada/Makefile
@@ -15,9 +15,9 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_GNOME= gtk20
-USES= ada gmake
+USES= ada gmake perl5 pkgconfig
DESTINY= ${WRKDIR}/destino
MAKE_ENV+= DESTDIR=${DESTINY} \
diff --git a/x11-wm/bbkeys/Makefile b/x11-wm/bbkeys/Makefile
index 0d824f598dd4..89066a37c4ab 100644
--- a/x11-wm/bbkeys/Makefile
+++ b/x11-wm/bbkeys/Makefile
@@ -14,7 +14,8 @@ LICENSE= MIT
BUILD_DEPENDS= blackbox:${PORTSDIR}/x11-wm/blackbox
-USE_PERL5_BUILD= yes
+USES= perl5 pkgconfig
+USE_PERL5= build
USE_XORG= x11 xext
GNU_CONFIGURE= yes
CPPFLAGS+= `pkg-config --cflags xft`
diff --git a/x11-wm/compiz-plugins-unsupported/Makefile b/x11-wm/compiz-plugins-unsupported/Makefile
index 6440ab9373a9..d584cc93c432 100644
--- a/x11-wm/compiz-plugins-unsupported/Makefile
+++ b/x11-wm/compiz-plugins-unsupported/Makefile
@@ -20,8 +20,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USE_GL= yes
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= intltool
USE_XORG= glproto
USE_LDCONFIG= yes
diff --git a/x11/fluxbg/Makefile b/x11/fluxbg/Makefile
index c6e8135ba4cb..b6c176b03d38 100644
--- a/x11/fluxbg/Makefile
+++ b/x11/fluxbg/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fluxbg
-# Date created: 30 September 2003
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= fluxbg
PORTVERSION= 0.7
@@ -17,7 +13,7 @@ COMMENT= Background changer for fluxbox/blackbox
LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtkmm20
GNU_CONFIGURE= yes
-USES= pathfix
+USES= pathfix pkgconfig
.include <bsd.port.pre.mk>