aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-11-16 00:21:01 +0800
committerriggs <riggs@FreeBSD.org>2015-11-16 00:21:01 +0800
commita1c8948170feac65d70330c9dc709454e6c6e752 (patch)
tree07a5d76e133d1ad1ba591c5fbc0cf0ee1c9414fe
parentbbd55014ae03dc1d1931ee7a284e09e7a2ba6e77 (diff)
downloadfreebsd-ports-gnome-a1c8948170feac65d70330c9dc709454e6c6e752.tar.gz
freebsd-ports-gnome-a1c8948170feac65d70330c9dc709454e6c6e752.tar.zst
freebsd-ports-gnome-a1c8948170feac65d70330c9dc709454e6c6e752.zip
Update to upstream version 0.7.0-b1
PR: 204499 Submitted by: yamagi@yamagi.org (maintainer)
-rw-r--r--audio/ncmpcpp/Makefile12
-rw-r--r--audio/ncmpcpp/distinfo4
-rw-r--r--audio/ncmpcpp/files/patch-src_bindings.cpp11
-rw-r--r--audio/ncmpcpp/files/patch-src_browser.cpp10
-rw-r--r--audio/ncmpcpp/files/patch-src_configuration.cpp10
-rw-r--r--audio/ncmpcpp/files/patch-src_helpers.cpp10
-rw-r--r--audio/ncmpcpp/files/patch-src_media__library.cpp10
-rw-r--r--audio/ncmpcpp/files/patch-src_mpdpp.cpp24
-rw-r--r--audio/ncmpcpp/files/patch-src_mpdpp.h9
-rw-r--r--audio/ncmpcpp/files/patch-src_playlist.cpp10
-rw-r--r--audio/ncmpcpp/files/patch-src_playlist__editor.cpp10
-rw-r--r--audio/ncmpcpp/files/patch-src_search__engine.cpp10
-rw-r--r--audio/ncmpcpp/files/patch-src_status.cpp (renamed from audio/ncmpcpp/files/patch-src__status.cpp)2
-rw-r--r--audio/ncmpcpp/files/patch-src_tag__editor.cpp10
-rw-r--r--audio/ncmpcpp/files/patch-src_window.h12
-rw-r--r--audio/ncmpcpp/pkg-message15
16 files changed, 116 insertions, 53 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index 3aee738f3b18..2095b3455cfa 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -1,9 +1,10 @@
# $FreeBSD$
PORTNAME= ncmpcpp
-PORTVERSION= 0.6.7
+PORTVERSION= 0.7.0b1
CATEGORIES= audio
MASTER_SITES= http://ncmpcpp.rybczak.net/stable/
+DISTNAME= ncmpcpp-0.7_beta1
MAINTAINER= yamagi@yamagi.org
COMMENT= ncurses mpd client, clone of ncmpc with some new features
@@ -15,7 +16,9 @@ LIB_DEPENDS= libmpdclient.so:${PORTSDIR}/audio/libmpdclient \
libfftw3.so:${PORTSDIR}/math/fftw3 \
libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
-USES= compiler:c++11-lib iconv libtool ncurses pkgconfig tar:bzip2
+WRKSRC= ${WRKDIR}/ncmpcpp-0.7_beta1
+
+USES= compiler:c++11-lib iconv libtool ncurses:port pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= glib20
CPPFLAGS+= -I${LOCALBASE}/include
@@ -51,11 +54,6 @@ VISUALIZER_CONFIGURE_ENABLE= visualizer
.include <bsd.port.pre.mk>
-.if ${NCURSESBASE} == /usr
-# no need to use ncurses-config if we use ncurses from the base system
-CONFIGURE_ARGS+= NCURSES_CONFIG=/usr/bin/true
-.endif
-
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/ncmpcpp ${STAGEDIR}${PREFIX}/bin/
post-install-DOCS-on:
diff --git a/audio/ncmpcpp/distinfo b/audio/ncmpcpp/distinfo
index 6951cfcaafae..7a6970638948 100644
--- a/audio/ncmpcpp/distinfo
+++ b/audio/ncmpcpp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ncmpcpp-0.6.7.tar.bz2) = 08807dc515b4e093154a6e91cdd17ba64ebedcfcd7aa34d0d6eb4d4cc28a217b
-SIZE (ncmpcpp-0.6.7.tar.bz2) = 429687
+SHA256 (ncmpcpp-0.7_beta1.tar.bz2) = 5d84fca070e19461524bdfcf46245e9ee4d445f1966984b7c48c71115e408065
+SIZE (ncmpcpp-0.7_beta1.tar.bz2) = 440532
diff --git a/audio/ncmpcpp/files/patch-src_bindings.cpp b/audio/ncmpcpp/files/patch-src_bindings.cpp
deleted file mode 100644
index 2110552cd32f..000000000000
--- a/audio/ncmpcpp/files/patch-src_bindings.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/bindings.cpp.orig 2015-07-05 02:18:34 UTC
-+++ src/bindings.cpp
-@@ -108,7 +108,7 @@ Actions::BaseAction *parseActionLine(con
- // push single character into input queue
- std::string arg = getEnclosedString(line, '"', '"', 0);
- Key k = stringToSpecialKey(arg);
-- auto queue = std::vector<int>{ k.getChar() };
-+ auto queue = std::vector<int>{ (int)k.getChar() };
- if (k != Key::noOp)
- result = new Actions::PushCharacters(&Global::wFooter, std::move(queue));
- else
diff --git a/audio/ncmpcpp/files/patch-src_browser.cpp b/audio/ncmpcpp/files/patch-src_browser.cpp
new file mode 100644
index 000000000000..ca8ca3b38d74
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_browser.cpp
@@ -0,0 +1,10 @@
+--- src/browser.cpp.orig 2015-11-04 20:01:29 UTC
++++ src/browser.cpp
+@@ -42,6 +42,7 @@
+ #include "utility/comparators.h"
+ #include "utility/string.h"
+ #include "configuration.h"
++#include "format_impl.h"
+
+ using Global::MainHeight;
+ using Global::MainStartY;
diff --git a/audio/ncmpcpp/files/patch-src_configuration.cpp b/audio/ncmpcpp/files/patch-src_configuration.cpp
new file mode 100644
index 000000000000..f519c206a591
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_configuration.cpp
@@ -0,0 +1,10 @@
+--- src/configuration.cpp.orig 2015-11-04 20:01:29 UTC
++++ src/configuration.cpp
+@@ -29,6 +29,7 @@
+ #include "mpdpp.h"
+ #include "settings.h"
+ #include "utility/string.h"
++#include "format_impl.h"
+
+ namespace po = boost::program_options;
+
diff --git a/audio/ncmpcpp/files/patch-src_helpers.cpp b/audio/ncmpcpp/files/patch-src_helpers.cpp
new file mode 100644
index 000000000000..cc2045b8f1bb
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_helpers.cpp
@@ -0,0 +1,10 @@
+--- src/helpers.cpp.orig 2015-11-04 20:01:29 UTC
++++ src/helpers.cpp
+@@ -26,6 +26,7 @@
+ #include "playlist.h"
+ #include "statusbar.h"
+ #include "utility/functional.h"
++#include "format_impl.h"
+
+ const MPD::Song *currentSong(const BaseScreen *screen)
+ {
diff --git a/audio/ncmpcpp/files/patch-src_media__library.cpp b/audio/ncmpcpp/files/patch-src_media__library.cpp
new file mode 100644
index 000000000000..cbf51fa88d60
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_media__library.cpp
@@ -0,0 +1,10 @@
+--- src/media_library.cpp.orig 2015-11-04 20:01:29 UTC
++++ src/media_library.cpp
+@@ -40,6 +40,7 @@
+ #include "utility/type_conversions.h"
+ #include "title.h"
+ #include "screen_switcher.h"
++#include "format_impl.h"
+
+ using Global::MainHeight;
+ using Global::MainStartY;
diff --git a/audio/ncmpcpp/files/patch-src_mpdpp.cpp b/audio/ncmpcpp/files/patch-src_mpdpp.cpp
index 41043282691c..db5a6c03c5be 100644
--- a/audio/ncmpcpp/files/patch-src_mpdpp.cpp
+++ b/audio/ncmpcpp/files/patch-src_mpdpp.cpp
@@ -1,6 +1,6 @@
---- src/mpdpp.cpp.orig 2015-07-05 02:18:34 UTC
+--- src/mpdpp.cpp.orig 2015-11-09 12:52:27 UTC
+++ src/mpdpp.cpp
-@@ -38,6 +38,8 @@ Connection::Connection() : m_connection(
+@@ -95,6 +95,8 @@ Connection::Connection() : m_connection(
m_port(6600),
m_timeout(15)
{
@@ -8,17 +8,17 @@
+ m_gen.seed(rd());
}
- Connection::~Connection()
-@@ -504,7 +506,7 @@ bool Connection::AddRandomTag(mpd_tag_ty
- }
- else
+ void Connection::Connect()
+@@ -560,7 +562,7 @@ bool Connection::AddRandomTag(mpd_tag_ty
+ if (number > tags.size())
+ return false;
+
+- std::random_shuffle(tags.begin(), tags.end());
++ std::shuffle(tags.begin(), tags.end(), m_gen);
+ auto it = tags.begin();
+ for (size_t i = 0; i < number && it != tags.end(); ++i)
{
-- std::random_shuffle(tags.begin(), tags.end());
-+ std::shuffle(tags.begin(), tags.end(), m_gen);
- auto it = tags.begin();
- for (size_t i = 0; i < number && it != tags.end(); ++i)
- {
-@@ -544,7 +546,7 @@ bool Connection::AddRandomSongs(size_t n
+@@ -599,7 +601,7 @@ bool Connection::AddRandomSongs(size_t n
}
else
{
diff --git a/audio/ncmpcpp/files/patch-src_mpdpp.h b/audio/ncmpcpp/files/patch-src_mpdpp.h
index 31c1f17e81b8..38eb97278d1c 100644
--- a/audio/ncmpcpp/files/patch-src_mpdpp.h
+++ b/audio/ncmpcpp/files/patch-src_mpdpp.h
@@ -1,4 +1,4 @@
---- src/mpdpp.h.orig 2015-07-05 02:18:34 UTC
+--- src/mpdpp.h.orig 2015-11-09 12:51:44 UTC
+++ src/mpdpp.h
@@ -23,6 +23,7 @@
@@ -8,11 +8,10 @@
#include <set>
#include <vector>
-@@ -277,6 +278,8 @@ private:
+@@ -587,6 +588,7 @@ private:
+ int m_port;
+ int m_timeout;
std::string m_password;
-
- mpd_tag_type m_searched_field;
-+
+ std::mt19937 m_gen;
};
diff --git a/audio/ncmpcpp/files/patch-src_playlist.cpp b/audio/ncmpcpp/files/patch-src_playlist.cpp
new file mode 100644
index 000000000000..6e4ddac347d9
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_playlist.cpp
@@ -0,0 +1,10 @@
+--- src/playlist.cpp.orig 2015-11-04 20:01:29 UTC
++++ src/playlist.cpp
+@@ -35,6 +35,7 @@
+ #include "utility/comparators.h"
+ #include "utility/functional.h"
+ #include "title.h"
++#include "format_impl.h"
+
+ using Global::MainHeight;
+ using Global::MainStartY;
diff --git a/audio/ncmpcpp/files/patch-src_playlist__editor.cpp b/audio/ncmpcpp/files/patch-src_playlist__editor.cpp
new file mode 100644
index 000000000000..b71d69658a8b
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_playlist__editor.cpp
@@ -0,0 +1,10 @@
+--- src/playlist_editor.cpp.orig 2015-11-04 20:01:29 UTC
++++ src/playlist_editor.cpp
+@@ -39,6 +39,7 @@
+ #include "utility/comparators.h"
+ #include "title.h"
+ #include "screen_switcher.h"
++#include "format_impl.h"
+
+ using Global::MainHeight;
+ using Global::MainStartY;
diff --git a/audio/ncmpcpp/files/patch-src_search__engine.cpp b/audio/ncmpcpp/files/patch-src_search__engine.cpp
new file mode 100644
index 000000000000..68dff6bbce42
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_search__engine.cpp
@@ -0,0 +1,10 @@
+--- src/search_engine.cpp.orig 2015-11-04 20:01:29 UTC
++++ src/search_engine.cpp
+@@ -35,6 +35,7 @@
+ #include "utility/comparators.h"
+ #include "title.h"
+ #include "screen_switcher.h"
++#include "format_impl.h"
+
+ using Global::MainHeight;
+ using Global::MainStartY;
diff --git a/audio/ncmpcpp/files/patch-src__status.cpp b/audio/ncmpcpp/files/patch-src_status.cpp
index a7fafc7595f9..72edb2b0666c 100644
--- a/audio/ncmpcpp/files/patch-src__status.cpp
+++ b/audio/ncmpcpp/files/patch-src_status.cpp
@@ -1,4 +1,4 @@
---- src/status.cpp.orig 2015-07-05 02:18:34 UTC
+--- src/status.cpp.orig 2015-11-04 20:01:29 UTC
+++ src/status.cpp
@@ -21,6 +21,8 @@
#include <boost/date_time/posix_time/posix_time.hpp>
diff --git a/audio/ncmpcpp/files/patch-src_tag__editor.cpp b/audio/ncmpcpp/files/patch-src_tag__editor.cpp
new file mode 100644
index 000000000000..f50899f6c8e8
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_tag__editor.cpp
@@ -0,0 +1,10 @@
+--- src/tag_editor.cpp.orig 2015-11-04 20:01:29 UTC
++++ src/tag_editor.cpp
+@@ -42,6 +42,7 @@
+ #include "title.h"
+ #include "tags.h"
+ #include "screen_switcher.h"
++#include "format_impl.h"
+
+ using Global::myScreen;
+ using Global::MainHeight;
diff --git a/audio/ncmpcpp/files/patch-src_window.h b/audio/ncmpcpp/files/patch-src_window.h
new file mode 100644
index 000000000000..0ab80f40698f
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_window.h
@@ -0,0 +1,12 @@
+--- src/window.h.orig 2015-11-04 20:01:29 UTC
++++ src/window.h
+@@ -23,7 +23,9 @@
+
+ #include "config.h"
+
++#define _XOPEN_SOURCE_EXTENDED
+ #include "curses.h"
++
+ #include "gcc.h"
+
+ #include <boost/optional.hpp>
diff --git a/audio/ncmpcpp/pkg-message b/audio/ncmpcpp/pkg-message
deleted file mode 100644
index a8a8fcd78b7e..000000000000
--- a/audio/ncmpcpp/pkg-message
+++ /dev/null
@@ -1,15 +0,0 @@
-###########################################################################
-ncmpcpp has been installed.
-
-Attention:
-ncmcpp no longer uses ~/.ncmpcpp/keys for configuration. It has been replaced
-by the incompatible ~/.ncmpcpp/bindings.
-
---------------------------------------------------------------------------
-
-A default config has been installed to:
-PREFIX/share/doc/ncmpcpp/config
-
-For more information about ncmpcpp visit:
-http://unkart.ovh.org/ncmpcpp
-###########################################################################