aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2012-01-24 04:36:58 +0800
committercrees <crees@FreeBSD.org>2012-01-24 04:36:58 +0800
commita1fb242b2238da3d53eec157520cde29ab2402b5 (patch)
tree4bf3e95a9c6af6c14d05c43ba70b7820a2dcb244
parenteec080149f1a6228f164938939626bb14baedda0 (diff)
downloadfreebsd-ports-gnome-a1fb242b2238da3d53eec157520cde29ab2402b5.tar.gz
freebsd-ports-gnome-a1fb242b2238da3d53eec157520cde29ab2402b5.tar.zst
freebsd-ports-gnome-a1fb242b2238da3d53eec157520cde29ab2402b5.zip
Add OPTION to postgresql9[10]-contrib for building without uuid-ossp
Requested by: sunpoet
-rw-r--r--databases/postgresql90-contrib/Makefile8
-rw-r--r--databases/postgresql90-server/Makefile8
-rw-r--r--databases/postgresql90-server/pkg-plist-contrib6
-rw-r--r--databases/postgresql91-contrib/Makefile8
-rw-r--r--databases/postgresql91-server/Makefile8
-rw-r--r--databases/postgresql91-server/pkg-plist-contrib8
-rw-r--r--databases/postgresql92-server/Makefile8
-rw-r--r--databases/postgresql92-server/pkg-plist-contrib8
8 files changed, 45 insertions, 17 deletions
diff --git a/databases/postgresql90-contrib/Makefile b/databases/postgresql90-contrib/Makefile
index 1b028084066e..803c3fd44c45 100644
--- a/databases/postgresql90-contrib/Makefile
+++ b/databases/postgresql90-contrib/Makefile
@@ -13,8 +13,8 @@ PKGNAMESUFFIX= -contrib
MAINTAINER= crees@FreeBSD.org
COMMENT= The contrib utilities from the PostgreSQL distribution
-LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt xml2.5:${PORTSDIR}/textproc/libxml2
-BUILD_DEPENDS= ${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid
+LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt \
+ xml2.5:${PORTSDIR}/textproc/libxml2
USE_PGSQL= yes
DEFAULT_PGSQL_VER=90
@@ -26,9 +26,11 @@ BUILD_DIRS= src/port contrib
INSTALL_DIRS= contrib
SLAVE_ONLY= yes
-CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-ossp-uuid
+CONFIGURE_ARGS+=--with-libxslt --with-libxml
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
+OPTIONS= OSSP_UUID "Enable / disable ossp-uuid support" on
+
post-install:
@- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/contrib/README
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index 8048f64c548a..edbd8ccfe69d 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -121,6 +121,14 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
. endif
.endif # !SLAVE_ONLY
+.if defined(WITH_OSSP_UUID)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid
+CONFIGURE_ARGS+=--with-ossp-uuid
+PLIST_SUB+= OSSP=""
+.else
+PLIST_SUB+= OSSP="@comment "
+.endif
+
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
diff --git a/databases/postgresql90-server/pkg-plist-contrib b/databases/postgresql90-server/pkg-plist-contrib
index 06f6e95af4b8..b3c4baf554cb 100644
--- a/databases/postgresql90-server/pkg-plist-contrib
+++ b/databases/postgresql90-server/pkg-plist-contrib
@@ -43,7 +43,7 @@ lib/postgresql/test_parser.so
lib/postgresql/timetravel.so
lib/postgresql/tsearch2.so
lib/postgresql/unaccent.so
-lib/postgresql/uuid-ossp.so
+%%OSSP%%lib/postgresql/uuid-ossp.so
%%DOCSDIR%%/README-contrib
%%DOCSDIR%%/contrib/README
%%DOCSDIR%%/contrib/autoinc.example
@@ -88,8 +88,8 @@ share/postgresql/contrib/test_parser.sql
share/postgresql/contrib/timetravel.sql
share/postgresql/contrib/tsearch2.sql
share/postgresql/contrib/unaccent.sql
-share/postgresql/contrib/uninstall_uuid-ossp.sql
-share/postgresql/contrib/uuid-ossp.sql
+%%OSSP%%share/postgresql/contrib/uninstall_uuid-ossp.sql
+%%OSSP%%share/postgresql/contrib/uuid-ossp.sql
share/postgresql/contrib/uninstall__int.sql
share/postgresql/contrib/uninstall_adminpack.sql
share/postgresql/contrib/uninstall_btree_gin.sql
diff --git a/databases/postgresql91-contrib/Makefile b/databases/postgresql91-contrib/Makefile
index 80248f9d16e5..4687e2d343f7 100644
--- a/databases/postgresql91-contrib/Makefile
+++ b/databases/postgresql91-contrib/Makefile
@@ -12,8 +12,8 @@ PKGNAMESUFFIX= -contrib
MAINTAINER= crees@FreeBSD.org
COMMENT= The contrib utilities from the PostgreSQL distribution
-LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt xml2.5:${PORTSDIR}/textproc/libxml2
-BUILD_DEPENDS= ${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid
+LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt \
+ xml2.5:${PORTSDIR}/textproc/libxml2
USE_PGSQL= yes
DEFAULT_PGSQL_VER=91
@@ -25,9 +25,11 @@ BUILD_DIRS= src/port contrib
INSTALL_DIRS= contrib
SLAVE_ONLY= yes
-CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-ossp-uuid
+CONFIGURE_ARGS+=--with-libxslt --with-libxml
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
+OPTIONS= OSSP_UUID "Enable / disable ossp-uuid support" on
+
post-install:
@- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/extension/README
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index 4783cf7c7fa5..7148c75aaf49 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -121,6 +121,14 @@ LIB_DEPENDS+= icudata.48:${PORTSDIR}/devel/icu
. endif
.endif # !SLAVE_ONLY
+.if defined(WITH_OSSP_UUID)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid
+CONFIGURE_ARGS+=--with-ossp-uuid
+PLIST_SUB+= OSSP=""
+.else
+PLIST_SUB+= OSSP="@comment "
+.endif
+
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
diff --git a/databases/postgresql91-server/pkg-plist-contrib b/databases/postgresql91-server/pkg-plist-contrib
index b616652ad171..25a7ad8cc1cf 100644
--- a/databases/postgresql91-server/pkg-plist-contrib
+++ b/databases/postgresql91-server/pkg-plist-contrib
@@ -43,7 +43,7 @@ lib/postgresql/test_parser.so
lib/postgresql/timetravel.so
lib/postgresql/tsearch2.so
lib/postgresql/unaccent.so
-lib/postgresql/uuid-ossp.so
+%%OSSP%%lib/postgresql/uuid-ossp.so
%%DOCSDIR%%/README-contrib
%%DOCSDIR%%/extension/README
bin/pg_test_fsync
@@ -164,9 +164,9 @@ share/postgresql/extension/tsearch2.control
share/postgresql/extension/unaccent--1.0.sql
share/postgresql/extension/unaccent--unpackaged--1.0.sql
share/postgresql/extension/unaccent.control
-share/postgresql/extension/uuid-ossp--1.0.sql
-share/postgresql/extension/uuid-ossp--unpackaged--1.0.sql
-share/postgresql/extension/uuid-ossp.control
+%%OSSP%%share/postgresql/extension/uuid-ossp--1.0.sql
+%%OSSP%%share/postgresql/extension/uuid-ossp--unpackaged--1.0.sql
+%%OSSP%%share/postgresql/extension/uuid-ossp.control
share/postgresql/extension/xml2--1.0.sql
share/postgresql/extension/xml2--unpackaged--1.0.sql
share/postgresql/extension/xml2.control
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 4783cf7c7fa5..7148c75aaf49 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -121,6 +121,14 @@ LIB_DEPENDS+= icudata.48:${PORTSDIR}/devel/icu
. endif
.endif # !SLAVE_ONLY
+.if defined(WITH_OSSP_UUID)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid
+CONFIGURE_ARGS+=--with-ossp-uuid
+PLIST_SUB+= OSSP=""
+.else
+PLIST_SUB+= OSSP="@comment "
+.endif
+
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
diff --git a/databases/postgresql92-server/pkg-plist-contrib b/databases/postgresql92-server/pkg-plist-contrib
index b616652ad171..25a7ad8cc1cf 100644
--- a/databases/postgresql92-server/pkg-plist-contrib
+++ b/databases/postgresql92-server/pkg-plist-contrib
@@ -43,7 +43,7 @@ lib/postgresql/test_parser.so
lib/postgresql/timetravel.so
lib/postgresql/tsearch2.so
lib/postgresql/unaccent.so
-lib/postgresql/uuid-ossp.so
+%%OSSP%%lib/postgresql/uuid-ossp.so
%%DOCSDIR%%/README-contrib
%%DOCSDIR%%/extension/README
bin/pg_test_fsync
@@ -164,9 +164,9 @@ share/postgresql/extension/tsearch2.control
share/postgresql/extension/unaccent--1.0.sql
share/postgresql/extension/unaccent--unpackaged--1.0.sql
share/postgresql/extension/unaccent.control
-share/postgresql/extension/uuid-ossp--1.0.sql
-share/postgresql/extension/uuid-ossp--unpackaged--1.0.sql
-share/postgresql/extension/uuid-ossp.control
+%%OSSP%%share/postgresql/extension/uuid-ossp--1.0.sql
+%%OSSP%%share/postgresql/extension/uuid-ossp--unpackaged--1.0.sql
+%%OSSP%%share/postgresql/extension/uuid-ossp.control
share/postgresql/extension/xml2--1.0.sql
share/postgresql/extension/xml2--unpackaged--1.0.sql
share/postgresql/extension/xml2.control