aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2017-01-05 09:45:39 +0800
committermandree <mandree@FreeBSD.org>2017-01-05 09:45:39 +0800
commita384bfa6b00ba1e87b774e17e940cd63750be28b (patch)
tree3edb444f84748adaf823d8f98ba763fec6a83519
parent71c63616e2c5b5cb1d41ab2f6524f686a8a2161e (diff)
downloadfreebsd-ports-gnome-a384bfa6b00ba1e87b774e17e940cd63750be28b.tar.gz
freebsd-ports-gnome-a384bfa6b00ba1e87b774e17e940cd63750be28b.tar.zst
freebsd-ports-gnome-a384bfa6b00ba1e87b774e17e940cd63750be28b.zip
Upgrade CPU flags to use SSE2 by default on i386.
Reported by: Ingo Weyrich
-rw-r--r--graphics/rawtherapee/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index dd7f8a10315b..01fb2b193d66 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rawtherapee
PORTVERSION= 4.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= http://rawtherapee.com/shared/source/
@@ -53,7 +53,7 @@ RTDIR= ${PREFIX}/libdata/${PORTNAME}
OPTIONS_DEFINE= OPTIMIZED_CFLAGS OPENMP
OPTIONS_DEFAULT= OPTIMIZED_CFLAGS OPENMP
OPENMP_DESC= Enable multicore processing using OpenMP
-OPTIMIZED_CFLAGS_DESC= Use extra compiler optimizations (requires SSE support)
+OPTIMIZED_CFLAGS_DESC= Use extra compiler optimizations (requires SSE2 support)
OPENMP_CMAKE_BOOL= OPTION_OMP
@@ -64,9 +64,9 @@ OPENMP_CMAKE_BOOL= OPTION_OMP
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -fexpensive-optimizations \
- -funroll-loops -msse
+ -funroll-loops -msse2
CXXFLAGS+= -O3 \
- -funroll-loops -msse
+ -funroll-loops -msse2
.endif
.endif