aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2010-10-10 00:33:31 +0800
committersunpoet <sunpoet@FreeBSD.org>2010-10-10 00:33:31 +0800
commita49f29b9d15976a56f1eb016a9d256ce971a80a6 (patch)
treeaa42b0517c97497ed05332b78220faa20dc85989
parent9148226e646721b8389e8a3cb70f4d5e983f91ad (diff)
downloadfreebsd-ports-gnome-a49f29b9d15976a56f1eb016a9d256ce971a80a6.tar.gz
freebsd-ports-gnome-a49f29b9d15976a56f1eb016a9d256ce971a80a6.tar.zst
freebsd-ports-gnome-a49f29b9d15976a56f1eb016a9d256ce971a80a6.zip
- Add NOPORTDOCS handling (reported by QAT@)
- Respect PREFIX - Use DOCSDIR PR: ports/151334 Submitted by: sunpoet (myself) Approved by: Chris Howey <howeyc at gmail.com> (maintainer), pgollucci (mentor, implicit)
-rw-r--r--sysutils/parallel/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/sysutils/parallel/Makefile b/sysutils/parallel/Makefile
index 5078e3ad694d..11f49d41d53b 100644
--- a/sysutils/parallel/Makefile
+++ b/sysutils/parallel/Makefile
@@ -15,19 +15,18 @@ COMMENT= GNU parallel is a shell tool for executing jobs in parallel
CONFLICTS= moreutils-[0-9]*
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --datarootdir="${PREFIX}"\
- --docdir="${PREFIX}/share/doc/${PORTNAME}"
-
-MAN1= parallel.1 sem.1 sql.1
-MANCOMPRESSED= no
+CONFIGURE_ARGS= --docdir="${DOCSDIR}"
+GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_PERL5= yes
+MAN1= parallel.1 sem.1 sql.1
+PLIST_FILES= bin/parallel bin/sem bin/sql
PORTDOCS= parallel.html sem.html sql.html
-PLIST_FILES= bin/parallel \
- bin/sem \
- bin/sql
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-docDATA||' ${WRKSRC}/src/Makefile.in
+.endif
.include <bsd.port.mk>