aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-07-14 15:42:04 +0800
committerrafan <rafan@FreeBSD.org>2008-07-14 15:42:04 +0800
commita6a91cb8059a142903bbbaed3fe08cb359bf799a (patch)
tree31e07f848ea8bcb448d75931942ecf2ba4ab360a
parent0e06dec4bb2bafc9c7e38ed3ff1d3d5e79937190 (diff)
downloadfreebsd-ports-gnome-a6a91cb8059a142903bbbaed3fe08cb359bf799a.tar.gz
freebsd-ports-gnome-a6a91cb8059a142903bbbaed3fe08cb359bf799a.tar.zst
freebsd-ports-gnome-a6a91cb8059a142903bbbaed3fe08cb359bf799a.zip
- Fix build and install when CONFIGURE_TARGET is prepended to executable files [1]
- Add missing dependency on glib2 [2] - gettext is required by configure unconditionally, so remove WITHOUT_NLS [3] PR: ports/125509 Reported by: Carsten Jonstrup <carsten.jonstrup at gmail.com> and Alastair Watts <awatts at pett.com.au> [1], Alastair Watts <awatts at pett.com.au> [2], rafan [3] Submitted by: Guido Falsi <mad at madpilot.net> (maintainer) Approved by: Guido Falsi <mad at madpilot.net> (maintainer)
-rw-r--r--comms/gnokii/Makefile15
-rw-r--r--comms/gnokii/pkg-plist26
2 files changed, 18 insertions, 23 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index b49114f7d5fb..983e8cb3768f 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnokii
PORTVERSION= 0.6.26
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML
USE_GMAKE= yes
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE} --enable-security \
@@ -31,6 +32,7 @@ CONFIGURE_ENV+= MSGFMT="${LOCALBASE}/bin/msgfmt" \
CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include -fPIC" \
LIBS="-L../common -L${LOCALBASE}/lib" \
PKG_CONFIG="${LOCALBASE}/bin/pkg-config"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PKGDEINSTALL= ${PKGINSTALL}
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -92,6 +94,7 @@ CONFIGURE_ARGS+= --disable-smsd
.else
PLIST_SUB+= SMSD=''
MAN8+= smsd.8
+USE_GNOME+= glib20
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so) && !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
PLIST_SUB+= MSM=''
@@ -113,21 +116,13 @@ CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11='@comment '
.else
USE_XORG= xpm
-USE_GNOME+= gtk20 libgnome
+USE_GNOME+= glib20 gtk20 libgnome
PLIST_SUB+= X11=''
.if !defined(NOPORTDOCS)
MAN1+= xgnokii.1
.endif
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
pre-fetch:
.if !defined(WITH_SMSD)
@${ECHO}
diff --git a/comms/gnokii/pkg-plist b/comms/gnokii/pkg-plist
index 20e13ba11b9a..f6ba56ac4ed1 100644
--- a/comms/gnokii/pkg-plist
+++ b/comms/gnokii/pkg-plist
@@ -26,19 +26,19 @@ libdata/pkgconfig/xgnokii.pc
sbin/gnokiid
sbin/mgnokiidev
%%SMSD%%sbin/smsd
-%%NLS%%share/locale/cs/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/de/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/et/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/it/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/pt/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/sl/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/gnokii.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnokii.mo
+share/locale/cs/LC_MESSAGES/gnokii.mo
+share/locale/de/LC_MESSAGES/gnokii.mo
+share/locale/et/LC_MESSAGES/gnokii.mo
+share/locale/fi/LC_MESSAGES/gnokii.mo
+share/locale/fr/LC_MESSAGES/gnokii.mo
+share/locale/it/LC_MESSAGES/gnokii.mo
+share/locale/nl/LC_MESSAGES/gnokii.mo
+share/locale/pl/LC_MESSAGES/gnokii.mo
+share/locale/pt/LC_MESSAGES/gnokii.mo
+share/locale/sk/LC_MESSAGES/gnokii.mo
+share/locale/sl/LC_MESSAGES/gnokii.mo
+share/locale/sv/LC_MESSAGES/gnokii.mo
+share/locale/zh_CN/LC_MESSAGES/gnokii.mo
%%SMSD%%share/smsd/README
%%SMSD%%share/smsd/action
%%SMSD%%lib/smsd/libsmsd_file.a