aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2018-08-15 00:35:34 +0800
committernivit <nivit@FreeBSD.org>2018-08-15 00:35:34 +0800
commita6dca86cacb7bc0d818a0ebef3ff634398f4e5ee (patch)
treeb87543566d274d71706a7d2a293e7b18e99dba6c
parent056f6eef01b53ccd49312dded6b36ec50e48991d (diff)
downloadfreebsd-ports-gnome-a6dca86cacb7bc0d818a0ebef3ff634398f4e5ee.tar.gz
freebsd-ports-gnome-a6dca86cacb7bc0d818a0ebef3ff634398f4e5ee.tar.zst
freebsd-ports-gnome-a6dca86cacb7bc0d818a0ebef3ff634398f4e5ee.zip
- Update to 1.8.2
- Update URL in pkg-descr to avoid a redirection - Add a patch and a post-extract-* target to fix a couple of Sphinx exceptions during the build process: 1) WARNING: autodoc: failed to import module u'webob.client'; the following exception was raised: Traceback (most recent call last): File "/usr/local/lib/python2.7/site-packages/sphinx/ext/autodoc.py", line 658, in import_object __import__(self.modname) ImportError: No module named webob.client 2) Exception occurred: File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 774, in resolve raise DistributionNotFound(req, requirers) DistributionNotFound: The 'webob' distribution was not found and is required by the application The full traceback has been saved in /tmp/sphinx-err-Kjn2DB.log, if you want to report the issue to the developers. Please also report this if it was a user error, so that a better error message can be provided next time. A bug report can be filed in the tracker at <https://github.com/sphinx-doc/sphinx/issues>. Thanks! *** Error code 1 Changes: https://docs.pylonsproject.org/projects/webob/en/stable/changes.html
-rw-r--r--www/py-webob/Makefile6
-rw-r--r--www/py-webob/distinfo6
-rw-r--r--www/py-webob/files/patch-docs_conf.py11
-rw-r--r--www/py-webob/pkg-descr2
4 files changed, 20 insertions, 5 deletions
diff --git a/www/py-webob/Makefile b/www/py-webob/Makefile
index 3d0c9c9857a4..6d2057a1ebe2 100644
--- a/www/py-webob/Makefile
+++ b/www/py-webob/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= webob
-PORTVERSION= 1.7.4
+PORTVERSION= 1.8.2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -29,6 +29,10 @@ NO_ARCH= yes
USES= python
USE_PYTHON= distutils autoplist
+post-extract-DOCS-on:
+ @(cd ${WRKSRC} && \
+ ${LN} -s src/WebOb.egg-info .)
+
post-install-DOCS-on:
@(cd ${WRKSRC}/build/sphinx/html && \
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -name objectiv.inv")
diff --git a/www/py-webob/distinfo b/www/py-webob/distinfo
index f0f44e33ae6f..c1c482d1dafc 100644
--- a/www/py-webob/distinfo
+++ b/www/py-webob/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1521342831
-SHA256 (WebOb-1.7.4.tar.gz) = 8d10af182fda4b92193113ee1edeb687ab9dc44336b37d6804e413f0240d40d9
-SIZE (WebOb-1.7.4.tar.gz) = 219331
+TIMESTAMP = 1534263360
+SHA256 (WebOb-1.8.2.tar.gz) = 1fe722f2ab857685fc96edec567dc40b1875b21219b3b348e58cd8c4d5ea7df3
+SIZE (WebOb-1.8.2.tar.gz) = 271737
diff --git a/www/py-webob/files/patch-docs_conf.py b/www/py-webob/files/patch-docs_conf.py
new file mode 100644
index 000000000000..7cfd121ed0af
--- /dev/null
+++ b/www/py-webob/files/patch-docs_conf.py
@@ -0,0 +1,11 @@
+--- docs/conf.py.orig 2018-04-18 12:16:19 UTC
++++ docs/conf.py
+@@ -3,6 +3,8 @@ import sys
+ import os
+ import shlex
+
++sys.path.insert(0, os.path.abspath('../src'))
++
+ extensions = [
+ 'sphinx.ext.autodoc',
+ 'sphinx.ext.intersphinx',
diff --git a/www/py-webob/pkg-descr b/www/py-webob/pkg-descr
index 812fb0ba677a..98b823758dea 100644
--- a/www/py-webob/pkg-descr
+++ b/www/py-webob/pkg-descr
@@ -5,4 +5,4 @@ The objects map much of the specified behavior of HTTP, including
header parsing and accessors for other standard parts of the
environment.
-WWW: http://webob.org/
+WWW: https://webob.org/